Skip to main content
Topic: unrecoverable playback error: Class not registered (0x80040154) (Read 170 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

unrecoverable playback error: Class not registered (0x80040154)

I had problems with a Realtek audio driver so uninstalled and pared back to the Win10 MSoft generic driver.  I then installed the latest Realtek driver from the Microsoft Update Catalog (MUC).  All working, no problems, sounds good.  I then installed the latest Realtek driver from an ASUS support site (this a later version than the MUC).  With this driver, which includes additional components from A-Volute/Nahimic, I get no sound from any source and Foobar gives a message... "unrecoverable playback error: Class not registered (0x80040154)".  Either this driver pack comes complete with a problem or the uninstall (back to the Win10 MSoft generic driver) has resulted in a Registry problem.  Any guidance on how to identify the "class" which is not registered would be greatly appreciated.

Re: unrecoverable playback error: Class not registered (0x80040154)

Reply #1
Fixed.  Removed Realtek driver and went back to downloading the base ASUS Audio Driver package from the ASUS MB support site then applied the latest update from ASUS support.

Re: unrecoverable playback error: Class not registered (0x80040154)

Reply #2
Missing CLSID, probably means a filter was expected or configured, but it was removed from the system, or renamed to a different GUID. If the error actually exposed what CLSID was missing, you could search the registry for references to it and clean that up, but probably not worth it.

 
SimplePortal 1.0.0 RC1 © 2008-2020