Skip to main content
Topic: I was really confused with this inverse phase problem (Read 596 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

I was really confused with this inverse phase problem

When I tried to fix an inverse phase problem, I found a strange thing and I was totally confused....
The original audio playback OK on mobile phone while using speaker (mono channel), but the transcoded audio was mute or only some little noise. Both of them playback OK while using earphone (2 channels)
I knew mobile phone speaker is mono channel and inverse phase audio would be NG after DMIX and playback through speaker. But the original audio also was an inverse phase audio,  why it was OK on speaker?

Could you please give any help for this problem? Thanks a lot!

ps:
The original and transcode audio format is AAC, and I decoded them into wave format.
original audio: panxian-origin.wav
transcoded audio: panxian-trans.wav
(Note: Not all mobile phone had this problem, but it was NG on my iphone 6s)

Re: I was really confused with this inverse phase problem

Reply #1
Quote
why it was OK on speaker?
It's s single speaker?   It's probably connected to only one channel so the left & right don't cancel.

Re: I was really confused with this inverse phase problem

Reply #2
Quote
why it was OK on speaker?
It's s single speaker?   It's probably connected to only one channel so the left & right don't cancel.

Yes, it is single speaker on mobile phone. I'm confused why original file can playback OK on speaker, but transcode one failed.

Re: I was really confused with this inverse phase problem

Reply #3
More over, at the first, I thought it was AAC encoder problem, but after decoded to WAV, I found this problem still existed in WAV files, that should be a phase problem.

Re: I was really confused with this inverse phase problem

Reply #4
Try playing this.  I created this more for testing new CD drives (channel swap bug on bad drives) but it's also useful for testing other kinds of things as well.  You should hear both the left and right in this test, if you do then your device is doing something DSP-wise to prevent cancellation of out of phase left and right sounds.  If you only hear one but not the other, there's probably a fault somewhere in the phone be it software or hardware.

Re: I was really confused with this inverse phase problem

Reply #5
Try playing this.  You should hear both the left and right in this test

Thanks a lot, I played it on my phone, I could hear both left and right on speaker.

Re: I was really confused with this inverse phase problem

Reply #6
More over, at the first, I thought it was AAC encoder problem, but after decoded to WAV, I found this problem still existed in WAV files, that should be a phase problem.
Why would you expect decoding to fix any issue? If it did, then it'd also do it when you simply play that file.
some ANC'd headphones + AutoEq-based impulse + Meier Crossfeed (30%)

Re: I was really confused with this inverse phase problem

Reply #7
Quote
that should be a phase problem.
You can fix that by killing one channel and making a mono file or by inverting one channel.    (Audacity can do that if you don't already have an audio editor.)      

A mono file will play out of both speakers and it will be smaller uncompressed and since both channels are identical (after flipping the polarity of one channel) it's not "true stereo" anyway.

Re: I was really confused with this inverse phase problem

Reply #8
You can fix that by killing one channel and making a mono file or by inverting one channel. 

Thanks a lot, I can fix it by inversing one channel phase.
But what I really confused is that both are inverse phase audios, why original one is OK via speaker, trancoded one is NG?  It is hard to explain this phenomenon to my partner.

Re: I was really confused with this inverse phase problem

Reply #9
Why would you expect decoding to fix any issue? If it did, then it'd also do it when you simply play that file.

Decoding cannot fix this problem, I just wondering whether AACEncoder might change some audio phase, that may be the reason of this problem, for example "Intensity Stereo Coding" module in AACEnc or others.

Re: I was really confused with this inverse phase problem

Reply #10
Decoding cannot fix this problem, I just wondering whether AACEncoder might change some audio phase, that may be the reason of this problem, for example "Intensity Stereo Coding" module in AACEnc or others.

Actually what happens in lossy codecs is that if something is either completely in phase or out of phase, the codec will simply encode it as such.  If you take the volume of the left or right channel and lower or raise it very slightly or add noise, the codec might spit out artifacts that aren't noticeable in either the mid channel (L+R) or side channel (L-R) under normal stereo conditions.  Because most music is often mixed with the vocal and drums in the center or near the center, this usually appears in the side channel.  With the material you have there, you actually might notice some artifacts when the left and right is summed together instead of subtracted.  Unless there is something wrong with the encoder being used for a specific codec whatever you try to encode with it shouldn't be flipped around with regards to phase, it's not how lossy codecs work.

Re: I was really confused with this inverse phase problem

Reply #11
Unless there is something wrong with the encoder being used for a specific codec whatever you try to encode with it shouldn't be flipped around with regards to phase, it's not how lossy codecs work.

Although I am still confused, I think you are right, that encoder shouldn't introduce a severe phase distortion to the audio. Thanks a lot.

 
SimplePortal 1.0.0 RC1 © 2008-2020