Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: Converting with FFMPEG, parallel, and allowing huge files (Read 707 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Converting with FFMPEG, parallel, and allowing huge files

I tried @DaemonFC 's solution (Topic: Is there an easy way to do FLAC<>WavPack on Linux?) to batch convert flac files to wavpack and that works well, so thank you for that! However, I need wavpack files that have the --allow-huge-tags option.  Is there any way to pass that encoder option to ffmpeg?  I know I can just do a wavpack --allow-huge-files [...] on the files after the fact, but that's extra processing.

Secondly, when using the --bar option with parallel, if I don't pass --loglevel info (the default) to ffmpeg it seems to hang on me. As well I get a lot of extra, well, info that i don't want. I don't assume there is a way to get ffmpeg to go quiet and get a progress from parallel? It almost seems that parallel is reading it's progress based on the ffmpeg output, which doesn't make any sense to me.
Music lover and recovering high end audiophile

Re: Converting with FFMPEG, parallel, and allowing huge files

Reply #1
I tried @DaemonFC 's solution (Topic: Is there an easy way to do FLAC<>WavPack on Linux?) to batch convert flac files to wavpack and that works well, so thank you for that! However, I need wavpack files that have the --allow-huge-tags option.  Is there any way to pass that encoder option to ffmpeg?  I know I can just do a wavpack --allow-huge-files [...] on the files after the fact, but that's extra processing.
The --allow-huge-tags option is not really a characteristic of WavPack files per se, so it's not something that can be set or unset. It's just a one time flag saying it's okay to create or edit a tag right now that contains more than 1 MB of data.

I experimented (and searched a little online) and figured out that FFmpeg cannot put cover art on WavPack files at all, so that option is a little meaningless with FFmpeg. So you'll need to append the cover art with the wvtag command-line (using --allow-huge-tags if the files are big) or use Foobar2000 perhaps (not sure what size limitations it forces).

As for the second part of your question, I really don't have any experience with using FFmpeg in scripts. Sorry!

Re: Converting with FFMPEG, parallel, and allowing huge files

Reply #2
Secondly, when using the --bar option with parallel, if I don't pass --loglevel info (the default) to ffmpeg it seems to hang on me. As well I get a lot of extra, well, info that i don't want. I don't assume there is a way to get ffmpeg to go quiet and get a progress from parallel? It almost seems that parallel is reading it's progress based on the ffmpeg output, which doesn't make any sense to me.
Add something like
Code: [Select]
-nostats -loglevel 0
to ffmpeg cli. Also looking at some scripts I seem to have this at the ffmpeg end
Code: [Select]
</dev/null 
# </dev/null is some sort of null input, so that script will work when in bg as well
PANIC: CPU 1: Cache Error (unrecoverable - dcache data) Eframe = 0x90000000208cf3b8
NOTICE - cpu 0 didn't dump TLB, may be hung

Re: Converting with FFMPEG, parallel, and allowing huge files

Reply #3
Thank  you both @smok3  and @bryant.  That was both informative and very helpful. I appreciate it! I have beets handling the cover art so I'm all set for that. 

I'll play with the loglevel, but again, messing with that seemed to make 'progress' hang.  I bet the redirect to /dev/null will do it.
Music lover and recovering high end audiophile

 
SimplePortal 1.0.0 RC1 © 2008-2020