Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: Newbie - Foobar2000 will not list album  (Read 342 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Newbie - Foobar2000 will not list album

Hi all,  I'm new to foobar and I'm still feeling my way along. I'm having a problem with one particular album. I customized the foobar interface a bit so that the panels list the Genre, Artist, Duration, Date, Album and Art in the top panels and the list of playing files in the lower window.  I created a directory call Music and each album is a subfile under it. It's all working fine except that Foobar refuses to list one album. I've checked the tags and they look the same as the other files. I've checked the file names and removed all but the number and letter characters. I've moved the files to a separate directory and and moved it back using foobar's file operations. I've rescanned the directory which contains my music files. And I've checked the directory containing the album to make sure it's not hidden. It just won't show up in the panel.
I can open the files in the album by using Add File and then go to the sub-directory and then the files and they play fine. I can even get the art to show up in the panel if I do this. But the album doesn't show up in the Genre, Artist, Duration, etc. columns no matter what I do.
What am I missing??  Any help is greatly appreciated. Jim
I have absolutely no idea what I'm doing . . . . . .

Re: Newbie - Foobar2000 will not list album

Reply #1
Hi there,

Since foobar can have many configurations, it would help to know which components and UI you are using. Can you please post a screenshot of your layout? (You can attach files to your post on these forums)

Most likely albums not showing up is tag related - either other programs writing tags incorrectly, or tags missing that are required by the view pattern (a Facets issue specifically)

Cheers

Re: Newbie - Foobar2000 will not list album

Reply #2
. . . Can you please post a screenshot of your layout? (You can attach files to your post on these forums)
Most likely albums not showing up is tag related - . . .  (a Facets issue specifically)

I suspect a tag issue too, but I can't find the problem. Here's a shot of the layout and the tags:
I have absolutely no idea what I'm doing . . . . . .

Re: Newbie - Foobar2000 will not list album

Reply #3
Oh, and here's a shot of the preferences:

BTW, thanks for the reply. Jim
I have absolutely no idea what I'm doing . . . . . .

Re: Newbie - Foobar2000 will not list album

Reply #4
Oh, and here's a shot of the preferences:
He probably does not need to see the Album List preferences, it appears album list is not part of your layout. A screen shot of the preferences directly above, "Media Library" - plus another two for "Facets" and Facets/Filters" might help point to a legacy exclusion causing your display problem.
A foobar enthusiast who's neither an audiophile, nor an album snob.

Ever notice whenever there is a thread mentioning track ratings, someone will inevitably come in to post that they don't use ratings or believe in rating music?

Re: Newbie - Foobar2000 will not list album

Reply #5
Thanks again for the replies. I've played around with the facets a bit and removed the brackets. Now I'm getting the album to show and Date has a "?" in the field, so it appears that a tag is the problem.  I'm trying to figure out how the columns are linked and how it all works with the filters and facets.  So far I've figured out brackets in the pattern definitions of the facet-columns will link those columns and any missing info means nothing in either is shown in the layout. Is the same true with Album List View? Are the definitions in the View panel linked if they are bracketed?

For example: In Preferences: Album: View: By Album  I have "%album%[ '['%album artist%']']|[[%discnumber%.]%tracknumber%. ][%track artist% - ]%title%" (without quotes). Does that mean "album artist" and "discnumber" are linked and if either is missing nothing shows up?

Here are a couple of screen shots. You might notice that I've already removed some of the brackets:
I have absolutely no idea what I'm doing . . . . . .

 

Re: Newbie - Foobar2000 will not list album

Reply #6
[...] So far I've figured out brackets in the pattern definitions of the facet-columns will link those columns and any missing info means nothing in either is shown in the layout. Is the same true with Album List View? Are the definitions in the View panel linked if they are bracketed?
No, this is just a Facets quirk in the way it follows title formatting. (And "linked" is just my way of explaining it - only applies when Facets is showing 'Multiple Columns' (not including 'Statistics') in one pane. Even ten years later Facets has unique features that take a little consideration. Square brackets in title formatting simply hide the field when it is empty. So when showing 'Multiple Columns', and one field is empty, Facets follows the rules, although confusingly by hiding both fields, seeing they are "linked" together in one pane)

Incidentally, it might be better to have Date column together in the Album pane, rather than Artist pane. Otherwise you get repeated artist entires.

In any case, if your album is showing "?" for Date it means the field is empty / missing, or foobar is not reading the same tag as your other tagging program has set. In foobar, right-click album or track(s) > Properties to review tags. You could try right-click Date field > Remove, then re-type the date and Apply, maybe that will fix it.

Cheers

 
SimplePortal 1.0.0 RC1 © 2008-2020