Skip to main content
Topic: foobar2000 v151: Update check failure: Network authentication error (80090326) (Read 3339 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #25
I have the same problem.  Foobar 1.5.2 and  Windows 7_64 SP1 Home Premium
When I click "check for new foobar2000 versions" or "check for updated components" I get "Update check failure: Network authentication error (80090326)"

That's what i did:
Windows update kb3140245-x64 was installed
MicrosoftEasyFix51044 was applied
TLS_1.2.reg file (from Reply #3) with rebooting
but all without success
In the registry it looks like this now:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp
DefaultSecureProtocols DWORD 0x00000a00 (2560)

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
SecureProtocols DWORD 0x00000a80 (2688)

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client
DisabledByDefault DWORD 0 (0)

Please help who knows the solution

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #26
Install a supported version of Windows. I’d rather recommend that than anything else.

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #27
Version 1.5.1 seems to be behaving oddly for me. Updating components works fine, but when checking for new fb2k versions the progress window opens and immediately closes. There's no error message. I installed it as a portable version for checking. I didn't happen across a similar problem with my main fb2k install before upgrading to 1.5.2.

Ignore the above. 1.5.1 was opening a new browser tab when checking for an updated fb2k version and I didn't notice. Idiot of the day award goes to me.
1.5.1 is updating normally.

Version 1.5.2 is checking for component updates and new fb2k versions normally.

I'm running XP.

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #28
Don't get too cocky. If it's not capable of doing TLS 1.2, what else do you think it'll be doing instead? I'll leave you to mull that one over for a moment.

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #29
It's always opened a browser, or browser tab, to download the installer when there's a new fb2k version, hasn't it? I forgot to check because the browser didn't steal focus.

Don't get too cocky. If it's not capable of doing TLS 1.2, what else do you think it'll be doing instead? I'll leave you to mull that one over for a moment.

Are you wanting me to mull over fb2k successfully checking for component updates and downloading and installing them automatically, or is there some other mulling I should be doing? :)

I did have a Network authentication error (80090328) issue a year or so ago, but Peter fixed it.
https://hydrogenaud.io/index.php?topic=116601.0

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #30
Well, yes, it has. It also has to use the same API to update components. Thankfully, they're hashed and signed by the server, so you don't have to worry about them being transmitted in cleartext, like they always were before we rolled out TLS support. Maybe we should make Windows 7 do cleartext update interface as well, to make things easier for more people who are apparently otherwise prevented from installing Windows 10.

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #31
Refinement to replay #25
Immediately after installing Foobar 1.5.2 portable (into an empty folder), function "Chesk for updated components" works without error with message "No updatable components present".
Error 80090326 occurs after installing any additional component, for example foo_dsp_xgeq, and then checking for component updates.
"Check for new Foobar versions" works with error in any case.

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #32
What are your settings in Prefs/Networking?  You may be dealing with some proxy issue and/or Windows permissions.  I run Foobar 1.5.2 portable out of C:\Foobar, and never had any updating issues after applying Case's patch.  I am using Windows 7 SP1 32-bit, and I do not use UAC.

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #33
Prefs/Networking = No proxy
UAC disabled
Foobar 1.3.2 works with such settings, and versions 1.4.0, 1.4.8 and 1.5.2 give an error

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #34
1.4.0 was the first to start enforcing HTTPS. You're welcome to keep using 1.3.2 forever, I guess. But most of my components won't serve updates to you, even if they do work with 1.3.

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #35
I can use the latest available version (now it's 1.5.2) and update manually. At the same time version 1.3.2 portable can be used to check for updates.
Сan't find anything better.

Re: foobar2000 v151: Update check failure: Network authentication error (80090326)

Reply #36
Windows 7 doesn't support TLS 1.2 by default which seems to now be required by the server. You can enable the feature by importing the attached reg file and rebooting.

Awesome, thx for the help, worked like a charm (Windows 7)

 
SimplePortal 1.0.0 RC1 © 2008-2020