Skip to main content
Topic: foo_vst - Electri-Q crashes or will not play using VST 2.4 (Read 280 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_vst - Electri-Q crashes or will not play using VST 2.4

Hello,

I try to run Electri-Q 1.8.8 Equalizer using VST 2.4 (0.9.0.3 , foo_vst) .
In an other forum the combination of this VST-Adapter and Electri-Q runs successfully.
Is it allowed to post threads of other forums here ?

I have configured Electri-Q as an active DSP in DSP manager.
When I try to visualize this plugin while playing a song foobar 1.5.1 completly crashes with this Error Report :

Illegal operation:
Code: C0000005h, flags: 00000000h, address: 072FE550h
Access violation, operation: read, address: 05CC0000h
Call path:
playback_process entry=>dsp/run=>dsp_manager::run=>dsp::run

When I stop the playing song then Electri-Q is visualizable but opening a song the playing aborts instantly without error. I press play and it makes stop.

Has somebody successfully run Electri-Q or has may has a sollution for this ?


Thanks, Andre

Re: foo_vst - Electri-Q crashes or will not play using VST 2.4

Reply #1
Andre:  development of foo_vst seems to have been discontinued, and the plugin is unfortunately well-known as being prone to crashes with all kinds of VST usage, not just with Electri-Q.  On the other hand, some seem to find one particular combination that works reliably.  My own experience was repeated crashes.  You may want to try foo_dsp_vstwrap (http://www.yohng.com/software/foobarvst.html) instead, although it too is prone to problems and cannot load more than one VST at a time (unless that one is a "chainer").  The hope of many here is that a Foobar native/integrated vst host will someday come to be (https://hydrogenaud.io/index.php/topic,117596.0.html) .

Re: foo_vst - Electri-Q crashes or will not play using VST 2.4

Reply #2
Thank you. With this vst wrapper I can now display the Electri-Q Equalizer without problems.

But now comes the next problem. The Electri-Q makes no effect on the output sound. When I increase the bass the output stays without. :(   The Bypass option is disabled.

My Component "George Yohng VST Wrapper" is grey not black. Can that be the problem ?

Re: foo_vst - Electri-Q crashes or will not play using VST 2.4

Reply #3
Hmm.  I do use the Yohng plugin for a single VST, the Acon EffectChainer, in which I have loaded a single limiter/compressor VST (Sonic Anomaly's "Unlimited").  In the Foobar components list the Yohng is NOT greyed out, but shown "black."  How did you install it?  By using the "Install" button from the component list pointed at foo_dsp_vstwrap.zip, or did you manually drop the extracted dll into a folder (which one)?  Try doing a right-click in the list and choose "Remove."  Then: the zip as downloaded from his site not only includes foo_vst_vstwrap.dll, but also his own limiter "George Yohng's W1 Limiter.dll"--delete the latter first, then try a re-install from the Components panel.  Or:  after removing the first try, exit Foobar and make a folder in foobar2000/user-components (NOT foobar2000/components) named "foo_dsp_vstwrap".  Then, extract only foo_dsp_vstwrap.dll from the zip into it, and restart Foobar.

Also:  in my Windows 7SP1 OS (no UAC enabled), the ini file used by the wrapper is actually created in C:\ProgramData as "GeorgeYohngVST.ini"--perhaps a Windows permissions issue on your system is preventing that ini file from being created there, which would in turn prevent any changes from taking effect?  That could well explain what you're seeing too.

The reason I had to use a single VST with a chainer instead of just loaded directly into the wrapper is that separately it caused "issues"--which is why I described that wrapper as having its own problems just like foo_vst.  Ah, if only we had a NATIVE host..

Re: foo_vst - Electri-Q crashes or will not play using VST 2.4

Reply #4
I have the zip file in which the foo_dsp_vstwrap.dll was located. That I put in the components directory. After that the component is listed gray in preferencers/components but it works :  The system try icon of the wrapper is present and I can select my Electri-Q VST Plugin there, but like I said without effect.

I tried to copy the dll into user-components\foo_dsp_vstwrap but then its not listed in components.
An installation from the components panel was bringing this component black :) ..I must rename the original zip name to foo_*.zip , then it was selectable and installaton was no problem.

But with that the Electri-Q has still no effect so I disabled the write lock of the ini file with no luck.

Oh my god :)

Re: foo_vst - Electri-Q crashes or will not play using VST 2.4

Reply #5
Hello,
I try to run Electri-Q 1.8.8 Equalizer using VST 2.4 (0.9.0.3 , foo_vst) .
In an other forum the combination of this VST-Adapter and Electri-Q runs successfully......

hey Andre0815, just happened to stumble on this old post in the foo_vst:VST 2.4 adapter thread in 3rd Party Plugins:
https://hydrogenaud.io/index.php?topic=84947.msg770523#msg770523

Note that poster mentions the Electri-Q 1.8.8 running fine in an older version of the plugin dated 1/8/2011; later the developer graciously reposted that version in a bundle with other older versions.  The one the OP mentions that works with Electri-Q is version 0.8.0.1, "foo_vst_0801.dll", and it's in the zipped package attached to the post here:
https://hydrogenaud.io/index.php?topic=84947.msg775788#msg775788

See if that one helps you out and let us know what happens!

Re: foo_vst - Electri-Q crashes or will not play using VST 2.4

Reply #6
Heho, really thanks for your investigations.
I have tried the foo_vst_801.dll by renaming it to foo_vst.dll, packeted into a foo_vst.zip and installed it in components.
Setting Electi-Q as active DSP produces crashing even at new startup of foobar.

 
SimplePortal 1.0.0 RC1 © 2008-2020