Skip to main content
Topic: Hisses and cracks when playing files on external DAC (Read 208 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Hisses and cracks when playing files on external DAC

Hello everyone,
Well, I don't know if this is a bug, but I experienced a scary thing and I'd like to know what you think of it.
I listen to FLAC and DSD files on a FiiO K3, using USB 2 mode, so using the provided driver. Once the driver is installed, the FiiO DAC cannot play files with sofware that does not recognise it. I have to unplug the DAC and revert to my Asus Xonar Essence STX and classic software like winamp.
With the DAC, to play DSD files, I installed the required components: DSD Processor and SACD decoder, along with ASIO and WASAPI.
I use ASIO and it works just fine. To play non DSD files with the DAC unplugged in Foobar, I deactivate DSD processor, which upsamples non DSD files for the DAC to play correctly.
Now, the problem: this works OK, but when I start to play a tune, there's always a "click" and "pop" in the audio. It does the same when scrolling in a tune. But today, when I clicked to go forward in a song, my brand new FiiO F9 Pro IEMs played noise at a high level that would have left me deaf if I had not stopped playing right away! The same as when listening to a digital stream not correctly played as if not supported!
Now, I'm not looking for a solution, I simply use another player to play songs without the DAC. I wouldn't risk destroying my IEMs and certainly not my ears, which are waaaay more valuable!
I think there's a latency problem when clicking away too fast with this setup, as if a buffer does not have time to fill between clicks or something like that.
Any opinion welcome from someone more knowledgeable than me!



 
SimplePortal 1.0.0 RC1 © 2008-2020