Skip to main content
Topic: Error during component installation (Read 355 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Error during component installation

A user is experiencing a weird error when trying to install fb2k component:
this is the error I get during the installation process:
"Could not load component "foo_spider_monkey_panel.fb2k-component": bad allocation"

I downloaded right now the Nightly buid from your GitHub project page: https://github.com/TheQwertiest/foo_spider_monkey_panel
using the link you provided for the nightly build:
link https://ci.appveyor.com/api/projects/theqwertiest/foo-spider-monkey-panel/artifacts/_result%2FWin32_Release%2Ffoo_spider_monkey_panel.fb2k-component?branch=master&job=Configuration%3A%20Release

Trying to install any previous version of the same component results in the same error.

I'm not sure if it's caused by my component or if it's a bug in fb2k.

@AndreaT, can you try installing/updating any other component and see if it works? And please, do *not* reinstall fb2k or at least save current fb2k configuration and/or folder, so that the bug could be reproduced again, diagnosed and fixed.

Re: Error during component installation

Reply #1
Hello @TheQwertiest , I already upated other components:
- Mathaudio Room EQ and Headphone EQ
- Super Audio CD player
NO problems with these components.
For the moment I am getting that installation error only when installing SMP component and, unfortunately, I am now getting this error also with the v1.2.2-preview that I am sure to have installed many times in between the 2 or 3 alfa versions you gave me for testing.
I will not reinstall FB and I remain fully available for collcting any info and for testing you may need.
Regards, Andrea

Re: Error during component installation

Reply #2
I can successfully install SMP 1.2.3, and probably also 1.2.2. The .fb2k-component appears to require about 32MB of RAM on top of whatever foobar2000 itself is currently using, to extract.

Re: Error during component installation

Reply #3
So probably AndreaT's foobar2000 is just out of RAM...

Re: Error during component installation

Reply #4
Hello @lvqcl and @kode54 , well... if so why I could update/upgrade the other components?
Today I will try removing some other components to make room and I will tempt the installation of SMP once more.

PS: Kindly note that on my system I already have SMP 1.2.3-beta installed and running, so there should be enough RAM space for its own replacement.

I will let you know about asap.
Regards, Andrea

Re: Error during component installation

Reply #5
Hello @TheQwertiest , today I found a way to install your nigtly build v1.2.3-beta.
To avoid the error, I had first to remove the Library Tree JS v 2.1.3 (I didn't removed the hosting SMP, just reset the configuration to the default empty page).
Then I restarted Foobar and, doing so, I was then able to install your new SMP component.
After this, I reinstalled again the Library Tree JS.
Regards, Andrea

Re: Error during component installation

Reply #6
No, see, the installation requires 32MB *on top* of whatever memory the app is already using when you go to install the component.

 
SimplePortal 1.0.0 RC1 © 2008-2019