Skip to main content
Topic: fb2k 1.5 beta 16 (and also beta 15) NOT working components updater  (Read 381 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

fb2k 1.5 beta 16 (and also beta 15) NOT working components updater

Hello Peter,
I am running Windows 7, 32bit edition, fully patched/updated daily.

I don't know before beta 15 because not tested, but starting from that one and still present in beta 16, the components updater does NOT work as expected.

Components updater lists what needing to be updated but does not download and install it as used to do.

Regards, Andrea

Re: fb2k 1.5 beta 16 (and also beta 15) NOT working components updater

Reply #1
Are you certain? There is a new feature of reporting updates for components that are listed in the component repository but aren't hosted there. Those require manual attention - you can open a browser to their info page with the Details button. Previously such components were ignored and unless you manually checked the repository or forum you didn't know they had updates.

Re: fb2k 1.5 beta 16 (and also beta 15) NOT working components updater

Reply #2
Hi there!
installed fb2k v1.5b16
installed CUI v1.2.0-rc.1
I click "Get updates" does not see updates to CUI v1.2.0
FYI

 

Re: fb2k 1.5 beta 16 (and also beta 15) NOT working components updater

Reply #3
The version check used by foobar2000 doesn't support that syntax. If CUI used v1.2.0 RC 1 or v1.2.0RC1 it would work properly. I did mention Peter about the detection issue before the last betas but he hasn't added support for musicmusic's versioning.

Re: fb2k 1.5 beta 16 (and also beta 15) NOT working components updater

Reply #4
Columns UI is hosted on a 3rd party site ( yuo.be ).  Does fb2k updater supports such components?

Re: fb2k 1.5 beta 16 (and also beta 15) NOT working components updater

Reply #5
In my case these were the components that were listed but not downloaded as instead it was in the past:
- Mathaudio room eq
- Monkey's audio decoder
- Spider Monkey Panel
just to least the 3 first I remember.

Regards,
Andrea

Re: fb2k 1.5 beta 16 (and also beta 15) NOT working components updater

Reply #6
Columns UI is hosted on a 3rd party site ( yuo.be ).  Does fb2k updater supports such components?
It does in the way I described.

It shows information about the update and has a Details button that opens this.

Re: fb2k 1.5 beta 16 (and also beta 15) NOT working components updater

Reply #7
In my case these were the components that were listed but not downloaded as instead it was in the past:
- Mathaudio room eq
- Monkey's audio decoder
- Spider Monkey Panel
Those components are not hosted on the component repository. With older foobar2000 version you would not see any updates to them. So unless they were there in the past and author has changed their mind, you have not been able to update them with native foobar stuff ever.


Re: fb2k 1.5 beta 16 (and also beta 15) NOT working components updater

Reply #9
Yes indeed. I probably mixed it to Spider Monkey in my head. But I also don't believe AndreaT had foo_input_monkey as undownloadable update. But it is easy for him to prove me wrong by showing a screenshot where it doesn't work.

Re: fb2k 1.5 beta 16 (and also beta 15) NOT working components updater

Reply #10
Hello Case and Rollin,
thanks for your support that made me understand the matter.

Regarding the component "Monkey's Audio Decoder", yes, it works, I made a mistake (I verified now installing and old version and then running the updater and it worked fine as expected).

Sorry for having made noise.
All the best
Regards, Andrea

 
SimplePortal 1.0.0 RC1 © 2008-2019