Skip to main content
Topic: Opus compression within Exact Audio Copy (EAC) is not working for me (Read 5364 times) previous topic - next topic
0 Members and 11 Guests are viewing this topic.

Opus compression within Exact Audio Copy (EAC) is not working for me

I'm totally failing at this, and I'm sure it's some bonehead error on my part (though the sparse documentation may have just a little bit to do with it.)

EAC v. 1.3 (the most recent version), does not have the opus encoder (opusenc.exe) built in. So I copied that file to the EAC directory.
On EAC's Compression Options screen (F11). I have checked the "Use external program..." box, selected "user defined encoder" from the pulldown, inserted ".ogg" as the file extension, entered the encoder file location including path, selected 128 from the bit rate pull-down, selected the high quality radio button, and left the remaining boxes unchecked except for "check the external program's return code."

When I click the "test encoder" button, it returns the opusenc all purpose error message, such as you get if you forget a required argument: it's the program's help message.

If I go ahead and try to rip-and-compress a track, I get a status box that says in part:
Reading Track
Normalizing
Copy OK
Compress Track by External Program
Audio Extraction Complete

I also get a popup that says:
The external compressor returned an error!
Options: [blank]
File: [name of the wav file ripped with full path]

My suspicion is that I need something in the "Additional command line options" box. Maybe EAC isn't passing the required input file name and output file name. (Opus doesn't presume that you want the same filename — with a different extension, of course — as I think it should.) But I experimented with a bunch of options, all to no avail.

I would especially appreciate hearing from someone who is running the opusenc converter within EAC to compare notes so I can see what I'm doing wrong.

Than you
Art in Northern Virginia


Re: Opus compression within Exact Audio Copy (EAC) is not working for me

Reply #1
Your suspicion that you need something in the "Additional command line options" box is correct.
https://wiki.hydrogenaud.io/index.php?title=EAC_Compression_Options
https://mf4.xiph.org/jenkins/view/opus/job/opus-tools/ws/man/opusenc.html
very simple example:
--bitrate 128 %source% %dest%
korth

Re: Opus compression within Exact Audio Copy (EAC) is not working for me

Reply #2
Super simple, once you know how! Thanks very much for the quick help.

Artman

 
SimplePortal 1.0.0 RC1 © 2008-2019