Skip to main content
Topic: Soundproblem in WASAPI-Mode (Read 315 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Soundproblem in WASAPI-Mode

Hello,

i have version 1.4.6 installed and i have set the output to WASAPI Event as default.

After booting my computer and starting foobar2000 i don't get any sound.

If i play a bit with the output setting, activate primary output for example , switch back to WASAPI, and/or start foobar2000 new then i hear a "plop" sound and it suddenly starts to work just fine in WASAPI mode, Regardless how often i close foobar2000.
That lasts until i restart my computer. Only at the first start of foobar2000 that problem occurs.

Any advises?

Re: Soundproblem in WASAPI-Mode

Reply #1
Even though event support has been a WHQL requirement for audio drivers since Vista or at the very least since Windows 7 some drivers have problems with them. I'd recommend trying push mode if event fails. That's why they are both exposed so users can pick the method that works best.

Could you please test if the WASAPI shared output component works for you after reboot instantly? That component uses event based output too so I'm curious if it suffers from the same problem.

Re: Soundproblem in WASAPI-Mode

Reply #2
Now i tried restarting several times. Strange behaviour is that now it works with WASAPI event..My computer is mainly used for music playback and i think the problem starts to happen when the machine was shut off a day or more.
I tried the WASAPI shared plugin. It works too, but i can hear windows system sounds as well.
I have WIN10 with latest updates installed. Also i keep all drivers up to date.

 

Re: Soundproblem in WASAPI-Mode

Reply #3
Hello,

even with the newest beta this problem still exists.

The strange thing is, it does not happen all the time, Just randomly.
Today i booted the machine, started foobar immediately and hit the play button: no sound output.
This time after just moving my mouse cursor over the loudspeaker icon in the task bar, the plop-sound came and it played just fine.
I have the latest Realtek driver from asus and installed all windows 10 updates. Also i keep my drivers up to date at all times.
This seems to be a minor problem..But it bothers me.
I feel totally ok with my internal soundcard and the optical output.
I hope the solution to this problem will not be to buy an internal pcie soundcard.
Is there a possibility to submit system logs, driver logs or whatever to that a developer can have a look at it:
If yes, which ones?
By the way, even or push mode have the same problem.
I know it is only a minor problem, but anyway..Ideas are welcome.

 
SimplePortal 1.0.0 RC1 © 2008-2019