Skip to main content
Topic: Cannot build ATL_helpers in VC 2019 (Read 618 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Cannot build ATL_helpers in VC 2019

I recently had to wipe my computer and reinstall everything from scratch. Now I've got a project which won't build due to a brand new error in ATL_helpers:

Error   C3668    'CDialogResizeHelper::ProcessWindowMessage': method with override specifier 'override' did not override any base class methods (compiling source file CDialogResizeHelper.cpp)   foobar2000_ATL_helpers   D:\Source\foobarSDK-1.4\foobar2000\ATLHelpers\CDialogResizeHelper.h   21   

The offending code line is:

Code: [Select]
	BEGIN_MSG_MAP_EX(CDialogResizeHelper)

but naturally there isn't a single "override" in the entire CDialogResizeHelper.h file. I'm also getting the same error in WTL-PP.h too. These files are completely unedited and I reinstalled the 1.4 SDK just to make sure. Still no joy.

I have a feeling this is due to some misconfiguration in VC2019, but for the life of me I can't figure out what it is. I've tried everything. This worked just fine before my reformat. It was also working fine in debug before I reinstalled the SDK and now I get the same error on debug configs too.

I'm using the latest VS2019 update, v142 build tools, latest Windows 10 SDK, and WTL 10.

Re: Cannot build ATL_helpers in VC 2019

Reply #1
Thanks for reporting, I will look into it.

Re: Cannot build ATL_helpers in VC 2019

Reply #2
You can try using older WTL for now, version 9.1 should work.

Re: Cannot build ATL_helpers in VC 2019

Reply #3
You can try using older WTL for now, version 9.1 should work.
That seems to have fixed it for now. I'm 90% sure I was using WTL10 before my reformat, so wonder if it's something related to the latest release of VC2019.

Re: Cannot build ATL_helpers in VC 2019

Reply #4
Fixed in SDK 2019-06-30.

Re: Cannot build ATL_helpers in VC 2019

Reply #5
Well I got everything working in WTL10 and using the latest SDK, but I basically had to rebuild my component's VC project settings from scratch and midway through I was running into the same override issue so I think there was a fair chance I was doing something wrong the whole time. No matter, it's working now.

 
SimplePortal 1.0.0 RC1 © 2008-2019