Skip to main content
Topic: Preferences: Playback [Not Saved] (Read 1688 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Preferences: Playback [Not Saved]

Hi

I have a rather annoying problem for which I cannot find a solution.

When I attempt to change and save the setting "Stop playback after the current track" to OFF / Unticked
All is well when I continue to play a playlist, but
when I close and re-open Foobar2000 (v1.4.4, Win8 64-bit, Portable Install)
The setting has reverted back to a ON / Ticked.

I repeat the process and the around we go again.

Any ideas?

Re: Preferences: Playback [Not Saved]

Reply #1
OK, so no ideas thus far...

Lest get pictorial

This is what the preferences look like when I close foobar



And sometimes (but not always) this is what the preferences look like when I open foobar



Regardless of the 2nd pick, the behaviour of Foobar (when re-opened) remains the same.
I untick the "stop playback" option - apply and the problem goes away.
I then open Foobar and the problem reappears.

I had hoped that an update would have fixed the problem but alas no,

So what can be done?

Thanks

Re: Preferences: Playback [Not Saved]

Reply #2
You have some component that turns the setting on. For example Playlist Attributes can be configured to do that.

Re: Preferences: Playback [Not Saved]

Reply #3
I thought I had checked that.

Here are the config & settings page:





Is there anywhere else I should look?

Re: Preferences: Playback [Not Saved]

Reply #4
Is there anywhere else I should look?
Yes. The "Stop after current" behaviour is controlled with playlist attributes only per playlist, not globally and is applied only, if playback is running. You need to check the "Playlist attributes" entry above the one you showed in your screen shot and check for the active playlist, if "Stop after current" is set to "Enabled".

Re: Preferences: Playback [Not Saved]

Reply #5
behaviour is controlled with playlist attributes only per playlist, not globally
This pattern appears to be re-occurring for the first playback every time I open Foobar regardless of which playlist I chose to play.

So I have taken a screen shot for a playlist specific (after a Foobar restart).



I did noting else except begin to play the playlist
And it stopped after the first track

I went to the preferences and here is what I found



Where to next?

Re: Preferences: Playback [Not Saved]

Reply #6
The behavior, which you describe, indicates, that indeed playlist attributes could be responsible for it. However, according to the shown settings, it should not be the case.

But there is another, quite specific situation, which could explain the described behaviour:
You start playback with a keyboard shortcut and you have assigned the same shortcut to "Stop after focused track". This function uses also stop after current and becomes effective, when the currently playing is the one for which this function was activated.

Re: Preferences: Playback [Not Saved]

Reply #7
I have never created a keyboard shortcut and from the looks of the preferences only the default remain.

I have decided to remove the " playlist attributes" component (sorry fbuser) from Foobar.
So far, so good a new playlist was selected (after restart) and the two tracks were played without stopping after the first

If the problem does not re-appear, I will re-install the component.

Re: Preferences: Playback [Not Saved]

Reply #8
As above, I have uninstalled the "playlist attributes" component
And the problem has re-appeared as per my 2nd post in this thread

So with reference to below:
But there is another, quite specific situation, which could explain the described behaviour:
You start playback with a keyboard shortcut and you have assigned the same shortcut to "Stop after focused track".
I have offered screenshots of the keyboard shortcuts of my Foobar.





Is there anything there to be of concern?

If not, where to next?

Re: Preferences: Playback [Not Saved]

Reply #9
Do you use menu Playback->Stop after current?

Re: Preferences: Playback [Not Saved]

Reply #10
Do you use menu Playback->Stop after current?
No!

As stated earlier in the thread, somehow Foobar automatically turns the setting on without my consent.
I switch the setting off
The setting is then somehow switched back on each time I restart Foobar

Re: Preferences: Playback [Not Saved]

Reply #11
Hi there,

I would try enabling both 'Stop playback after current track' and 'Reset the above when stopping' in Preferences. Then let it play a track and stop, it should reset / switch off 'Stop after current' option afterwards. Then try restarting foobar and see if it reappears. Perhaps there is a bug with the reset option being off.

It might also have something to do with 'Save playback state when closing foobar2000 and resume on next startup', I would try also switching that off for awhile and see if the problem reappears.

Cheers

Re: Preferences: Playback [Not Saved]

Reply #12
Tried it (see images below)


Before


After

The playback stopped after the first track

 
SimplePortal 1.0.0 RC1 © 2008-2019