Skip to main content
Topic: Foobar2000 does not remember being hidden in tray (did work in old version) (Read 549 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Foobar2000 does not remember being hidden in tray (did work in old version)

Hi, I just updated from v1.3.14 to current v1.4.4

After this update, it seems like the ability to remember the window state after closing and restarting foobar2000 again has changed.
It does still remember if it was minimized or not and will also restore size and position. So far, so good.
However, when I hide foobar2000 in the notification area, this will not be stored anymore. Closing foobar2000 while being hidden and then starting it again, will cause it to start in the foreground, which is not ideal. In the old version, this used to work as expected. Any chance to get this functionality back?

Reason, why I want this, is because I mainly use the plugin Deskband Controls to control playback. Thus, I almost never use the main program window and therefore don't want it to pop up when opening music files and also don't want it to use space in the taskbar when it starts minimized. Small icon in notification area is enough for the very rare case, I want to access the main program window.

Settings that are probably relevant:
-  "Default User Interface -> Window minimize and close" is set to "close hides".
-  "Playback -> Others -> Save playback state when closing foobar2000 and resume on next startup" is selected.

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #1
Maybe you should try the options in the figure below.

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #2
I noticed the same as xt48 when updating to v1.4.2 and I never had Deskband Controls installed.

I'm not 100% sure, but I think, I updated from a 1.3.x version when this behaviour occured.

However, I'm using the option "minimize hides, close exits", if that would make a difference.

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #3
Maybe you should try the options in the figure below.

This will hide Deskband Controls when nothing is playing.
Not what I wanted. Deskband Controls should stay visible at all times. Only foobar2000 main window (the window you will see on a new, vanilla installation of foobar2000 with default settings and without any plugins installed) should be hidden.

Maybe, I should also point out, that my question is not specifically related to Deskband Controls. The fact, that I am using this plugin is only my motivation, as to why the behaviour in the old version was useful for me. Might be, that other people with other plugins or people who just prefer to use media keys without any gui, will also be interested in restoring the old behaviour.
From a technical point of view, there is no connection and, as @Maggi correctly noticed, you should be able to observe this change in behaviour without Deskband Controls (or any other plugins) installed.

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #4
Hi there,

You can edit the Windows shortcut to start minimized -

foobar2000.exe /hide

That along with "minimize hides, close exits" setting, should start foobar in the tray.

(Incidentally this is around 3rd or 4th time someone has posted about this since v1.4, so maybe not a bad idea to revise the settings)

Cheers ;)

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #5
Hi there,

You can edit the Windows shortcut to start minimized -

foobar2000.exe /hide
This is a very good idea. However, this will only work if you use the shortcut to start foobar. Usually, that is not what I do. Instead, I tend to use Windows File Explorer to browse my music collection and double click on some mp3 or playlist file, which will then launch foobar. :-\

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #6
So I guess the best workaround would be to put the shortcut in Windows Startup folder so it is launched at startup. Note that foobar stays minimized when playing from Explorer, so long as 'Bring to front when adding new files' is disabled under Preferences > Shell Integration.

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #7
Possible, but also not ideal. Sometimes, I use Spotify and have to close foobar (or just don't start it), because having two media players run simultaneously is not a good idea when using media keys on the keyboard. Otherwise it is quite funny (or annoying, depending how you look at it) when you get effects like failing to to pause playback because the play/pause button just became a switch button that pauses one player while at the same time starting the other one that was previously paused. xD

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #8
The point is that it was working fine in v1.3.x.
This issue occured after updating to version 1.4.x, so I presume it should be an easy fix for the next update.

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #9
I just updated to v1.4.4 and this issue persists.
I just noticed, the thread starter reported for v1.4.4... sorry

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #10
Thanks for all your insight on this matter.
The beahvior has been changed for the next update so the 'hidden' state sticks across restarts.

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #11
That's wonderful news. Thank you very much!  :)

 

Re: Foobar2000 does not remember being hidden in tray (did work in old version)

Reply #12
Awesome! Very much appreciated... :)

Thanks a lot, Peter!

 
SimplePortal 1.0.0 RC1 © 2008-2019