Skip to main content
Topic: Create CUE Sheet Output Differs with Input Type (Read 1554 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Create CUE Sheet Output Differs with Input Type

Here's a weird one and I'm not sure if it's a feature or a bug.

When using the Create CUE Sheet function in CUETools 2.1.7 on Win10 I get different output depending on which type of input I'm using. It appears that the function is reading and respecting the Advanced Settings/Tagging options in some cases and ignoring them in others.

For example, I have the tagging options set as shown in Figure 1 so that detailed cue sheet info will get pulled from the file tags into the dummy cue sheets.

When I generate a cue sheet by selecting files with the browser in File Browser mode the function respects the tag settings and outputs the proper tags to the cue sheet file as shown in Figure 2.

If, however, I generate a cue sheet from the exact files with the exact same tag settings but select the files with the browser in Multiselect Browser mode the function ignores the tag settings and only outputs the basic file info as shown in Figure 3.

This seems like weird behavior to me. I don't know why it would be intentional. It's not a big deal but it does make it tough to generate cue sheets from multiple releases as you have to go through them one disc at a time rather than just selecting a big batch in Multiselect Browser mode.

Any insight on whether and why this is intended behavior or a way to avoid it would be appreciated.


Re: Create CUE Sheet Output Differs with Input Type

Reply #1
The tool was added in v1.9.2. The browser modes were added sometime later.
The Multiselect Browser was originally added as a 'Batch' mode. (Selecting just a single album for Encode or Verify now disables 'batch' mode.)
'Batch' modes suppress (or bypass) sections of code that are unnecessary, problematic, or require user input.
Seems reasonable that some things may not work the same. Was this tool overlooked, not intended for use in 'batch' modes or just not a priority? I can't answer that.

I could suggest
Action: Encode > Mode: Tracks > Audio Output: None
but that will also have some problems.
You could uncheck Mode: Edit Tags to suppress CTDB metadata
and check Advanced Settings > CUETools (tab) > Audio Filenames > Keep original filenames
only to find that the CUE cannot be written to the source folder.
Even though Audio Output: None is set, you'll get a warning message that "Source and destination audio file paths cannot be the same..."

Re: Create CUE Sheet Output Differs with Input Type

Reply #2
Thanks Korth.

Maybe I can get around this with a command line script of some sort. I'll work on it.


SimplePortal 1.0.0 RC1 © 2008-2020