Skip to main content


If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: CUERipper doesn't like my drive. (Read 1206 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

CUERipper doesn't like my drive.

I already opened an issue on GitHub but I also wanted to try here, and see if someone has an idea what's going on.

When I try to rip a disc from my LG GH24NSD1 SATA drive I get this error.
"Exception: Error reading CD: medium error: UNRECOVERED READ ERROR"

It detects the disc, seems to detect gaps, but once it starts reading audio data, it fails. EAC and ImgBurn seem to work.

But here is where it gets weird: If I run CUERipper from a VM (XP, haven't tried any other OS), and map the emulated drive to this physical one, then it works.
Even weirder is that, if, after using the drive from the VM that way, I shut the VM down and open CUERipper from the host OS, then it works for one ripping session. After that one is finished or cancelled, further ripping attempts result in the same error again.

I also tried running CUERipper from fresh installs of windows 7 and windows 10, both 64 bit, on a spare drive, just to rule out my current OS installation (win7) being the cause of the error. Didn't solve anything.

I guess the drive is not the best thing ever and it seems it's doesn't quite like CUERipper, but under the right circumstances, it works.

Re: CUERipper doesn't like my drive.

Reply #1
Latest firmware for your drive installed?

Re: CUERipper doesn't like my drive.

Reply #2
Latest firmware for your drive installed?
LG does not seem to provide updates, and, as much as I look arround, I can't seem to find it anywhere else.
If you can, I'll be happy to take a look.

Re: CUERipper doesn't like my drive.

Reply #3
Try and see if they have something more current.  I don't know the age of your drive, but good luck.  This is a link from the author of ImgBurn and I got the latest for my drive from there.  They're official updates.

Re: CUERipper doesn't like my drive.

Reply #4
Yes, I've known that site for years, and they have nothing on this drive.
It's not listed in the LG section, searching for the model number turns up nothing, and neither does checking from ImgBurn itself.
It seems LG has not released an update for this drive, so I'd say that route is a dead end for this drive.

Can anyone explain how it is that the drive will work with CUERipper from a VM in passthrough mode but not from the host OS?

Re: CUERipper doesn't like my drive.

Reply #5
I know this is an old thread but my reply might help others. I just bought a new drive same as above and kept getting these errors as well. After some searching I found this is a common problem for this drive and a fix was made. If you go to this link some nice person has made a 2.1.7 workaround fix and it works for me now. is the download link. Cheers.

SimplePortal 1.0.0 RC1 © 2008-2021