Skip to main content
Topic: [TOS#6, Double Post] DSD, WavPack and Foobar SACD Decoder (Read 111 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[TOS#6, Double Post] DSD, WavPack and Foobar SACD Decoder

Hello,

I have found a strange behavior in Foobar in the recognition and playing of DSD files in Wavpack according to the order in which the SACD decoder is found in the decoding list.
The starting point is an SACD ISO file which is displayed and reproduced correctly;



From this ISO, with sacd_extract I've got a dff file and a cuesheet file that play correctly:



And finally, these dff+cue files are compressed with wavpack, resulting in a single wv file with embebed cuesheet:

wavpack prueba.dff --allow-huge-tags -w Cuesheet=@prueba.cue

The first problem occurs when adding this wv file to the Foobar library. If in the decoding list we have SACD first, when adding the file (and rescanning the library), the file is shown like this and with the following properties:







As you can see, the file is played as a DSD64 file without tracks, although a cuesheet appears in the properties, it does not run during playback, and the file's metadata are not imported either.

However, if we down the SACD decoder in the decoding list and add the wv file back to the library, the following happens:





As shown in the image, in this case the wv file has been added to the library with all the metadata and the embedded cuesheet, playing the tracks correctly and being able to change the track correctly. However, in this case the file is not reproduced as a DSD file but as 24-bit PCM and 352800 Hz (data that confirms the display in my DAC).

But if at this point the SACD decoder is raised to the upper level, a curious thing occurs:



In this case, we apparently have the ideal situation: a DSD wavpack file with embedded tracks that plays well as DSD (my DAC also recognizes it as DSD64). But also in this case we find a new error: every time we change the track, it shows that the selected track is apparently playing, but in reality what it sounds is always the file from the beginning (that is, track 1). It seems that it is not able to locate the jump to its correct position and always returns to the beginning of the file, that is, as if it were a file without an embedded cue.

I'm not sure if the problem is in the wavpack or in the SACD decoder. The fact is that if the SACD decoder is able to play a dff+cue file without problem, it should be the same with a DSD wavpack with embedded cue. Then the problem could be in how the wavpack file is recognized in Foobar?.

Regards,
Ignacio


 
SimplePortal 1.0.0 RC1 © 2008-2019