Skip to main content
Topic: How to change the default output path? (Read 1440 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

How to change the default output path?

I haven't been able to find out how to change the default path. There's this post but it doesn't ask the exact same question.

Instead of "C:\Users\user\Music\Converted\Artist\Album\Artist - Album.cue" I want to save to another drive by default and not always configure the path manually. I never store lossless music on C:.

Re: How to change the default output path?

Reply #1
In the template change %music%\ to D:\ (or the letter of your other drive)
korth

Re: How to change the default output path?

Reply #2
Along these lines, how do I get CUEtools to automatically set the output path to be the same as the input path of the cue sheet? In other words, I want the extracted flac tracks to be in the same location as the single flac/cue files.

Re: How to change the default output path?

Reply #3
In-place conversion (output of audio files to source directory) is on the list of requested features.
When you try to 'encode' with the output set to the source directory, if any new audio file would have the same filename as an existing file, you may see an error message "Source and destination audio file paths cannot be the same...". This occurs when you select "Audio Output: None" as well. Other files may be overwritten (.CUE, folder.jpg, etc).

I would suggest setting the output path to a new folder and moving the files after conversion. For example
[%directoryname%\]new\%filename%.cue
korth

Re: How to change the default output path?

Reply #4
I gather this request has been on the list forever. What is [%directoryname%\] set to, i.e. the directory path of the input?

I just did a test and [%directoryname%\] is incorrect. The "\" cannot be inside the "[]" characters. But, it is worse than that. All that happens is that a directory called "[%directoryname%]" is created in the last directory that I wrote to.

Re: How to change the default output path?

Reply #5
I just did a test and [%directoryname%\] is incorrect. The "\" cannot be inside the "[]" characters.
Sure it can. The "[]" characters just make it conditional on the existence of %directoryname%.
I can only assume you're doing something I didn't expect like selecting input at folder level.

Quote
But, it is worse than that. All that happens is that a directory called "[%directoryname%]" is created in the last directory that I wrote to.
? Unless you care to share how you changed the template...

Edit: [%directoryname%\]new[%unique%]\%filename%.cue is one of the default templates. I just left the [%unique%] part out. See pic, output path fills correctly with the template as I wrote it.
korth

Re: How to change the default output path?

Reply #6
Yes, I selected the input path by using the left-hand folder browser. I clicked on the + for a folder and then selected the cue file. That became the input.

For the output, I used Browse to get to the same path as the input. I then added "tracks\" before image.cue. In the settings, Keep original filenames is unchecked. Track format is: %artist% - %title%

I then ran that configuration.

I went to .../cue.tools/wiki/CUETools_Templates and looked at the variables and noticed that %directoryname% is not listed. The note says that those not listed are tags. I do not know of a tag named directoryname. Even if there is, it wouldn't serve the purpose I was after.

I then selected a new cue file in another folder. In the output, I removed everything before "\tracks" and replaced it with [%directoryname%], making the output: [%directoryname%]\tracks\image.cue

When I ran that configuration, it created a "[%directoryname%]\tracks" directory in the directory of the first run above. I do not know what %directoryname% is supposed to return as a value, but instead it was treated as text and used to create a directory.

It looks like until the option is added whereby the output path is equal to the input path, I'm going to have to manually browse to the input path and add "\tracks" to get around the issue whereby the embedded cue filename is equal to one of the contained tracks.

Re: How to change the default output path?

Reply #7
%directoryname% when used in an Output Template is the path to the source file (which differs from the Foobar2000: Title Formatting Reference it is based on).

Output should be set to 'Use template'. The Output box will be greyed out, giving control to the Template.



Template is entered in box below.


korth

Re: How to change the default output path?

Reply #8
Ah Ha! I did not know that the variables could only be used in template mode. It looks like the wiki page that I referenced needs to be updated to include the %directoryname% variable.

I replaced "new[%unique%]" with "tracks" and ran that. It worked!!!  Off to do a bunch more and see what happens.

Thanks for your response and patience.

Re: How to change the default output path?

Reply #9
It looks like the wiki page that I referenced needs to be updated to include the %directoryname% variable.
Done. Added info on a few others as well.
korth

 
SimplePortal 1.0.0 RC1 © 2008-2019