Skip to main content
Topic: Starting foobar muted deliberately (Read 291 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Starting foobar muted deliberately

Is it possible to start foobar2000 in a forced muted state or to disable sound completely?


Re: Starting foobar muted deliberately

Reply #2
I believe foo_scheduler has an option for tasks on start but I'm not currently near a machine w/ foobar to verify. If it does, just set it to mute/vol 0 on startup.

Re: Starting foobar muted deliberately

Reply #3
If you always want foobar2000 to be in mute mode on start up, you can achieve that with one jscript line:
Code: [Select]
fb.VolumeMute()



I'm late

Re: Starting foobar muted deliberately

Reply #4
Thanks for all your suggestions. I'm trying the jscript suggestion but it doesn't set default to mute on startup, only when the jscript panel is activated. Is there a way to initiate fb.VolumeMute() when playback starts? That would be the next best thing.

Re: Starting foobar muted deliberately

Reply #5
I'm trying the jscript suggestion but it doesn't set default to mute on startup, only when the jscript panel is activated.

Isn't the jscript panel activated on start up?
I'm late

Re: Starting foobar muted deliberately

Reply #6
I'm not sure about that, but the code isn't run on start up, only when I open the config window and apply it runs and applies mute.

Re: Starting foobar muted deliberately

Reply #7
Pressing "Ok" in the config window triggers the panel initialization, which is what is supposed to happen by default on start up.
Can you check in the console if the panel is actually initialized on start up?
I'm late

Re: Starting foobar muted deliberately

Reply #8
I've found the reason why it didn't work. I was running two consecutive portable installations, one was my regular config, the other a barebones test bed. The jscript panel on the test bed does initialize on startup according to the console but when the other regular portable foobar2000 was already running the test bed config wouldn't apply fb.VolumeMute(). When I started only the test bed and no other foobar2000 running then all went as expected. So your solution works. Thanks.

Re: Starting foobar muted deliberately

Reply #9
Foo Scheduler:

A) Upper window:
1- Add player event - On playback start - (re enable event)

B) Window below:
1. Add actions list name - Mute Volume
2. Add action - Mute/Unmute

C) Upper window:
On playback start - (re enable event) - Assign action list - Mute Volume

 
SimplePortal 1.0.0 RC1 © 2008-2019