Skip to main content
Topic: Incorrect encoding replacement in CUE (Read 571 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Incorrect encoding replacement in CUE

For several years, the problem of erroneous transcoding of UTF-8 in ANSI has been discussed, I still do not understand how to turn it off, when correcting CUE, the file is recoded in Ansi, and all Unicode characters disappear

18.05.2010: CUETools 2.0.9:

    Fixed a bug with cue sheets saved in ANSI instead of utf8 - ???

I am use 2.1.7, turn off 'Force ANSI filenames', turn on 'Force ANSI filenames' does not give the result

Re: Incorrect encoding replacement in CUE

Reply #1
There currently is no setting to force UTF-8 CUE sheets. A 'Force UTF-8 CUE' setting has been previously requested.

https://hydrogenaud.io/index.php/topic,66233.msg828467.html#msg828467
- utf8 is used when cuesheet has characters that are missing in your default codepage, e.g. if you have Russian Windows version, utf8 will be used for Japanese, but not for Russian.

Quote
when correcting CUE
I assume you mean Action: Correct filenames.
2.1.7 appears to be working on my system as Gregory described (saves the CUE as UTF-8 when foreign characters are present).
korth

Re: Incorrect encoding replacement in CUE

Reply #2

2.1.7 appears to be working on my system as Gregory described (saves the CUE as UTF-8 when foreign characters are present).

really does not recode CUE if it initially has letters for example the Scandinavian alphabet, thanks, this is an unpredictable scenario, of course there must be a function to encode / non-encoding

Re: Incorrect encoding replacement in CUE

Reply #3
I hate to drag up an old thread but wanted to note that this issue is not restricted to "foreign" characters.

CUETools ANSI/Windows-1252 cue sheets can't be properly read by programs such as VLC Media Player that look for UTF-8. VLC will choke on CUETools cue sheets if there are things like apostrophes and single quote marks in them. I have to go back and resave the cue sheets to UTF-8-BOM using a script if I want them to work as playlists in VLC.

It's a minor but annoying problem. A check box in the settings to force UTF-8 output in the cue sheet would be a nice feature.

Cheers.

 
SimplePortal 1.0.0 RC1 © 2008-2019