Skip to main content
Topic: DSD / DFF in wavpack using Ubuntu (Read 49427 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: DSD / DFF in wavpack using Ubuntu

Reply #50
foo_input_sacd I have to keep it installed otherwise Foobar does not read the dsd files, whether they are wv or dsf / dff
Actually, foobar2000 does read and play WavPackDSD files without any additional components. And it can play dff/dsf files with foo_input_ffmpeg. So foo_input_sacd is not mandatory unless you need to output DSD directly without decoding to PCM.

Re: DSD / DFF in wavpack using Ubuntu

Reply #51
Thank you very much for this info, I didn't know of the existence of foo_input_ffmpeg, I will definitely try it ...... I ask you some things if I don't disturb you, my dac (Chord Qutest) accepts input dsd files so I like to play the files dsd native without converting them to pcm, that's why I use foo_input_sacd ..... but I ask you, can the foo_input_ffmpeg plugin install the same right? So I do some tests, in the case I install foo_input_ffmpeg what should I put as an output module? I have [DSD] Asio - Chord ...... with the foo_input_ffmpeg plugin everything will be converted back to PCM? Also the DSF files? On Ubuntu I use DeadBeef and the wv / dsd-64 files reproduce them in PCM 352.8, if instead I have the dsd128 / 256 how are they played? My dac in pcm reaches 384 ......
Thank you

Re: DSD / DFF in wavpack using Ubuntu

Reply #52
When playing DSD with foo_input_ffmpeg, it will be converted to PCM.
As for other part of you question, i don't completely understand. But if you can successfully play regular PCM files (flac, mp3 and so on) with you current setup, you don't need to change output settings to use foo_input_ffmpeg.
As for samplerate of output PCM when decoding with foo_input_ffmpeg, it can be adjusted


Also, notice that you will need ffmpeg itself ( https://ffmpeg.zeranoe.com/builds/ ) for foo_input_ffmpeg to work

Re: DSD / DFF in wavpack using Ubuntu

Reply #53
Yes, the PCM files reproduce them quietly, so useless I put this component ..... I saw in the list of installed components that Foobar already has ffmpeg by default, what changes with the component foo_input_ffmpeg that you suggested?
Thank you

Re: DSD / DFF in wavpack using Ubuntu

Reply #54
I saw in the list of installed components that Foobar already has ffmpeg by default
Built-in ffmpeg is used only for decoding of MP3, AAC, Vorbis.

Re: DSD / DFF in wavpack using Ubuntu

Reply #55
Thanks again, to use this component, do I need to have ffmpeg installed on windows 10? How do I install it or do I just need to put the component on Foobar?
Thank you

Re: DSD / DFF in wavpack using Ubuntu

Reply #56
AFAIK, external ffmpeg will only decode stereo WAVPACK/DSD at the moment. I think @bryant has a patch in the queue for multichannel files to be decoded by ffmpeg but so far it hasn't been voted in.

Re: DSD / DFF in wavpack using Ubuntu

Reply #57
What should I select for wv files?

Re: DSD / DFF in wavpack using Ubuntu

Reply #58
AFAIK, external ffmpeg will only decode stereo WAVPACK/DSD at the moment
ffmpeg doesn't decode WavPackDSD at all (yet). Tested on build from 2019.08.22. You can test it too. As for DSD in dsf/dff, ffmpeg can decode all variants.

Thanks again, to use this component, do I need to have ffmpeg installed on windows 10? How do I install it or do I just need to put the component on Foobar?
Yes, you need to download ffmpeg - https://ffmpeg.zeranoe.com/builds/ No installation needed. Just unpack archive and point FFmpeg Decpder Wrapper (in its settings) to folder containing ffmpeg.exe and ffpropbe.exe.

What should I select for wv files?
One more time: to play WavPackDSD in foobar2000 you do not need additional components. ffmpeg is needed to play dsf/dff without foo_input_sacd
You need to point FFmpeg Decpder Wrapper to folder containing ffmpeg.exe and ffpropbe.exe. And create new profile for dsd decoding.


Re: DSD / DFF in wavpack using Ubuntu

Reply #59


One more time: to play WavPackDSD in foobar2000 you do not need additional components.


Then surely I'm wrong something because I can't reproduce wv / dsd in any way except with the foo_input_sacd component and in the decoding window sacd decoder must be on top of wavpack, in this way I reproduce them, in any other way Foobar makes me wrong .....

Re: DSD / DFF in wavpack using Ubuntu

Reply #60


One more time: to play WavPackDSD in foobar2000 you do not need additional components.


Then surely I'm wrong something because I can't reproduce wv / dsd in any way except with the foo_input_sacd component and in the decoding window sacd decoder must be on top of wavpack, in this way I reproduce them, in any other way Foobar makes me wrong .....

With foo_input_sacd you can have some problems. When you select a wavpack-dsd file from your media library, what does the codec field say: DSD64 or WavPack?

Re: DSD / DFF in wavpack using Ubuntu

Reply #61
DSD tells me, also because I have no other way to reproduce them, in any other way Foobar gives me an error, I have to use an output module [DSD] Asio or Wasapi, then forcefully use foo_input_sacd, if I put any other output module it gives me error ...... so I don't reproduce them natively, I have to have foo_input_sacd ..... I would like to try to see if there is a difference between the foo_input_sacd component and the reproduction in Wavpack but I can't. ...
Thank you

Re: DSD / DFF in wavpack using Ubuntu

Reply #62
Try moving the wavpack decoder above the sacd decoder. Then drag and drop a wavpack-dsd file to a playlist and try playing it back... the output module should be just a normal one (for pcm).

If this works you will need to delete foobar2000 media library and rescan your files. If this doesn't work I don't know what the problem is.

Re: DSD / DFF in wavpack using Ubuntu

Reply #63
AFAIK, external ffmpeg will only decode stereo WAVPACK/DSD at the moment
ffmpeg doesn't decode WavPackDSD at all (yet). Tested on build from 2019.08.22. You can test it too. As for DSD in dsf/dff, ffmpeg can decode all variants.
FWIW, the patch to allow FFmpeg to decode WavPack DSD is here and still merges and probably still works. It handles both stereo and multichannel, but whether it would work with FFmpeg is not clear.

The reason it was rejected is that it creates a new codec ID for WavPack DSD, which seems to be against the rules in some circumstances (no explanation given). I hope to create a new patch in the next month or two.

Re: DSD / DFF in wavpack using Ubuntu

Reply #64
Try moving the wavpack decoder above the sacd decoder. Then drag and drop a wavpack-dsd file to a playlist and try playing it back... the output module should be just a normal one (for pcm).

If this works you will need to delete foobar2000 media library and rescan your files. If this doesn't work I don't know what the problem is.

Today I started to do some tests, I had a PC with windows 10 just installed and I put fb2k 1.4.6, actually reads the wv / dsd files but I discovered that a dsd64 sends it as pcm 352.8 while instead I made a try with a dsd256 and fb2k goes wrong, then I went into the windows audio settings and noticed that if I set as output over 192 on the dsd128 / 256 foobar it goes in error, so paradoxically a dsd64 can reproduce it in pcm 352.8 while a dsd128 / 256 no more than pcm 192 ...... with dsd64 I can use wasapi as an output module while with 128/256 no, I can only use ds.
The test was done with windows just installed and with the only wasapi component on fb2k, I didn't put anything else, not even the drivers of the dac (chord qutest) that windows recognizes ......
In the other PC where I have 1.5 b11 and various components installed including the sacd decoder I have no other way if I don't play wv / dsd as native dsd, in any other way fb2k gives me error ......

Re: DSD / DFF in wavpack using Ubuntu

Reply #65
Today I started to do some tests, I had a PC with windows 10 just installed and I put fb2k 1.4.6, actually reads the wv / dsd files but I discovered that a dsd64 sends it as pcm 352.8 while instead I made a try with a dsd256 and fb2k goes wrong, then I went into the windows audio settings and noticed that if I set as output over 192 on the dsd128 / 256 foobar it goes in error, so paradoxically a dsd64 can reproduce it in pcm 352.8 while a dsd128 / 256 no more than pcm 192 ...... with dsd64 I can use wasapi as an output module while with 128/256 no, I can only use ds.
WavPackDSD decoder in foobar2000 outputs PCM with samplerate equal to samplerate of DSD divided by 8. So, for DSD64 you will get PCM with samplerate 352800, for DSD128 - 705600, for DSD256 - 1411200. If you use WASAPI exclusive output and your sound card doesn't support such high sampleraters, you need to use resampler in foobar2000's DSP. As for DS output - resampling is done automatically, when needed.

Re: DSD / DFF in wavpack using Ubuntu

Reply #66
Thanks for the answer ... In fact it is difficult to find a dac on the market that goes beyond 384 in pcm ... On fb2k where should I act to activate the component to reduce the frequencies?  Then will it resample me all over?  I would like to use wasapi as an output module and resample only the wv / dsd 128/256 because they go beyond the frequency of my dac .... As far as DSF files are concerned, should I install the ffmpeg component right?I would like to do some tests without installing the foo_input_sacd component and see how it goes .... I would practically send everything in pcm ...


Re: DSD / DFF in wavpack using Ubuntu

Reply #68
@Bryant, for the first time it happened to me on two files that the md5 verification codes do not match, in fact the program signaled it to me, I had to use the -hm option without the v otherwise the .wv file was not created for me , practically what have these files wrong? Can I use them or are they not reproducible?
Thank you

Re: DSD / DFF in wavpack using Ubuntu

Reply #69
The only time I've seen this is with .dsf files that are invalid because they don't have zeros at the end of the final, incomplete block. The DSF spec says they are supposed to, but a few don't. Since WavPack does not store that final bit of data, the MD5 ends up not matching even though all the actual audio is correct.

Assuming that your source file was a .dsf file, everything should be fine. I would recommend not using the -v option (obviously, because it won't work) and also not using the -m option because then a "verify" operation in the future will still fail.

Re: DSD / DFF in wavpack using Ubuntu

Reply #70
Yes, two .dsf files are correct but this is the first time something like this has happened to me ...... I code my files with this command "wavpack -hmv --import-id3 * .dsf (not always amount the tags because I often have problems with the sacd encoder so I prefer to put them after), so you advise me not to use the mv option anymore and then to use only -h?
Thank you

Re: DSD / DFF in wavpack using Ubuntu

Reply #71
I still believe that the -hmv is the way to go.

But for those few invalid files that fail I would recommend skipping the -m and -v.

Re: DSD / DFF in wavpack using Ubuntu

Reply #72
I have two dsf files that give me this error, what could it be?  is not a valid .DSF file (by total size)!

Re: DSD / DFF in wavpack using Ubuntu

Reply #73
Now I'm a little confused. In your post above you said that you had two .dsf files that would not match MD5 and you have to skip -v but otherwise they worked. I explained that this was because bad padding made the files invalid, but they were otherwise okay.

Now you mention the error is not a valid .DSF file (by total size)!. Are you actually getting that error? If so, then that is something different and I have never seen a file like that, and I don't understand how you were able to encode it.

Re: DSD / DFF in wavpack using Ubuntu

Reply #74
These have nothing to do with the files that gave the md5 error, there are two other dsf files that wavpack does not encode by returning this error, it is the first time I see such an error .....
Thank you

 
SimplePortal 1.0.0 RC1 © 2008-2019