Skip to main content
Topic: VST Adaptor 0.9.0.3 does not work well under Windows 10 (32 bit Ed.) (Read 137 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

VST Adaptor 0.9.0.3 does not work well under Windows 10 (32 bit Ed.)

Hello,

I am encountering a big problem after having upgraded my PC from Windows 7 to Windows 10 (32bit Edition).

After the upgrade to Windows 10, the component VST Adaptor 0.9.0.3 wrongly reports a VST DLL as being 64bit or corrupted.
However, I can verify that that component is OK by running the stand-alone app (see attached word doc reporting the problem and showing that the DLL is OK).

Anyone else had similar problems?
Anyone knows how to contact the VST Adaptor developer?

Thanks and regards,
Andrea


Moderator edit: Link to .docx file removed, because it contained personal information.

Re: VST Adaptor 0.9.0.3 does not work well under Windows 10 (32 bit Ed.)

Reply #1
I asked a mod to remove the document as it contained your serial number for the plug-in.

The problem you see isn't really foo_vst's fault. The VST plugin uses dynamic C runtime linking and it doesn't get loaded from a different directory. You should get the proper runtime installed system wide by installing old .NET Framework, but easier solution is to copy the msvcr71.dll file from C:\Program Files\Allocator directory into your foobar2000 install dir.

 

Re: VST Adaptor 0.9.0.3 does not work well under Windows 10 (32 bit Ed.)

Reply #2
Many thanks, Case, for your prompt reply and for having asked to remove my attachment with my personal details (I didn't realize that).
I already tried your solution and it works (copied msvcr71.dll into the Foobar2000 dir).
Many thanks and kind regards,
Andrea

 
SimplePortal 1.0.0 RC1 © 2008-2018