Skip to main content
Topic: foo input sacd (Read 10921 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo input sacd

Hi everyone, and sorry 4 my bad english... I installed the foo_input_sacd plugin on foobar2000. When I play sacd recordings in ISO format, palyback is distorted and discontinued, with a lot of "scratches". I tryed to unistall and install the plug in again, but problem still persist. With all Hd recordings (24/96) the system works perfectly, except the ISO format of SACD. The software is installed on an Hp Mini 110-3103 with Intel Atom 455 and Windows 7 Starter with latest service pack and updates from Microsoft. Thanks.

foo input sacd

Reply #1
This means that Atom 455 is too slow do decode SACD.

Added:

download foo_benchmark, install it and test SACD decoding: right click -> Utilities -> Decoding Speed Test.

foo input sacd

Reply #2
I can playback SACD 2.0 tracks fine with a NVIDIA ION at ~75% CPU load.

foo input sacd

Reply #3
uncompressed DSD or compressed DST?

foo input sacd

Reply #4
DST, the cpu load for DSD would be much lower, around 40-50% probably.

foo input sacd

Reply #5
@lvqcl: I don't think it's a problem of slow cpu, because I can play HD videos without problems. I can play all other types of HD audio tracks, even 24/192 tracks with a stream of 8Mbit/s that aren't SACD, and it works perfectly. Even in this case, the CPU usage, showed by Task Manager, dosen't exceed 60%. The problem affects only SACD tracks. Does anyone have suggestion? Thanks!

-

I forgot to mention that CPU usage is about 60% even when I try to play SACD tracks, but playback is still distorted.

foo input sacd

Reply #6
Hi arnoldt3

I too had the same problem a few weeks back.  Being a musician using Logic Audio & Reason I had encountered this before with soft synths, So I opened my soundcards control panel & located the wdm/asio buffersize panel it appeared that a setting of 256 samples (which is my cards default) was too low so I increased it until I had smooth playback, which, was @ 768 samples!

Cpu utilisation is very high, but, that is to be expected.

I use asio as my output in foobar 1.1.7/1.1.8 along with continuator & GY's VST wrapper DSP's



I hope this helps you get smooth playback too arnoldt3.

Slowflow.

foo input sacd

Reply #7
Try different samplerates for the SACD plugin.

foo input sacd

Reply #8
Edit: sorry, my mistake!    My split file was actually NOT joined. Everything is fine now! Btw, make sure to rename sacd ripper created split file name to the one "File Splitter" is looking for...

Just ripped a SACD in iso with a total size of around 4.5GB. sacd ripper split the iso in 2, 1 file in 4GB and a small number 2 file. After some search, I use this File Splitter http://www.filesplitter.org/ to join the iso.

I open the iso in foobar and it show all the tracks. But when playback the last 2 tracks, which I guess are on the split file, it said "index out of range" and can not play or convert.

What is wrong? ripping? file joining? foo_input_sacd?

Thanks in advance.

foo input sacd

Reply #9
With the wealth of information you're providing, I'd randomly guess that your file system is FAT32 which cannot handle files bigger than 4GB.

 

Re: foo input sacd

Reply #10
Today's FOO_INPUT_SACD update, I downloaded and checked, version the same before 1.1. 0, but the "Readme file" has been modified as follows, which I think is important.

 
SimplePortal 1.0.0 RC1 © 2008-2019