Skip to main content
Topic: foobar DSD playback problems with AVR (Read 350 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foobar DSD playback problems with AVR

Hello everyone,

I am sorry if my question is answered somewhere around the forums, but I read a lot about how to setup foobar and still can not manage to do it properly.

So my setup is as follows;
Windows 10 PC -> foobar-> - HDMI -> Denon X3300 AVR (in Pure Direct)

The AVR is suppose to support DSD through HDMI, even though info on that topic is scarce.

My foobar SACD settings look like this:
https://ibb.co/fiZ9ap

When I try this output setting:
https://ibb.co/bHY2vp

Or any of the other wasapi or dsd : wasapi settings with the Denon flacs &other files play fine. My AVR info says the sample rate is 192kHz as it should.
But when I try to play dsd 64/128 I get these errors and there is no playback and sound:
https://ibb.co/cRDP89

When I setup the output setting like this (the highlighted option), dsd files are playing:
https://ibb.co/hKfhvp

But I get this error at the beginning of every track.
https://ibb.co/nEBBo9

And also on this setting even lower bitrate FLACs (192kHz) are still being played in 48kHz according to the info on my AVR menus), so something is definitely not right and I should be using some other setting, probably WASAPI).

Basically only with the last setting dsd files are playing, but this is using the windows direct stream or something, right? As mentioned above in my receiver setup - general - information - audio - it says the stereo, PCM, 48 kHz, so that can not be fine.
Should I aim for direct DSD playback from my AVR? Is it OK for the output to be converted to PCM by foobar? If yes - shouldn't it at least have a higher sample rate, probably the same as the source DSD?

Any help would be greatly appreciated.

EDIT:
OK, I manged to get rid of the annoying FIR error message with the last setting by changing the DSD2PCM to Direct (64fp...). But other than that I still believe DSD file playback is not proper and there is some downsampling happening.


Re: foobar DSD playback problems with AVR

Reply #2
I see. Thanks a ton! You probably saved me dozens of hours digging into the subject and testing different methods.

So are there any workarounds besides buying a dedicated DAC with a USB input and RCA output?

I understand that the Denon X3300 can accept DSD through USB as well, but there are some mentions a PC can't be connected directly, it has to be a USB stick or hardrive. Maybe with a LAN cable? I will dig online about some info, but wouldn't mind some help if someone is aware how it can be done. :)


Also - can foobar or Jriver convert those DSDs to PCM and downsample them to 192kHz (which is my AVR limit)?
I tried setting up foobar to output PCM only and use the Sox (mod2) DSP resampler to resample everything to 192kHz, but it doesn't seem to do anything.
When I try these settings:
Output data format: 24-bit
SACD - Output Mode - PCM
PCM Samplerate - 44100
DCD2PCM Mode - any of Multistage or Direct options

Foobar plays the DSD files, I guess they are converted to PCM 44100. But when I try to setup a higher samplerate of 88200 or 176400 I get this error:
"Unrecoverable playback error: Unsupported stream format: 176400 Hz / 24-bit / 2 channels"
I guess the bit-rate and samplerate do not work together.
But basically how can I at least get the max out of the PCMs? Like 176400 or something similar?
Again I would really appreciate help on this. :)


And another general question - even though my AVR says it reads DSD (I believe DSD128), it also has a limit of 192kHz I think. How would this be possible, when DSD 128 is way higher with 5,6mHz? Same goes for some USB DACs I guess, as I have seen a lot of them that say they support DSD 64, 128, even 256 or 512, but yet they have a max limit of either 192kHz or 384kHz. I guess I am missing something, but just wanna make sure if I invest in a separate DAC it would at least do the job.

Thank you once again for the help.

I see. Thanks a ton! You probably saved me dozens of hours digging into the subject and testing different methods.

So are there any workarounds besides buying a dedicated DAC with a USB input and RCA output?

I understand that the Denon X3300 can accept DSD through USB as well, but there are some mentions a PC can't be connected directly, it has to be a USB stick or hardrive. Maybe with a LAN cable? I will dig online about some info, but wouldn't mind some help if someone is aware how it can be done. :)


Also - can foobar or Jriver convert those DSDs to PCM and downsample them to 192kHz (which is my AVR limit)?
I tried setting up foobar to output PCM only and use the Sox (mod2) DSP resampler to resample everything to 192kHz, but it doesn't seem to do anything.
When I try these settings:
Output data format: 24-bit
SACD - Output Mode - PCM
PCM Samplerate - 44100
DCD2PCM Mode - any of Multistage or Direct options

Foobar plays the DSD files, I guess they are converted to PCM 44100. But when I try to setup a higher samplerate of 88200 or 176400 I get this error:
"Unrecoverable playback error: Unsupported stream format: 176400 Hz / 24-bit / 2 channels"
I guess the bit-rate and samplerate do not work together.
But basically how can I at least get the max out of the PCMs? Like 176400 or something similar?
Again I would really appreciate help on this. :)


And another general question - even though my AVR says it reads DSD (I believe DSD128), it also has a limit of 192kHz I think. How would this be possible, when DSD 128 is way higher with 5,6mHz? Same goes for some USB DACs I guess, as I have seen a lot of them that say they support DSD 64, 128, even 256 or 512, but yet they have a max limit of either 192kHz or 384kHz. I guess I am missing something, but just wanna make sure if I invest in a separate DAC it would at least do the job.

Thank you once again for the help.

EDIT:
OK, managed to solve one of the problems - when trying to resample the PCM files, I hadn't specified a sample rate for Sox mod2 to resample to 192kHz.
So first in the SACD settings I set the output to 352800 and then I put the same value in the Sox mod2 "Resample ONLY frequencies" field. And it works - my AVR is now receiver is now playing 192kHz PCM! A small win. 
But the other questions stand, I guess. Even though I wonder is all the trouble worth it. And would I even be able to tell the difference between a bit-perfect DSD and the resample 192kHz PCM I am playing...

Re: foobar DSD playback problems with AVR

Reply #3
If you haven't already, check out DoP  (DSD over PCM.)  It doesn't change any of the DSD bits, but it wraps them in PCM and "smuggles" them thru a system that can handle 24bit/176.4k PCM.  Many (most?) DSD capable DACs support it.  It's what foo_input_sacd outputs for DSD by default.  To use DoP you need to have a bit perfect path to your DAC (no volume control, no DSP, no replaygain) both in in your player (foobar2000) and in the OS.  WASAPI, KS and ASIO can be setup for bit perfect playback relatively easily.


Also, if you haven't found it already, https://diyaudioheaven.wordpress.com/digital/pc-software/foobar-2000-for-dummies-part-3-new-experimental-sacd-plugin-v-0-9-x/  is worth a read.

Re: foobar DSD playback problems with AVR

Reply #4
Thanks for the offered help and advice.

I actually had everything setup correctly, I was using WASAPI (event) with my AVR, converting to PCM than downsampling using sox Mod2 resampler to 192kHz. My receiver was recognizing the signal as 192kHz PCM and sound was awesome.
Then my Windows 10 updated, or I do not what happened and now everything is messed up again. :/
When using the previous settings which worked for 3 days flawlessly, now I get this error message when trying to playback a song.

"Unrecoverable playback error: Device invalidated"

In the windows setting I have allowed apps to take exclusive control for sound, I read a lot online, I was resetting some audio stuff through command prop, reinstalled foobar, tried every possible advice I found online with no luck.
Basically I can no longer play files through foobar using WASAPI output.
When I switch to DS output it works, files play without issues, but I guess this is not the way to go if I want good quality and/or bit-perfect conversion to PCM.

Again - advice and help would be most welcome and greatly appreciated!

Re: foobar DSD playback problems with AVR

Reply #5
One of the Windows updates uninstalled my DAC's drivers and put in it's driver, it sort of worked, but reinstalling my DAC's USB drivers was much better.

In any case , i you used "DSD: WASAPI (event)…" , try "DSD: WASAPI (push)…" (and vice versa)

In your Windows sound control panel for your device, besides verifying that the two exclusive mode options are checked in the Advanced page, also check you have "Disable all enhancements" checked on the Enhancements page if you have one.

In foobar2000's Advanced options there are more WASAPI options under the Playback section: FWIW I have mine set at 500 for hardware buffer push mode, 1000 for hardware buffer in event mode, and "High worker process priority" checked.

If your DAC comes with a good ASIO driver, you could try that too.  (Some ASIO drivers are quite buggy, so if you have problems you'll probably want to skip ASIO.)

 
SimplePortal 1.0.0 RC1 © 2008-2018