Skip to main content
Topic: Disable field mapping in Foobar? (Read 266 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Disable field mapping in Foobar?

Foobar (aswell as mp3tag) field map PUBLISHER to ORGANIZATION for FLAC;
VirtualDJ just wants PUBLISHER (for FLAC & MP3);
In mp3tag you can remove this mapping from the FIELD MAPPING list, so it stays PUBLISHER;
Problem is.. with foobar, I dont see such option; is there any?



Re: Disable field mapping in Foobar?

Reply #3
LABEL would be my first choice too(!)
In FLAC, this gets written to ORGANIZATION field, when using foobar.

In my ext. program, to show the LABEL column, it expects PUBLISHER field.

Using MP3 format, all goes well.
Since I'm writing to PUBLISHER.

Using FLAC format, foobar automatically maps the PUBLISHER tag to ORGANIZATION.
Hence I don't see any value showing in LABEL column at ext. program.

The solution would still be, to prevent foobar to automatically field map to ORGANIZATION.
...But how?

Re: Disable field mapping in Foobar?

Reply #4
Actually, foobar2000 does not see nor read a PUBLISHER tag. So if you can get a tagger to write a PUBLISHER (populated with the value of the ORGANIZATION field, that fb2k has written) - then it should probably solve your problem. Not sure what happens if fb2k overwrites tags though.

See the attached 1sampleflacpublisher.flac file.

LABEL would be my first choice too(!)
In FLAC, this gets written to ORGANIZATION field, when using foobar.

No, LABEL stays LABEL, I just tried. See the attached 1sampleflacwithLABELwrittenbyfoobar2000.flac

Edit: Hm, I see that one of these files have 4 kilobytes padding.

 

Re: Disable field mapping in Foobar?

Reply #5
Sorry for the confusion.
Indeed when foobar writes to LABEL, it stays LABEL.

But in order to have my ext. program show content in its LABEL column, I need to write the value to PUBLISHER.
This PUBLISHER tag gets written in MP3.
But the moment the same action applies to FLAC, u will see the PUBLISHER tag is called ORGANIZATION.
This is because of auto field mapping in foobar.
And it looks like there's no way to disable it (like you can in mp3tag).

Re: Disable field mapping in Foobar?

Reply #6
There is AFAIK no way to disable it in foobar2000.
But if you create a literal PUBLISHER in MP3tag and populate its content from what fb2k wrote to ORGANIZATION, then you will have the same content in both tags, and both VirtualDJ and foobar2000 should see precisely one of them as "PUBLISHER".

Re: Disable field mapping in Foobar?

Reply #7
Thanks for thinking along with me.
Yes, what you describe, seems to be the only option (using another program, mp3tag in this case).
I might make something smooth using foobar_run and a portable preconfigured version of mp3tag.

I'm trying to make it as simple as possible, so anyone can use it.
For now I've made 4 portable versions of foobar, each themed and preconfigured for ''the big 4'' in DJ software land,
See https://imgur.com/a/9dcHgGs (incl. overview which tags scheme each app is using).





 
SimplePortal 1.0.0 RC1 © 2008-2018