Skip to main content
Topic: foo_benchmark: wrong average speed is reported if decoder is foo_input_ffmpeg (Read 187 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_benchmark: wrong average speed is reported if decoder is foo_input_ffmpeg

fb2k 1.4 beta 20, foo_benchmark 1.2.3, foo_input_ffmpeg 0.5.4, ffmpeg N-91330-ga990184007 from Zeranoe. Wrong average speed is reported if file is decoded with foo_input_ffmpeg. Here is example. As you can see in "Total" part: min speed is 337.789, max speed is 840.177, but average speed is 1734.020
Code: [Select]
System:
  CPU: Intel(R) Core(TM) i3-3245 CPU @ 3.40GHz, features: MMX SSE SSE2 SSE3 SSE4.1 SSE4.2
  App: foobar2000 v1.4 beta 20
Settings:
  High priority: no
  Buffer entire file into memory: no
  Passes: 3
  Threads: 1
  Postprocessing: none
Stats by codec:
  TWINVQ: 556.606x realtime
File: D:\Downloaded\achterba.vqf
  Run 1:
    Decoded length: 2:00.094
    Opening time: 0:00.286
    Decoding time: 0:00.069
    Speed (x realtime): 337.789
  Run 2:
    Decoded length: 2:00.094
    Opening time: 0:00.080
    Decoding time: 0:00.069
    Speed (x realtime): 807.001
  Run 3:
    Decoded length: 2:00.094
    Opening time: 0:00.074
    Decoding time: 0:00.069
    Speed (x realtime): 840.178
  Total:
    Opening time: 0:00.074 min, 0:00.286 max, 0:00.146 average
    Decoding time: 0:00.069 min, 0:00.069 max, 0:00.069 average
    Speed (x realtime): 337.789 min, 840.177 max, 1734.020 average
Total:
  Decoded length: 6:00.281
  Opening time: 0:00.439
  Decoding time: 0:00.208
  Speed (x realtime): 1734.020

Re: foo_benchmark: wrong average speed is reported if decoder is foo_input_ffmpeg

Reply #1
Fixed, thanks for reporting.

Re: foo_benchmark: wrong average speed is reported if decoder is foo_input_ffmpeg

Reply #2
Now it reports speed correctly everywhere except last line in full report. See: Speed (x realtime): 1741.913
Code: [Select]
System:
  CPU: Intel(R) Core(TM) i3-3245 CPU @ 3.40GHz, features: MMX SSE SSE2 SSE3 SSE4.1 SSE4.2
  App: foobar2000 v1.4 beta 20
Settings:
  High priority: no
  Buffer entire file into memory: no
  Warm-up: yes
  Passes: 3
  Threads: 1
  Postprocessing: none
Stats by codec:
  TWINVQ: 813.626x realtime
File: D:\Downloaded\SAMPLES\VQF\achterba.vqf
  Run 1:
    Decoded length: 2:00.094
    Opening time: 0:00.079
    Decoding time: 0:00.069
    Speed (x realtime): 812.875
  Run 2:
    Decoded length: 2:00.094
    Opening time: 0:00.079
    Decoding time: 0:00.069
    Speed (x realtime): 807.374
  Run 3:
    Decoded length: 2:00.094
    Opening time: 0:00.078
    Decoding time: 0:00.068
    Speed (x realtime): 820.738
  Total:
    Opening time: 0:00.078 min, 0:00.079 max, 0:00.079 average
    Decoding time: 0:00.068 min, 0:00.069 max, 0:00.069 average
    Speed (x realtime): 807.374 min, 820.738 max, 813.625 average
Total:
  Decoded length: 6:00.281
  Opening time: 0:00.236
  Decoding time: 0:00.207
  Speed (x realtime): 1741.913

Re: foo_benchmark: wrong average speed is reported if decoder is foo_input_ffmpeg

Reply #3
OK, another update coming up shortly.

 
SimplePortal 1.0.0 RC1 © 2008-2018