Skip to main content
Topic: DLNA (Read 386 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

DLNA

I am trying to connect from my w10 laptop (while using foobar) to wifi soundbar (Samsung MS750).
Tried to install and use both foo_out_upnp and foo_upnp, with no success.

Although soundbar got visible in Foobar's output drop-down list, no sound is coming out.
Usual error is "time-out".
I had a success only once for 10 mins, with foo_out_upnp; as soon as I tried to change something in settings, sound was lost (although I reverted the setting to original value).

Can anyone network-knowledgeable please provide some advice?
 

Re: DLNA

Reply #1
Hey there,

Just wondering is there a specific reason you are going WiFi? Have you tried Bluetooth? If you just want it to play music...

(I have a Win10 tablet and Samsung M360 sound bar, connecting them in BT settings is pretty fast and stable, and the quality is great - hard to say I would notice a difference to lossless).

In any case, you might find better help posting/reading over in the discussion threads for foo_out_upnp and foo_upnp. I'm not familiar with how they work so cannot help there.

Best of luck 8)

Re: DLNA

Reply #2
First, soundbar does not support aPtx, so bluetooth connection for high quality formats is not optimal.
Second, because machines need to work as expected  :))
I did not address the threads you are mentioning, because they seem long inactive.

So, contributions will be highly appreciated.

Re: DLNA

Reply #3
I know you want foobar2000, but does W10 native DLNA server work?

Re: DLNA

Reply #4
I suppose you mean Windows Media Player.
It is hit and miss, but anyhow it only worked with saved files on hard disk, and not with streaming media (i.e. internet radio).

Re: DLNA

Reply #5
Had the same flaky output from foo_out_upnp until I stopped both the foo_upnp Media Server and Media Renderer.  May not have needed to do both but at least I'm now able to use Foobar2k to stream shuffled playlists to my receiver with DSP's, Replaygain and Crossfeed engaged.
Preferences > Tools > UPnP > Server > Basic Settings

Still touchy about pausing, skipping, etc. but I had it go over four hours last weekend.

Been tweaking the foo_out_upnp settings this past week to see what effect they have:
Preferences > Advanced > Playback > UPnP MediaRenderer Output



Re: DLNA

Reply #6
Currently, only foo_out_upnp is installed (with which I had the short lucky spell).
Still no honey.

Probably success or failure depends on the devices involved (and how every brand implements DLNA).
Any Samsung experience around?

Re: DLNA

Reply #7
Latest (unproven through time yet) solution:
  • install UPnP MediaRenderer Output (only)
  • select "prefer wav" in advanced settings/playback/upnp
No meters and visualizations work on Foobar Ui, but sound is working .
Lets hope it stays like this.

 
SimplePortal 1.0.0 RC1 © 2008-2018