Skip to main content
Topic: Waveform Minibar (mod) (Read 17081 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Waveform Minibar (mod)

Reply #150
Have you tried simulating it by setting the RMS color to black and regular color to dark gray?
Yes, it makes no big difference, the sharp edges are still there.


Re: Waveform Minibar (mod)

Reply #152
Hello,

how can I temporarily DISABLE the components waveform generation?

Atm, I work wtih huge files on a network drive which is not the fastest.
It takes about 10-30 seconts per file to scan.

I have enabled "abort seekbar generation... realtime", but its not aborting and I don't want the generation to be started at all.

The option "track to prefer, when showing waveform" does not have a good solution for me. (I need to switch between playing, skipping, playing other sounds, etc.)

I just like to disable the generation completely, but it seems not to be possible w/o uninstalling?

A right-click option "✔ disalble waveform generation" on the wavebar panel would be nice. (as a feature request)

As well as this:
I'm wondering too, if you could put the preferences "track to prefer when showing waveform" to the contextmenu (when rightclicking on the waveform), so users can switch fastly and do not need to open prefs, change setting, press ok, and change it back when needed, and open the prefs again for it..
I often like to change to "selected track", while my default setting is "playing, selected when stopped", but I don't want to stop the music ;-)) It could be faster to accomplish, with rightclick on waveform and quickly click one of the four entries.

Re: Waveform Minibar (mod)

Reply #153
how can I temporarily DISABLE the components waveform generation?
There's "Halt minibar processing" setting under the Library menu. It predates the context menu and I haven't yet remembered to add it there.

Re: Waveform Minibar (mod)

Reply #154
New version out that includes the track preference selection and processing halting in the context menu. There are also some fixes.

Re: Waveform Minibar (mod)

Reply #155
You are top class! Thank you! Tested and it is now working "as it should". ;-)
(It is great, that the cursor is moving while the generation is turned off!)

Cannot edit tags of file, while waveform is generated

Reply #156
Well, there is another question/issue.

I often get the f2k Info
Code: [Select]
"Could not update tags (File is already in use) on:
C:\mp3\myfile.mp3"
when trying to change tags, while the waveform is still generated.

I change tags via scripts bound to keyboard shortcuts, so I usually change 2-3 tags very quickly, while the component is on its way to generate the waveform.
It happens on SSD, HD and Network too, no difference.  Keyboard-shortcuts are fast, waveform generation is not.

My options are,

a) halting the waveform generation

b) wait until the generation is finished, then press the shortcuts.
c) ?

I must say,
b) is out of question

a) will result in enjoying and using the waveform mainly when I do other work than tagging or moving files in f2k (which is only about 15% while the rest 85% is fetching/finetuning tags, etc.), so the fine waveform is mostly deactivated.
Which is a pitty IMHO, because it is so helpful to use (jumping visually, skipping parts) and very convenient (click=done) to work with.

c) Is something which did not come to my mind yet.... %-)

So the question is,
is there a way to omit this message (and of course enable editing/changing a file, while its beeing processed)?

The waveform generator opens the file in r/o mode (I guess), so why can't I edit that file?
Is this a Windows7 thing, or may this be canged in f2k somewhere, maybe any advanced setting?

Thanks for your ideas.

Re: Waveform Minibar (mod)

Reply #157
is there a way to omit this message (and of course enable editing/changing a file, while its beeing processed)?

The waveform generator opens the file in r/o mode (I guess), so why can't I edit that file?
Is this a Windows7 thing, or may this be canged in f2k somewhere, maybe any advanced setting?
It's not a Windows 7 thing and you can't change that. foobar2000 wants exclusive write access to the file while tagging so an outside decoder having it open prevents this.

Only way that comes to mind to circumvent this is to read the file to memory and decode from there. But that would slow the waveform generation down and would consume a lot of memory. And wouldn't even work on large files.

Note that the faster your machine is the faster the waveform generation is. Typical tracks get scanned here in a fraction of a second so waiting for them to finish is not a problem. Also if you take advantage of the waveform cache and scan the files in advance there won't be any file locks later when showing the seekbar.

Since you like keyboard shortcuts you could map the '[main]' -> 'Library' -> 'Halt minibar processing' command to a key to be able to quickly turn it off if it gets in the way. And if you happen to use the 'playing track' mode hitting Stop will also stop incomplete waveform generation. It requires no further action, when you resume playback the waveform generation is restarted.

Re: Waveform Minibar (mod)

Reply #158
Actually should have asked Peter sooner. New version out now that allows you to tag files while waveform is being generated. And if your file is unseekable it will get tagged once waveform generation is finished.

 
SimplePortal 1.0.0 RC1 © 2008-2019