Skip to main content
Topic: bug attach picture (Read 712 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

bug attach picture

Hello,

My FLAC files get corrupted when I attach pictures on them with Foobar2000.
The way I proceed is:
Tagging>attach pictures>Front cover
Then the files are unreadable and their names are changed ending with a ~ symbol.
I never used this codec before, but since I do it I have this problem very often.

Thank you.

Re: bug attach picture

Reply #1
Which version of foobar2000 are you using? There have been some FLAC issues with versions 1.3.11 - 1.3.15, so if you are using such an old version you should upgrade.

Re: bug attach picture

Reply #2
What format on the album art? Jpeg?
Try using TagScanner. Though I've never had that problem with foobar2000.
I suspect it has something to do with either the file system, or permissions. ~ usually idicates temporary files.

Re: bug attach picture

Reply #3
~ usually idicates temporary files.

At least recent versions of fb2k use .tmp when writing metadata (larger than the padding, so that a new file needs to be created).


“It sounded bad to me. Digital. They have digital. What is digital? And it’s very complicated, you have to be Albert Einstein to figure it out.”
- Donald Trump, May 2017

Re: bug attach picture

Reply #4
Thank you for your replies.
Here are more explanations about my issue:

The files names look like xxx.FLA~ and take place in the final directory instead of the valid .flac files.
Sometimes just a few files are corrupted although the other ones are safe, sometimes everything has to been ripped again.
Sometimes everything is ok, but I can't be sure so I'm afraid to use .flac now... it's such a loss of time!
It happened with .png and .jpg. I analyzed the pictures with Windows Defender and there was nothing wrong with them.
My OS is Windows 10.
I have used 1.16 until this morning. I just updated to latest one 1.17.
I'll report if I still have the problem with this new version.
Thank you for Tagscanner, I'll report error messages.

Re: bug attach picture

Reply #5
foobar2000 doesn't use such syntax for temporary filenames. Are your files on some network storage? It almost looks like the storage system alters the names on its own. You could use Process Monitor to log the tagging operation and share a log that shows the error. If some program on your computer is reponsible it would be visible in the log.

Re: bug attach picture

Reply #6
Hello,

I had the problem again under foobar2000 v1.3.17.

Here is the error message:
Attached picture editing failure on "C:\Users\stephane\Music\Prince\HITnRUN Phase Two\08-When She Comes.flac": Object not found
Attached picture editing failure on "C:\Users\stephane\Music\Prince\HITnRUN Phase Two\10-Black Muse.flac": Object not found
Attached picture editing failure on "C:\Users\stephane\Music\Prince\HITnRUN Phase Two\11-Revelation.flac": Object not found

The files are in the folder.
Filenames got changed into:
08-WHE~1.FLA
09-SCR~1.FLA
etc...

Re: bug attach picture

Reply #7
That makes more sense. The file extensions don't change to FLA~ but file names somehow get truncated to the short 8.3 format.

Re: bug attach picture

Reply #8
The 8.3 "short format" is a "fallback option" in Windows - I have no idea why that happens on Windows 10 though.
A "reference": https://en.wiktionary.org/wiki/Micros~1

Try to open these .FLA files in foobar2000. Likely they are just OK FLAC files, except the filename. Check it - with foobar2000, this component is a must: http://www.foobar2000.org/components/view/foo_verifier
A standalone application that does pretty much the same thing (for FLAC - for mp3 it will be very, very picky about the metadata blocks): Audiotester from http://www.vuplayer.com/other.php
 
“It sounded bad to me. Digital. They have digital. What is digital? And it’s very complicated, you have to be Albert Einstein to figure it out.”
- Donald Trump, May 2017

 

Re: bug attach picture

Reply #9
@bobgeorge , can you use Process Monitor to monitor the next tagging you do and if you hit the file renaming issue, share the logs from the sessions?

 
SimplePortal 1.0.0 RC1 © 2008-2018