Skip to main content
Topic: Vorbis 1.3.7 aoTuV and Lancer patches (Read 36151 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Vorbis 1.3.6 aoTuV and Lancer patches

Reply #25
Hello, would it be possible to get the standalone Lancer patch?

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #26
Updated top post for the Vorbis 1.3.7 release.


Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #28
Updated top post for the Vorbis 1.3.7 release.

I might just be doing something wrong, but it seems to be missing xmmlib.h/xmmlib.c in the lib directory vs the previous release.

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #29
Updated top post for the Vorbis 1.3.7 release.

I might just be doing something wrong, but it seems to be missing xmmlib.h/xmmlib.c in the lib directory vs the previous release.
They are contained in the lancer patch file, towards the end.

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #30
Two issues with Enzo's repo merging these

1) Missing xmmlib.h, xmmlib.c and cpu.c in the lib directory.
2) I compiled the Windows build using cmake, and on Ubuntu using ./autogen.h, ./configure and make. The output files have different vendor strings:

On Windows (cmake built):
AO; aoTuV 6.03 (2020) (based on libVorbis 1.3.7)

On Ubuntu (autogen, configure, make)
BS; LancerMod(SSE2) (based on aoTuV 6.03 (2018))

I think these should probably match, no? Is the Windows build missing the lancer patch? Sorry i'm pretty bad at this C toolchain stuff.

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #31
Indeed, the cpu.c and xmmlib.c/.h files were part of the patch, but missing in the repository. Fixed now.

As for the vendor strings, you'll have to build with SSE2 enabled on Windows. Otherwise the Lancer code will not be enabled. Not sure how to do that with cmake, though. I use MinGW/autotools on Windows too.

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #32
Visual Studio 2017 and newer default to SSE2 if you don't change any of the settings.

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #33
I got the included Visual Studio 2010 solution to build with some jiggering... might be worth including a disclaimer in there that the cmake system doesn't include the Lancer bits. Or just remove the cmakefiles.

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #34
The Lancer code will work with cmake just fine. You just need to make sure to tell cmake to create project files with SSE2 optimizations enabled. I don't know how to do that. Not a big fan of cmake.

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #35
Thanks enzo for the updates. All 1.3.7 and derivative builds are now on Rarewares. :)

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #36
Is it on freac?

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #37
Is it on freac?
Only in the continuous builds for Linux as of now. It will be included with fre:ac 1.1.3.

You can use the Rarewares builds with fre:ac 1.1.2b, though. To do that, replace both, Vorbis.dll and VorbisEnc.dll in fre:ac's codecs folder with the DLL from Rarewares (i.e. copy the libvorbis.dll to the codecs folder, then change its name to Vorbis.dll, then do the same again changing the name to VorbisEnc.dll, so you'll have two copies of the new DLL as Vorbis.dll and VorbisEnc.dll).

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #38
Thanks enzo for the updates. All 1.3.7 and derivative builds are now on Rarewares. :)
I don't see any reference to Lancer at Rarewares. Is it normal?

 

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #39
Oggenc2.88 using libVorbis v1.3.7 - aoTuVb6.03 (Lancer Builds)

oggdropXPd V.1.9.2 using libVorbis v1.3.7 - aoTuVb6.03 - Lancer

libvorbis.dll using libvorbis v1.3.7 - aoTuVb6.03 (Lancer Builds)

ogg vorbis dlls using libvorbis v1.3.7 + aoTuVb6.03 (Lancer Builds)

vorbis.dll - for HeadAC3he using libvorbis v1.3.7 - aoTuVb6.03 (Lancer Builds)

They're all there. ;)

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #40
I'd like to report something minor (cosmetic) about oggenc2.88-1.3.7-aoTuVb6.03-P4.zip on RareWares. With my previous version, oggenc2 --version gives me "OggEnc v2.88 (libvorbis 1.3.6-aoTuV-b6.03)". It's now "OggEnc v2.88 (libvorbis 1.3.6)", still 1.3.6 and not saying aoTuV.

A vorbis file encoded with it does says "Tool : AO; aoTuV 6.03 (2020) (based on libVorbis 1.3.7)" so the above is not a real problem. Just potentially confusing. Thanks!

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #41
I'd like to report something minor (cosmetic) about oggenc2.88-1.3.7-aoTuVb6.03-P4.zip on RareWares. With my previous version, oggenc2 --version gives me "OggEnc v2.88 (libvorbis 1.3.6-aoTuV-b6.03)". It's now "OggEnc v2.88 (libvorbis 1.3.6)", still 1.3.6 and not saying aoTuV.

A vorbis file encoded with it does says "Tool : AO; aoTuV 6.03 (2020) (based on libVorbis 1.3.7)" so the above is not a real problem. Just potentially confusing. Thanks!
Thanks for the notification. I'll correct and re-upload shortly. (Actually, I notice it applies to all the oggenc2 compiles!!)

Edit: Corrected compiles now at Rarewares. :)

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #42
Thanks! :D

Re: Vorbis 1.3.7 aoTuV and Lancer patches

Reply #43
Thank you. One question, aoTuVb6.03 has not been updated for many years, is it currently better than Xiph 1.3.4 at all bitrates? For example at 160 kbps.

 
SimplePortal 1.0.0 RC1 © 2008-2020