Skip to main content
Topic: ASIO on Windows 10 problem - Asus Xonar STX II (Read 481 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

ASIO on Windows 10 problem - Asus Xonar STX II

Hello,

I have weird problem with Asus soundcard Xonar STX II using with Foobar2000 player with ASIO driver.
Using latest drivers for Xonar STX II.

Problem is when I choose ASIO driver in Foobar2000 audio output I have sluttering sound when I for example open browser and when it's opening sound getting more sluttering, even when I browse a web, a bit sluttering all the time.

But what is werid when I set Foobar2000 to run with Administrator option than problem do not exist.
I quess it's problem cause by Windows 10 64bit (build 1803), but maybe you know how to solve this problem.

I wanted to use Foobar2000 without Administrator option because when I turn it on, then I do not have anymore taskbar navigation buttons.
These ones


Thank you.

Re: ASIO on Windows 10 problem - Asus Xonar STX II

Reply #1
You won't like my reply but my recommendation is to stop using ASIO. It's meant for low-latency realtime operation and it serves no purpose in music playback. If you want to prevent other programs from making sounds during music playback use the WASAPI exclusive component. If you use seeking, pause or foobar2000's volume control I would recommend the default DirectSound output or shared mode WASAPI.

Re: ASIO on Windows 10 problem - Asus Xonar STX II

Reply #2
Stop ASIO nooo :) in WASAPI I quess it will not be a bit-perfect work automaticlly right ?.

as I said before if I run Foobar2000.exe with "Run as administrator" than ASIO work perfect no more sluttering in music etc.
What more, if I disable totally UAC user control in Windows 10 (in registry) and let Foobar run normally without Admin permissions thant work fine again.
So this is fault by Windows 10 or Foobar, I quess more Windows 10 and built in stupid permissions, UAC etc.

Re: ASIO on Windows 10 problem - Asus Xonar STX II

Reply #3
Actually WASAPI is bit-perfect, but bitperfectness is only useful for bitstreaming formats to external decoder. Which IMO isn't useful at all as then you lose all the features of foobar2000, like ReplayGain, volume control, DSPs...

If you wish, you can test changing MMCSS mode from "Audio" to "Pro Audio" under Preferences -> Advanced -> Playback -> Thread priority. It will boost some playback related thread priorities to realtime. But this shouldn't be required as playback threads already run at near-realtime priority and everything else on the system should run much lower. Also at least my ASIO drivers run their internal threads with realtime priority and foobar2000 can't affect it.

But really, if your ASIO drivers suck and can't handle playback without glitching, there's really no point in torturing yourself by trying to use them.

Re: ASIO on Windows 10 problem - Asus Xonar STX II

Reply #4
Thank you Case for reply, I also discovered when I disable UAC (User Account Control) permamentlly in registery (set value "EnableLUA" to "0"), then Foobar2000 and my ASIO work perfect, and I do not have to even set Foobar2000.exe to "Run as administrator".'
Looks like Windows 10 built in UAC mess something with ASIO driver from Asus.
So there are two options
Disable this UAC permamntlly in register
or
Run Foobar2000.exe with admin option.
I prefer disable this useless for advanced users UAC control, and with that option I do not loose taskbar thumbnail control buttons from Foobar.


 

Re: ASIO on Windows 10 problem - Asus Xonar STX II

Reply #6
Thank you very much Pollux88 for this theard, I will try it for sure.

 
SimplePortal 1.0.0 RC1 © 2008-2018