Skip to main content
Topic: Sansa Clip+/Rockbox problems with database (Read 445 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Sansa Clip+/Rockbox problems with database

Using Sansa Clip +
Rockbox 3.14
Puddletag 1.0.2

I am having problems with tags. I created tags using puddletag for some music files. I copied them over using rsync from my computer to the clip+
The problem is that some of the tags were not updated.
I then deleted all the files from the clip and then copied the files to the clip+
Now some of the files are not showing up after I update the database.

My questions:
Why weren't the tags updated when I used rsync to update the files the first time?
Why aren't all the files showing up in the database after I recoppied them?


Re: Sansa Clip+/Rockbox problems with database

Reply #1
Personally I found database feature not particularly reliable on sansas (rockboxed) , No longer using clip+ tough.
On Sony NWA15 database refresh in a blink of an eye.
Be sure to remove ID3V1 TAGZ, sansa don't Luke them.

Re: Sansa Clip+/Rockbox problems with database

Reply #2
The database walks the filesystem, and when it finds a supported format, it parses the tags. Things that can screw that up are a corrupt file system (very common on the cheaper sansas) or corrupt files such that the tags can't be parsed.

Id3v1 tags are supported by the way, but they are ignored if an id3v2 tag is present.

Re: Sansa Clip+/Rockbox problems with database

Reply #3
How do you fix a corrupted filesystem on a Sockboxed Sansa device? (Clip Zip here).

Cheers,
David.

Re: Sansa Clip+/Rockbox problems with database

Reply #4
On Windows this should fix it:
chkdsk /r /f     <drive letter>:

 
SimplePortal 1.0.0 RC1 © 2008-2018