Skip to main content
Topic: AC3 & DTC decoder errors (Read 307 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

AC3 & DTC decoder errors

I just installed the new versions of the AC3 (0.9.9) and DTS (0.5.4) decoder components, and now get these errors when fb2k (1.3.17) starts:

Code: [Select]
Failed to load DLL: foo_input_dts.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.

Failed to load DLL: foo_ac3.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.

Re: AC3 & DTC decoder errors

Reply #1
The forums are starting to be filled with people reporting this. Unfortunately kode54 has chosen to use dynamic C runtime linking with his components and marked them as 1.3 compatible. Dynamic linking was supposed to be used only with foobar2000 v1.4, which is currently in beta stage. The components work out-of-the-box on the new 1.4 beta but require 32-bit Microsoft Visual C++ 2017 Redistributable installation on the current stable 1.3 version.


Re: AC3 & DTC decoder errors

Reply #3
So it seems. Amusingly MS lists two links on their download page and the one they tell you to copy points to the older version, at least at the moment.

 

 
SimplePortal 1.0.0 RC1 © 2008-2019