Skip to main content
Topic: OpenMPT Module Decoder (Read 6387 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: OpenMPT Module Decoder

Reply #50
*shrug* They use the same library, and are audibly identical to my ears. Are you sure you don't have DUMB installed somehow?

Re: OpenMPT Module Decoder

Reply #51
Yes, I do, but it's disabled. I tried removing it, and the glitch is still occurring in openmpt54 only. This is what the glitch sounds like.

Re: OpenMPT Module Decoder

Reply #52
And I'm saying that particular issue doesn't happen here. In fact, it sounds like it should be caused by a bug that was just fixed by 0.4.5 of the upstream library. Please verify from the Components page of Preferences that both "OpenMPT component" and "OpenMPT component (kode54 fork)" list version of 0.4.5.

Re: OpenMPT Module Decoder

Reply #53
Yes, both say 0.4.5.
foo_openmpt.dll (2019-05-29 07:05:31 UTC)
    OpenMPT component 0.4.5
foo_openmpt54.dll (2019-05-29 07:05:16 UTC)
    OpenMPT component (kode54 fork) 0.4.5

Re: OpenMPT Module Decoder

Reply #54
What about your settings for my component?

Also, to be sure we're using the same test file, a sha256 sum.

6e5bedb948b710af0d0f305301379057bef10877d08d856bb646d17fa35fd2e8  bahgdad boogie.it

E: Also, a screen shot of your Preferences -> Decoders page, showing the order of components listed and enabled.

Re: OpenMPT Module Decoder

Reply #55
SHA256 hash is the same, 6E5BEDB948B710AF0D0F305301379057BEF10877D08D856BB646D17FA35FD2E8.
Component settings.
Sample rate: 48000 Hz.
Channels: Stereo.
Interpolation: linear.
Loops: infinite.
Fade time: 0.
Gain: +10.00 DB.
Separation: 100%.
Volume ramping: Default.
Use Amiga Resampler for Amiga modules: enabled. Here is a screenshot of my decoding preferences page.

Re: OpenMPT Module Decoder

Reply #56
Can't reproduce. Please replicate with a portable installation.

Re: OpenMPT Module Decoder

Reply #57
This is strange. I tried resetting the component's configuration by deleting the .cfg file in the foobar2000 configuration folder. That seems to have resolved the issue for some reason and the file plays normally now. Would love to know what caused that but either way, it's working.

Re: OpenMPT Module Decoder

Reply #58
I've found what causes the issue. It seems that it only happens when enable playback override in view>OpenMPT control is checked. If the setting isn't enabled, the issue doesn't occur and the file plays normally.

Re: OpenMPT Module Decoder

Reply #59
Thanks for helping me find this rather obscure bug. It has to do with the fact that the override was unmuting all channels on startup by default. Now the control, in interactive mode, will probe the interactive instance for which channels should be muted on startup, and will make the override control invert those channels, so they start as muted, and may be manually unmuted.

Yes, this song has a bunch of channels that are ordinarily muted, and apparently contain unwanted or later unused notes.

Big difference between DUMB and OpenMPT here: I don't think DUMB and the muting system I implemented ever allowed unmuting channels specified as muted by the file itself, whereas OpenMPT does allow that.

Re: OpenMPT Module Decoder

Reply #60
Quick question,
I have looping enabled (set to "1") and a fade time of 10000ms. I'm curious as to why the fades sound erratic, with an unusual 'fluttering' sound and speed increase? I can live with it, just that it's unexpected vs. a natural/smooth fadeout, and thought it could be a bug/maybe unintentional? Cheers.

Re: OpenMPT Module Decoder

Reply #61
Perhaps this does not belong here, but I need to ask: is there any solution regarding metadata tagging for tracker files that are read by this component? Plenty of tracker files don't have metadata for even basic info like an artist's name, but this information is of course quite useful when organizing music or sifting through a collection in foobar.
Is there any kind of workaround for this issue, or is it simply a limitation of the formats that must be accepted?

Re: OpenMPT Module Decoder

Reply #62
Perhaps this does not belong here, but I need to ask: is there any solution regarding metadata tagging for tracker files that are read by this component? Plenty of tracker files don't have metadata for even basic info like an artist's name, but this information is of course quite useful when organizing music or sifting through a collection in foobar.
Is there any kind of workaround for this issue, or is it simply a limitation of the formats that must be accepted?

It's a limitation that I tolerated with esoteric audio formats for a long time. Then External Tags came along, and now I use those for everything, even for conventional audio formats that don't require them. Definitely recommend you do the same! I'm just waiting and hoping for foobar2000 mobile to support them, so that ie. tracker formats can have filled-out artist, album, title, cover art etc. there too.

Re: OpenMPT Module Decoder

Reply #63
It's a limitation that I tolerated with esoteric audio formats for a long time. Then External Tags came along, and now I use those for everything, even for conventional audio formats that don't require them. Definitely recommend you do the same! I'm just waiting and hoping for foobar2000 mobile to support them, so that ie. tracker formats can have filled-out artist, album, title, cover art etc. there too.

Wow! I had no idea such a component existed, this is fantastic! This will absolutely solve my hurdles in organization with my tracker collection  :)

Re: OpenMPT Module Decoder

Reply #64
Quick question,
I have looping enabled (set to "1") and a fade time of 10000ms. I'm curious as to why the fades sound erratic, with an unusual 'fluttering' sound and speed increase? I can live with it, just that it's unexpected vs. a natural/smooth fadeout, and thought it could be a bug/maybe unintentional? Cheers.
This is fixed now.

Re: OpenMPT Module Decoder

Reply #65
I see the latest foo_openmpt54 supports Amiga style filenames. nice.
could you fix info than displayed on the Codec column? thanks

 

Re: OpenMPT Module Decoder

Reply #66
I don't even set the codec field, the player does that. That means I have to run a second extension check on the file, to see if it has a matching prefix, before assigning that to the "codec" info field. I don't even know if OpenMPT has a simple format detection, I'd shove that in codec instead.

 
SimplePortal 1.0.0 RC1 © 2008-2019