Skip to main content
Topic: How do I specify WASAPI Default as the output device ?  (Read 820 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

How do I specify WASAPI Default as the output device ?

I have this peculiar problem where I turn TV off while playing music through foobar from my PC to Sony receiver and the music stops playing a few moments after the TV is turned off. Apparently Sony receiver identifies itself with the TV's name when TV is on and as Sony when TV is turned off.

The WASAPI plugin doesn't have an entry for WASAPI Default like Kodi and others applications do. So I am forced to select the receiver from the list of WASAPI devices displayed for the output. Since the device name changes when TV is turned off it displays an error message along with the configuration dialog with Output tab displayed, prompting me to select the output device.

Is there any other plugin that would let me select WASAPI Default as the output device ? Or any other work around ?

Thanks

Re: How do I specify WASAPI Default as the output device ?

Reply #1
There is no explicit "Default" generic device ID, instead the component must ask what the default is every time it opens the output for playback.

I see Kodi's WASAPI sink implements this, though. It shouldn't be hard for Peter to do something about this, if he has time.

Re: How do I specify WASAPI Default as the output device ?

Reply #2
Thanks Kode54.

Up until a couple of weeks ago I was using Onkyo receiver and had no issues with it at all. The device identifier was consistent regardless of the TV. The Sony receiver I bought apparently disguises itself as the TV when TV is on and identifies itself only when the TV is off !

So, I guess a default handler would prove be useful, that way there is no need to change the device in every app, but in the Windows Playback Devices only.

I am not sure how to contact Peter ?

Re: How do I specify WASAPI Default as the output device ?

Reply #3
Is this still not possible?

I'm using Foobar 1.5.4 and while with DirectSound one can choose "Primary Sound Driver", there's no such thing for WASAPI.

Since I use other tools to switch main device according to my needs (speakers, headphones), with just a double click on relevant icon on desktop, it's pretty annoying to be forced to delve into menus, picking and choosing... when it could "easily" (I guess) automated.

Re: How do I specify WASAPI Default as the output device ?

Reply #4
If you install Wasapi shared output component you can select Output = "Wasapi (shared); Default Sound device"

Cheers

Re: How do I specify WASAPI Default as the output device ?

Reply #5
WASAPI shared doesn't do bitperfect output (for me, at least...)

Re: How do I specify WASAPI Default as the output device ?

Reply #6
Just add a device output dropdown to your toolbar. It probably wasn't possible when this thread was started but default UI and columns UI can both do it now.


 

Re: How do I specify WASAPI Default as the output device ?

Reply #7
You could probably make a desktop shortcut to switch to WASAPI output by command line using snotlicker's foo_run_main component? (Which is turning out to be quite useful! ;) )

Just get the speaker name exactly as it appears in the menu -

Code: [Select]
C:\Path\To\foobar2000.exe /run_main:"Playback/Device/WASAPI (event) : Speakers (2- Realtek(R) Audio)"

Cheers

 
SimplePortal 1.0.0 RC1 © 2008-2020