Skip to main content
Topic: Biography (Read 37639 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Biography

Reply #50
Wow...Thanks...That's it!!!!
 8)

Re: Biography

Reply #51
Hello everybody,
I have the following problem. I like to use the biography view. Works also wonderful. I work with the portable version. However, if I copy the entire Foobar folder to another directory, e.g. from the external USB disk to a local directory under C: \, the artist images are neither downloaded nor displayed. Also I have in the security settings for this directory set to "everyone". Without success. The biography text works. Deleting the .ini-file no change.
Has anyone ever watched?
Many Thanks
Greetings Frank

Re: Biography

Reply #52
I couldn't actually reproduce the issue. I copied a portable install from external USB to "C:\" and it all worked. Images were in the default location. It wasn't clear what your original image location was, whether they were copied & the nature of the new location etc. With default ini settings, save paths are automatically relative to install location.

All I can currently think of is that it's a hangover from this issue that specifically effected image downloading and is easily correctable. Essentially, the utils.WriteTextFile in early releases of the JScript panel v2 series resulted in a corrupt "foo_lastfm_img.vbs" file that wouldn't save images. Try following steps 1-4 in the post. Essentially ensure Biography version 0.9.0.2 is being used. Navigate to foobar2000\yttm\foo_lastfm_img.vbs and delete the corrupt "foo_lastfm_img.vbs". Restart foobar2000. A new functional "foo_lastfm_img.vbs" should be created. You may need to use sources > force update to show images (i.e. if you've artists folders with just update.txt & no pictures).

Re: Biography

Reply #53
I'm sorry, it was my mistake.
I did not copy the folder yttm because so many files were inside.
That was the cause.
Many thanks for your effort

Re: Biography

Reply #54
Hello,
This might be me just being stupid, but all I get is "No Photo" and "No Cover". Is there something I am missing that needs to be setup additionally?

Re: Biography

Reply #55
since the installation is still coming out, no photo that I need to work? what configuration? Thank you

Re: Biography

Reply #56
solved was my internet...

Re: Biography

Reply #57
Hi I am using foobar 1.4 beta 17 with Darkone 4 modified by yourself.
I have deleted the whole appdata...yttm folder which has been recreated.
I get the biographies but no artist images?

Re: Biography

Reply #58
It sounds like a hangover of this issue that's easily correctable.

Essentially, the utils.WriteTextFile in early releases of the JScript panel v2 series resulted in an invalid "foo_lastfm_img.vbs" file that wouldn't save images. Try following steps 1-4 in the post. Essentially ensure Biography version 0.9.0.2 is being used. You may need to update it. Navigate to foobar2000\yttm\foo_lastfm_img.vbs and delete the corrupt "foo_lastfm_img.vbs". Restart foobar2000. A new functional "foo_lastfm_img.vbs" should be created. You may need to use sources > force update to show images (i.e. if you've artists folders with just update.txt & no pictures).

Re: Biography

Reply #59
New Version: JScript Biography 0.9.0.3

This is maintenance update to fix compatibility with JScript Panel 2.2.0+. There are no new features.



Re: Biography

Reply #62
Firstly, really appreciate your work.

I got an error message need to be resolved, hope you can help.
The message only occurs when playing particular albums.

Code: [Select]
Opening track for playback: "C:\muzik\library\[2001] 더 자두 - Jadu Version 0001\11. 일년만에 돌아왔네 (Happy Bitrhday To You!).mp3"
Error: Spider Monkey Panel v1.1.5 (Biography v1.0.1 by WilB)
ActiveX_Run failed:
ActiveXObject: Error code 0x800a0035

File: <main>
Line: 2343, Column: 38

Stack trace:
  images@<main>:2343:38
  getArtImages@<main>:2429:21
  Images/this.getArtImg@<main>:2369:140
  Images/this.on_playback_new_track@<main>:2374:230
  on_playback_new_track@<main>:2810:176


Code: [Select]
Opening track for playback: "C:\muzik\library\[2013] 수상한 커튼 - 아름다운 날\03. 긴 하루.mp3"
Error: Spider Monkey Panel v1.1.5 (Biography v1.0.1 by WilB)
ActiveX_Run failed:
ActiveXObject: Error code 0x800a0035

File: <main>
Line: 2343, Column: 38

Stack trace:
  images@<main>:2343:38
  getArtImages@<main>:2429:21
  Images/this.getArtImg@<main>:2369:140
  Images/this.on_playback_new_track@<main>:2374:230
  on_playback_new_track@<main>:2810:176

Re: Biography

Reply #63
Firstly, really appreciate your work.

I got an error message need to be resolved, hope you can help.
The message only occurs when playing particular albums.

Code: [Select]
Opening track for playback: "C:\muzik\library\[2001] 더 자두 - Jadu Version 0001\11. 일년만에 돌아왔네 (Happy Bitrhday To You!).mp3"
Error: Spider Monkey Panel v1.1.5 (Biography v1.0.1 by WilB)
ActiveX_Run failed:
ActiveXObject: Error code 0x800a0035

File: <main>
Line: 2343, Column: 38

Stack trace:
  images@<main>:2343:38
  getArtImages@<main>:2429:21
  Images/this.getArtImg@<main>:2369:140
  Images/this.on_playback_new_track@<main>:2374:230
  on_playback_new_track@<main>:2810:176


Code: [Select]
Opening track for playback: "C:\muzik\library\[2013] 수상한 커튼 - 아름다운 날\03. 긴 하루.mp3"
Error: Spider Monkey Panel v1.1.5 (Biography v1.0.1 by WilB)
ActiveX_Run failed:
ActiveXObject: Error code 0x800a0035

File: <main>
Line: 2343, Column: 38

Stack trace:
  images@<main>:2343:38
  getArtImages@<main>:2429:21
  Images/this.getArtImg@<main>:2369:140
  Images/this.on_playback_new_track@<main>:2374:230
  on_playback_new_track@<main>:2810:176
Update:

I tried to figure out the crash pattern. For now, what I found is that it only happens when artist's name is any one of below. Image files are existing btw. Hope it's helpful.

더 자두
두번째 달
벨 에포크 (Belle Epoque)
수상한 커튼
윤도현 밴드
테이크(Take)
크라잉 넛

Update2:

Ugh... I guess I found a solution.
After I turned on "Beta: use unicode utf-8 for worldwide language support" in the system locale setting, the issue seems resolved. But honestly, I have no idea what happened.


Re: Biography

Reply #64
I got an error message need to be resolved, hope you can help.
The message only occurs when playing particular albums.
Which system locale are you using (I assume you are on Windows 10)?

 

Re: Biography

Reply #66
Makes sense, those names appear to be Korean.


Re: Biography

Reply #68
New Version: Biography 1.1.1

REQUIREMENT: Spider Monkey Panel 1.2.1+
Optional: FontAwesome. This font is highly recommended for better rendering of certain buttons. If not installed, affected buttons fallback to a different style.

Please post discussion here.

Re: Biography

Reply #69
New Version for JScript Panel: Biography 0.9.0.4

REQUIREMENT: JScript Panel 2.2.2+

This version is intended for users who wish to continue using JScript panel. There are no new features compared with earlier 0.9.x.x versions. It's recommended that you use the latest Spider Monkey Panel version if possible, e.g., it has a newer feature set and is more actively maintained.

CHANGELOG v0.9.0.4

CHG: Renamed server settings ini file to biography_jsp.ini to avoid potential conflict with the spider monkey panel version. This will reset server settings.
FIX: Compatibility with JScript panel 2.2.2+.
FIX: Updated due to changes at lfm.

Please post discussion here.

Re: Biography

Reply #70
Thanks for the work; this all performs fine. But, when did the Allmusic and LastFM biogs become identical??? No matter which artist I choose, the wording from the two sources is exactly the same...

Re: Biography

Reply #71
Except for rare cases where the LFM site uses the AM biography, the LFM & AM bios should be different. I checked both sites and they seem to be working correctly.

Check the server settings in biography...ini. 1) Ensure you haven't set the same save locations for the two bios, which would cause them to overwrite each other and the behaviour you describe. 2) Check you haven't disabled [AUTO-FETCH] for one of the bio sources. If using the Spider Monkey panel version, server settings can simply be reset by: right click > menu > sources > server settings > reset to default.

Also by default, the bio falls back to whichever is available if only one is found. LFM requires matching the artist name as the bio usually includes all artists of the same name. AM bios only contain a single artist: so to discern artists of the same name the album name has to match as well. If the album name is missing or can't be matched at the site, a match to the track title is used instead (Spider Monkey Panel Version only).

If further discussion is required, please put it in the main discussion thread (linked above) so as to keep this thread free of clutter, so latest download links can easily be found.

 
SimplePortal 1.0.0 RC1 © 2008-2019