Skip to main content
Topic: Migrated to a new forum system (Read 24069 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Migrated to a new forum system

Reply #225
I don't suppose there is an option/add-in for searching within threads? I just realised I'm missing the search box from the bottom left of every page on the old forums.

The top-right search box has become the contextual search. So entering a query there in a thread searches the thread, entering it on a forum searches the forum. I've seen another board do this, it takes a little getting used to.

If the default text changed depending on the context it might help. Such as 'Search topic', etc.

Re: Migrated to a new forum system

Reply #226
Thanks for the pointer!

Re: Migrated to a new forum system

Reply #227
Not weird when you consider that people have only posted in about 12 topics in the last 24 hours, if that many.
My point was that it doesn't list all topics since your last visit, but maybe it's not supposed to. I'm also not sure what the "updated topics" link is supposed to do, half the time it's either empty or only contains 1-2 topics.

I'd really prefer to have a link to a list of all threads that had new posts added since my last visit, as the old forum did.

Re: Migrated to a new forum system

Reply #228
I'm having trouble understanding the Unwatch and Watch functionality. When I am logged in and viewing a thread, there is an Unwatch button. This suggests that I am watching that thread. I can click it, and it becomes Watch.

The Unwatch button appears on every thread, so apparently they are all watched by default? Is that how it is supposed to work?

What does watching a thread even mean?

Re: Migrated to a new forum system

Reply #229
Not weird when you consider that people have only posted in about 12 topics in the last 24 hours, if that many.
Which now takes two clicks to get to.

Fixed it for me with a Greasemonkey-script:
Code: [Select]
// ==UserScript==
// @name        hydrogenaudio unread
// @namespace   hydro-forum-fix
// @include     https://hydrogenaud.io/*
// @version     1
// @grant       none
// ==/UserScript==
var els = document.getElementsByTagName("A");
for(var i = 0, l = els.length; i < l; i++) {
    var el = els[i];
    el.href = el.href.replace(/hydrogenaud.io\/index.php\?action\=unread$/ig, 'hydrogenaud.io\/index.php\?action\=unread\;all\;start=0');
}

Re: Migrated to a new forum system

Reply #230
Found some other URL formatting from the previous site that currently redirect to the OP rather than the specific page.

Examples:

https://www.hydrogenaud.io/forums//lofiversion/index.php/t63984-600.html
https://www.hydrogenaud.io/forums//lofiversion/index.php/t62114-900.html
https://www.hydrogenaud.io/forums//lofiversion/index.php/t77883-1200.html

Not sure how Google handles redirects for results. Does it eventually update to the new URL or crawl the new pages and find the same result? If the latter then it wouldn't be so bad.

Re: Migrated to a new forum system

Reply #231
Fixed.

Re: Migrated to a new forum system

Reply #232
Fixed.

I notice that the fixes only affects single forward slashes rather than the (admittedly odd) double forward slashes that all the URLs from Google's results share.

Original link (doesn't redirect):


Manually changed to single forward slash (does redirect):

Re: Migrated to a new forum system

Reply #233
Where has the "report post" button gone to?

(Sorry if you've covered this).

Cheers,
David.


Re: Migrated to a new forum system

Reply #235
Thanks.

Re: Migrated to a new forum system

Reply #236
Not weird when you consider that people have only posted in about 12 topics in the last 24 hours, if that many.
Which now takes two clicks to get to.

Fixed it for me with a Greasemonkey-script:
Code: [Select]
// ==UserScript==
// @name        hydrogenaudio unread
// @namespace   hydro-forum-fix
// @include     https://hydrogenaud.io/*
// @version     1
// @grant       none
// ==/UserScript==
var els = document.getElementsByTagName("A");
for(var i = 0, l = els.length; i < l; i++) {
    var el = els[i];
    el.href = el.href.replace(/hydrogenaud.io\/index.php\?action\=unread$/ig, 'hydrogenaud.io\/index.php\?action\=unread\;all\;start=0');
}

I guess this will have to do in the meantime, thanks. On the other hand, having an extension installed to save you one click is kind of an overkill.

Another thing that has been mentioned here before (I think) was that now foobar2000's threads are also listed in the unread section. I'd prefer to be able to filter them out, as I'm not really interested in them.

Re: Migrated to a new forum system

Reply #237
Original link (doesn't redirect):


Manually changed to single forward slash (does redirect):

Both redirect here, and the result of the old redirect is probably cached by your browser, because it obeys the 301 Moved Permanently response. Safari here queries the old link for a response regardless.

Re: Migrated to a new forum system

Reply #238
There are strange character issues in old posts in https://hydrogenaud.io/index.php/topic,2645.0.html and likely elsewhere too.

It's probably got something to do with escape characters and the apostrophe in the conversion process. It could be as simple as just doing a one time scan in the database and strip out all instances of \\\ as there are precious few legitimate reasons to use three slashes.
Every night with my star friends / We eat caviar and drink champagne
Sniffing in the VIP area / We talk about Frank Sinatra
Do you know Frank Sinatra? / He's dead

Re: Migrated to a new forum system

Reply #239
Fixed with a simple SQL query.

Re: Migrated to a new forum system

Reply #240
I just noticed that two forum descriptions contain escaped quotes in the text displayed on the page. Maybe an extra \ in the forum settings?

News Subscriptions: Submit news for validation. Validated news will appear in the \"Validated News\" -forum and on the front page.

Lossless / Other Codecs: General discussion of lossless audio compression and other lossless codecs like ALAC, Monkey\'s Audio, WMA Lossless, OptimFrog, LA, LPAC, Shorten, TAK etc.

Re: Migrated to a new forum system

Reply #241
Fixed now.

Re: Migrated to a new forum system

Reply #242
I am exceedingly displeased with this change of forum. I have been a member here for more than ten years, as user AndyH-ha. I did not forget my password; something was screwed up with the new software and I am unable to sign on as I have been doing for years.

I tried the retrieve password procedure, entering my user name. Unfortunately the user name was all that was asked. It will not work because, years ago, the acceptable e-mail addresses did not include yahoo. I set up an account on a friend's business system in order to be able to join. I don't recall what that address was except that the first part of the address was "probably" andy. The account was only for getting me onto the forum, never for any other use. That business went away years ago. Therefore, what ever "password recovery" message was went out can never be retrieved as the system, and the account thereon, no longer exists.

Of course now I can't re-register as the same user because this broken system thinks I am not the person I have always been. It will, without reasonable intervention, hold my user name as unuseable for, probably, as long as the forum exists. There has to be a way to fix it  --  aside from human intransigence. Please change the AndyH-ha email address to my real email address:
ahahx@yahoo.com
so the password can be straightened out for me to use my account.

Re: Migrated to a new forum system

Reply #243
While y'all are at it please change the kode54 email address to my real email address:
kode54@cleansoap.org
so the password can be straightened out for me to use the my account. :D
Creature of habit.

Re: Migrated to a new forum system

Reply #244
Dunno, but I couldn't login with my old account (g0a). Maybe something with special chars in passwords and I couldn't reset either as I no longer have that mail address. Not that I care too much, just saying as there might be others affected.

Re: Migrated to a new forum system

Reply #245
It turns out the email address did, sort of work. The link was forwarded to me with the following message and I was able to restore balance by entering a useable password.

Is this of interest or even real?   I don't have this email in our email domain currently, but maybe we had it in a prior time when I was using a different service provider.  that account would have vanished, however, quite some time ago.

Dear AndyH-ha,
This mail was sent because the 'forgot password' function has been applied to your account. To set a new password, click the following link:

I'm glad to have provided some amusement but I find the attitude rather obnoxious.


Re: Migrated to a new forum system

Reply #246
Can we stop shrinking the http images we have posted in the past? It's easier to see the original sized image on the same page, and fetching from crowd to crowd is of least security concern.

Re: Migrated to a new forum system

Reply #247
Of course you didn't change your password. The forum change broke all existing passwords due to incompatible password hashing methods. And I will not be changing this forum's password hashing method to match IPS 2.x.

The IPS password hashing method is:

md5(md5(salt) . md5(md5(password)))

The ElkArte password hashing method uses phpass v0.3, and with this server configuration and the default calling parameters to it, if the password is not exactly 64 characters, it is first turned into an SHA-256, before being passed through phpass. phpass on this server is allowed to use its first method, Blowfish, and the default is 2^10 iterations.

I will not be supporting fallback on the insecure method.

As for shrinking http:// images, that is because the server does not keep local copies of the full size images it proxies. If you want full size images, change the links to https. Or maybe convince web browser products not to consider mixed content degraded security.

Progress may or may not be made in the realm of detecting when a user's email address no longer functions, by detecting bounced messages on the server and notifying the user through the web page. I will update as I hear more on that.

Re: Migrated to a new forum system

Reply #248
As for shrinking http:// images, that is because the server does not keep local copies of the full size images it proxies. If you want full size images, change the links to https.
I cannot change the links posted by Guruboolez, but I would like to see his excellent readability being kept. If you can keep the thumbnails, you can also keep local copies of the full size images and discard thumbnails. Full size images occupy less server storage. Look at the images of those listening tests and compare the file size.
http://wiki.hydrogenaud.io/index.php?title=Private_Listening_Tests

Re: Migrated to a new forum system

Reply #249
The forum started logging me out every time I restarted my browser (despite me selecting the option to stay logged in permanently). I went to wipe the site's cookies to try and fix it and found it had created 150 cookies (basically one for each thread I had been on). Is that really necessary? Anyway, I wiped all the cookies and now it is remembering my login state properly.

The forum change broke all existing passwords due to incompatible password hashing methods.
Did it really break all passwords? I'm still logging in with the same one.
.

 
SimplePortal 1.0.0 RC1 © 2008-2018