Skip to main content
Topic: Song rating disappears when played (Read 778 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Song rating disappears when played

What the title says. I have no idea why this happens, and it's very annoying because I love to rate my music.
Any ideas on how to fix it?

Thanks in advance!

Song rating disappears when played

Reply #1
Pretend you're someone else for a moment and read that post. How are you going to help this person in need when they've provided no information at all about their setup.

Song rating disappears when played

Reply #2
I can't think of anything else to do that. This is what happens.

1. Rate track
2. Play track
3. Rating is gone

I have no idea of what might have caused it, so I ask in case anyone here has been through a similar situation of foobar deleting tags on playback.

This is the message that appears on the console when I play the file
Quote
Opening track for playback: "E:\Music\Amon Tobin\1997. Bricolage\08 - Amon Tobin - The Nasty.mp3"

And here it's when the tag gets removed approximately one minute after playback
Quote
Reopening played file after update: "E:\Music\Amon Tobin\1997. Bricolage\08 - Amon Tobin - The Nasty.mp3"


Song rating disappears when played

Reply #4
Probably related to foo_playcount taking over %rating%.
http://wiki.hydrogenaud.io/index.php?title...es_of_confusion

Use $meta(rating) wherever applicable instead of %rating%.


I'm using $meta(rating) to display the ratings, but the tags keep being deleted and don't know how to stop it. Is there a way to disable foo_playcount to update the %rating% tag or do I need to uninstall it?

Song rating disappears when played

Reply #5
What are you using to tag said RATING field?

What does right clicking a track/properties show? Namely do you see a RATING field on the metadata tab? What about the properties tab (within the properties window)? Does it show rating in the playback statistics group next to played, first played, last played etc?

Song rating disappears when played

Reply #6
What are you using to tag said RATING field?

What does right clicking a track/properties show? Namely do you see a RATING field on the metadata tab? What about the properties tab (within the properties window)? Does it show rating in the playback statistics group next to played, first played, last played etc?


Manually. Going to the properties box of the song and writing a number in the Rating field.
Yes, there's a field with a RATING name. It says nothing about a rating on the properties tab though, so no, it's not next to any of the fields you mentioned.

Song rating disappears when played

Reply #7
Is there a way to disable foo_playcount to update the %rating% tag or do I need to uninstall it?


It's off by default so if this is the cause of your problems, you must have enabled it previously

File>Preferences>Advanced>Tools>Playback statistics.

If you don't want to turn if off because you want play counts and the other stuff written to your files, then you should use foo_playcount to rate as well.

By the way, specifying that you were tagging your files manually but also had foo_playcount installed was the kind of information I was asking for in my first reply. Hopefully you will now understand how useless your first post was.

Song rating disappears when played

Reply #8
Is there a way to disable foo_playcount to update the %rating% tag or do I need to uninstall it?


It's off by default so if this is the cause of your problems, you must have enabled it previously

File>Preferences>Advanced>Tools>Playback statistics.

If you don't want to turn if off because you want play counts and the other stuff written to your files, then you should use foo_playcount to rate as well.

By the way, specifying that you were tagging your files manually but also had foo_playcount installed was the kind of information I was asking for in my first reply. Hopefully you will now understand how useless your first post was.

Yes, that was it! Thanks a lot!
It didn't cross my mind the idea of tagging the files in a way it wasn't manually, so I'm sorry for that haha

 
SimplePortal 1.0.0 RC1 © 2008-2020