Skip to main content
Topic: Text Display (foo_textdisplay) (Read 165767 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Text Display (foo_textdisplay)

Reply #200
Try changing LargeFieldsConfig.txt and see if that helps.

Re: Text Display (foo_textdisplay)

Reply #201
Try changing LargeFieldsConfig.txt and see if that helps.

Ah, that would be the one I'd say, given 1900 characters were displayed while idle but not more (in mine the max is set to '2000'). Had forgotten it was configured in a standalone file.

Re: Text Display (foo_textdisplay)

Reply #202
I'm having the same issue with a dot being displayed, instead of lyrics in the Text Display panel. I have removed the lyrics and unsynced lyrics entries from the LargeFieldsConfig.txt

Screenshot: https://i.imgur.com/lH2nOmo.jpg

Anything else I could try?
I only recently updated foobar from some pre 1.0 version. I'm on win7x64, foobar 1.4 beta 8.

Re: Text Display (foo_textdisplay)

Reply #203
Update: I have noticed that if "Prefer playing track" is enabled, the lyrics -do- show. Disabling it again shows the dot again. So it seems like this is a bug within Text Display. Ironically this seems to be rather similar to a bug I reported 10 years ago after the initial release. How time flies.

I doubt that this component is still under development though, so I suppose this workaround is as good as it gets.

Cheers

Re: Text Display (foo_textdisplay)

Reply #204
IMO, a text display component is absolutely essential and should be part of foobar's native basic installation.

Re: Text Display (foo_textdisplay)

Reply #205
Let's just hope the legendary @foosion gets to see this ! ;)

 

Re: Text Display (foo_textdisplay)

Reply #206
Anyone know if there's a solution to this little annoyance? It's easier to explain with screenshots.

The text displayed changes according to whether an item is playing or selected etc, and it works fine when the "prefer playing track" option is checked, but not when it's unchecked.

When a track is playing it looks like the first screenshot.
When there's no track playing or selected and "prefer playing track" is checked, it behaves as I'd hoped. See the second screenshot.
But when there's no track playing or selected and "prefer playing track" is unchecked, it displays as per the third screenshot.

It's only a minor annoyance but I'm still learning when it comes to fb2k's syntax, so I'm wondering if there's a way around it I'm not yet aware of. The syntax for the orange text in the screenshots is below (that's what I'm trying to fix if I can). Is there a better way to do it?

Thanks.

Code: [Select]
>>>$if(%filename%,$if(%isplaying%,Currently Playing Track,Selected Track),No Track Playing Or Selected)<<<

 
SimplePortal 1.0.0 RC1 © 2008-2018