Skip to main content
Topic: Big CPU Usage 'Spikes'......? (Read 4041 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Big CPU Usage 'Spikes'......?

Using v0.667 and every few seconds Foobars CPU usage jumps to about 22%. The rest of the time its close to zero. Why is this? What can be done?

Running Win2k SP3.

Thanks.


Big CPU Usage 'Spikes'......?

Reply #1
kX drivers are one known cause for this, you might want to check this thread.

Big CPU Usage 'Spikes'......?

Reply #2
OK, I admit I'm stoopid! All this talk of KX drivers etc baffle me. I've read the thread and can't ascertain if it's possible to resolve this CPU usage problem. I've got foobar 667 running at default settings on win2k sp3, SBlive! latest drivers etc.

If somebody could clear this up for me I'd be most grateful!

Thanks.


Big CPU Usage 'Spikes'......?

Reply #3
that link doesnt work, does anyone know where it is? (or the fix?)

Big CPU Usage 'Spikes'......?

Reply #4
Just be sure it isn't a driver/etc issues by using the 'null output' option 1st
You can fool some of the people all of the time, and all of the people some of the time, but you can not fool all of the people all of the time.

- Abraham Lincoln


Big CPU Usage 'Spikes'......?

Reply #6
Okay, being stoopid again maybe....but can somebody point me in the direction of the 'null output' option?

Thanks!


Big CPU Usage 'Spikes'......?

Reply #7
Quote
Okay, being stoopid again maybe....but can somebody point me in the direction of the 'null output' option?

Thanks!


Foobar2000 --> Preferences --> Playback --> Output --> Output method = Null output
You can fool some of the people all of the time, and all of the people some of the time, but you can not fool all of the people all of the time.

- Abraham Lincoln

Big CPU Usage 'Spikes'......?

Reply #8
The null output option is in preferenced --> output the select the pulldown menu and it should be there.

I'm not sure if it's only included in cases special installer if it is take a look here for it

0.7 special install

Saint
"If you cannot read this, please ask the flight attendant for assistance."
- United Airlines Flight Safety Brochure

Big CPU Usage 'Spikes'......?

Reply #9
Am using v667 and the 'null' option doesn't appear to be present!?



Big CPU Usage 'Spikes'......?

Reply #11
Downloaded that foo_null file and stuck it in my foobar folder. Still no option present in the program, but foo_null is now shown as a loaded component. Still getting the infamous CPU spikes. Any more ideas?

Thanks for your help guys!


Big CPU Usage 'Spikes'......?

Reply #12
...

Big CPU Usage 'Spikes'......?

Reply #13
Quote
Downloaded that foo_null file and stuck it in my foobar folder. Still no option present in the program, but foo_null is now shown as a loaded component. Still getting the infamous CPU spikes. Any more ideas?

Thanks for your help guys!


To use foo_null you need to choose it as the sound output device/plugin.

Big CPU Usage 'Spikes'......?

Reply #14
Check Preferences->Diskwriter option Output format (select Speed Meter).
To start measurement, right-click on the file, select Convert->Run conversion.
You can check processing time in console. (menu Components->Show Console)

But... you can also check Preferences->Output and select Null Output.
Then play the file normally and check if the problem is still there.
ruxvilti'a

Big CPU Usage 'Spikes'......?

Reply #15
Oh yeah, that's why I stopped distributing foo_output_null.

Big CPU Usage 'Spikes'......?

Reply #16
Right. Under no circumstances can I get  the null option to display. Only options under Preferences->Output  are kernel streaming, waveout and directsound. Did the run conversion thang and it generally takes 4500 miliseconds or so. There is no mention of 'processing time'.

Any more for any more?

Thanks!


Big CPU Usage 'Spikes'......?

Reply #17
Maybe 'Null output' is built into Foobar 0.7, but not 0.667...
ruxvilti'a

 
SimplePortal 1.0.0 RC1 © 2008-2019