Skip to main content
Topic: An artifact in opus (Read 2161 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

An artifact in opus

I found an artifact after encoding into the opus format.

The artifact appears around 5-6s in the right channel. The synthesizer sound was felt somewhat weird and pricked.
I converted the source with or without the SoX resampler, and in both cases the same artifact was heard.

Quite clear @96k. Although too subtle @128k to ABX for me , I think someone else can find the artifact @128k as well.

Here's my ABX logs.

@96k + SoX mod2 (48k)
Code: [Select]
foo_abx 1.3.4 report
foobar2000 v1.3.6
2015/01/18 19:53:11

File A: D:\Music\fripSide - only my railgun\01. only my railgun.flac
File B: D:\Music\Rip\01. only my railgun_96.opus

19:53:11 : Test started.
19:53:57 : 01/01  50.0%
19:54:12 : 02/02  25.0%
19:54:30 : 03/03  12.5%
19:54:49 : 04/04  6.3%
19:55:14 : 05/05  3.1%
19:55:30 : 06/06  1.6%
19:55:42 : 07/07  0.8%
19:56:18 : 07/08  3.5%
19:56:54 : 08/09  2.0%
19:57:26 : 08/10  5.5%
19:58:11 : 09/11  3.3%
19:59:24 : 09/12  7.3%
19:59:44 : 09/13  13.3%
20:00:09 : 10/14  9.0%
20:00:22 : 11/15  5.9%
20:01:05 : 12/16  3.8%
20:01:35 : 13/17  2.5%
20:01:55 : 14/18  1.5%
20:03:13 : 15/19  1.0%
20:03:20 : Test finished.

----------


@96k w/o SoX (i.e. Speex resampler employed in opusenc)
Code: [Select]
foo_abx 1.3.4 report
foobar2000 v1.3.6
2015/01/18 20:04:38

File A: D:\Music\fripSide - only my railgun\01. only my railgun.flac
File B: D:\Music\Rip\01. only my railgun_96_woSoX.opus

20:04:38 : Test started.
20:05:30 : 01/01  50.0%
20:05:48 : 02/02  25.0%
20:06:28 : 03/03  12.5%
20:11:04 : 04/04  6.3%
20:11:33 : 05/05  3.1%
20:11:56 : 06/06  1.6%
20:12:09 : 07/07  0.8%
20:12:42 : 08/08  0.4%
20:12:44 : Test finished.

----------
Total: 8/8 (0.4%)


@128k w/o SoX (failed)
Code: [Select]
foo_abx 1.3.4 report
foobar2000 v1.3.6
2015/01/18 20:15:00

File A: D:\Music\fripSide - only my railgun\01. only my railgun.flac
File B: D:\Music\Rip\01. only my railgun_128.opus

20:15:00 : Test started.
20:15:59 : 01/01  50.0%
20:16:32 : 02/02  25.0%
20:16:51 : 02/03  50.0%
20:17:21 : 02/04  68.8%
20:17:51 : 03/05  50.0%
20:18:09 : 04/06  34.4%
20:18:27 : 04/07  50.0%
20:18:53 : 05/08  36.3%
20:19:16 : 06/09  25.4%
20:20:46 : 07/10  17.2%
20:21:50 : 07/11  27.4%
20:22:04 : 08/12  19.4%
20:22:23 : 09/13  13.3%
20:22:36 : 10/14  9.0%
20:22:48 : 10/15  15.1%
20:24:32 : 10/16  22.7%
20:24:35 : Test finished.

----------
Total: 10/16 (22.7%)


An artifact in opus

Reply #1
Code: [Select]
Encoded with libopus 1.1.x-git


Isn't this a test build? Opus supports 44.1kHz too maybe try run a standard build of Opus.

An artifact in opus

Reply #2
Code: [Select]
Encoded with libopus 1.1.x-git


Isn't this a test build? Opus supports 44.1kHz too maybe try run a standard build of Opus.


Opus doesn't use 44.1 kHz. Any 44.1k sources will be resampled to 48k by the internal speex resampler.
The reason of using SoX resampler is to check whether the artifact is resulted from the internal speex resampler or not.

The encoder in opus-tools 0.1.9 produced the artifact as well. The file was attached.


Code: [Select]
foo_abx 1.3.4 report
foobar2000 v1.3.6
2015/01/18 22:46:24

File A: D:\Music\Rip\01._only_my_railgun.flac
File B: D:\Music\Rip\01. only my railgun.opus

22:46:24 : Test started.
22:47:02 : 01/01  50.0%
22:47:45 : 02/02  25.0%
22:48:22 : 02/03  50.0%
22:49:58 : 03/04  31.3%
22:50:12 : 03/05  50.0%
22:50:25 : 04/06  34.4%
22:51:05 : 05/07  22.7%
22:51:24 : 06/08  14.5%
22:51:47 : 07/09  9.0%
22:52:31 : 07/10  17.2%
22:53:11 : 08/11  11.3%
22:53:23 : 09/12  7.3%
22:53:42 : 10/13  4.6%
22:54:19 : 11/14  2.9%
22:54:21 : Test finished.

----------
Total: 11/14 (2.9%)



An artifact in opus

Reply #3
My biggest problem with this is that 96kbps isn't meant to be transparent, and I would say that this artifact is within what I would assume is expected of this bitrate, though it is fairly odd that it gives me a prickly sensation as well.

 
SimplePortal 1.0.0 RC1 © 2008-2019