Skip to main content
Topic: AMIP - the complete now playing plug-in (Read 207863 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

AMIP - the complete now playing plug-in

Reply #176
Can anyone give another mirror for amip_config.zip please?


AMIP - the complete now playing plug-in

Reply #178
Thank you!

By the way, where can I get more presets for mirc display? I like the 2nd preset in AMIP but I want to add Artist, Album and Title to the display and I don't understand the coding in that one 

AMIP - the complete now playing plug-in

Reply #179
There is no any place with shared presets, you need to read the docs when the site will be on-line to understand the syntax and get the variables list.

AMIP - the complete now playing plug-in

Reply #180
Is there a problem with musepack?

amip: CBR - Stereo
EncSpot 2.0: VBR - Joint Stereo

same file ...

AMIP - the complete now playing plug-in

Reply #181
Any estimates on getting a fix for things that don't have an ID3V1 tag?

I can't seem to force FB2k to write ID3v1 tags, either. This annoys me.
hi

AMIP - the complete now playing plug-in

Reply #182
Quote
Is there a problem with musepack?

amip: CBR - Stereo
EncSpot 2.0: VBR - Joint Stereo

same file ...
[a href="index.php?act=findpost&pid=378671"][{POST_SNAPBACK}][/a]

EncSport understands musepack, probably not the version used in AMIP? AMIP only uses it for mpeg files.

AMIP - the complete now playing plug-in

Reply #183
Quote
Any estimates on getting a fix for things that don't have an ID3V1 tag?

I can't seem to force FB2k to write ID3v1 tags, either. This annoys me.
[a href="index.php?act=findpost&pid=378676"][{POST_SNAPBACK}][/a]

It's a problem with id3v2 tags v2.4 and 2.3 in Unicode format, it's not specific to AMIP, other applications are also affected. It will be resolved as soon as AMIP will move to the new tag library (not sure when, though). There is also similar discussion in AMIP forum, but the site is still off-line.

AMIP - the complete now playing plug-in

Reply #184
how change hotkeys for AMIP?

AMIP - the complete now playing plug-in

Reply #185
Install AMIP Configurator (amip_config.zip), it has GUI for changing hotkeys.

AMIP - the complete now playing plug-in

Reply #186
I'm using fb2k 0.9 final and AMIP 2.53.
I tried to display the info on my Yahoo! Messenger 7.0.2.120.

Is there any way to display WavPack's bitrate?
I've tried both %br and %ABR to no avail; displayed 0 all the time.
Worked with VBR MP3 and Vorbis files, though.
Haven't tried with FLAC or OptimFROG.

Any suggestions?

Correction:
It does work, but intermittenly.
Sometimes it does, sometimes it doesn't. o.O

Anyway, this component is the very best out there.
Keep up the good work! =)

AMIP - the complete now playing plug-in

Reply #187
There are some weird problems with bitrate reporting. Read here.

I didn't manage to reproduce this problem on my machine. Read the thread linked above. If reinstalling doesn't help, send me a file illustrating the problem.

AMIP - the complete now playing plug-in

Reply #188
Thanks, problem is (somewhat) solved. =)
It doesn't show 0Kbps anymore.

Btw, I have this WavPack file reported as 810Kbps while it actually has (in its properties) 781Kbps.
Coincidentally, the next file in the same folder does have a bitrate of 810Kbps.
These two files are an encode of a single album which consists of only two tracks.

Anyway, in what kind of situation should I use %ABR?
It seems %br already report the exact same numbers (for VBR files) as %ABR.

And there's this %ver variable which outputs the whole 'foobar2000 v0.9' string when used with fb2k 0.9.
I thought for a string like that I should use %player %ver, but with that I got 'foobar2000 foobar2000 v0.9' instead.
Is this an error on AMIP's side or that fb2k doesn't return values as expected?
Btw, I used %ver for Callbacks' parameters (/yahoo %ver) if that'd be of any help.

And when changing between songs, my Y!M status sometimes turns into a Busy status.
It's pretty apparent when opening new files, not changing between tracks already present in the current playlist.
Is this AMIP's 'error' or is it that Y!M is just being lousy? =b

Last but not least, AMIP's documentation explains $lc(string) twice.
You might want to fix it. =)

Oh, and thanks beforehand.

AMIP - the complete now playing plug-in

Reply #189
i have a problem with AMIP. i installed it and it works brilliantly but something is up with the AMIP Configurator. when i previously had it(i reinstalled foobar2000), when i went to preferences > Tools > AMIP Wrapper > Configure AMIP, it oppened the AMIP Configurator. but now, it doesn't and keeps saying that the default thing is outdated. but the problem is, the AMIP Configurator is already installed.

AMIP - the complete now playing plug-in

Reply #190
Have you tried reinstalling the stand-alone AMIP Configurator?

AMIP - the complete now playing plug-in

Reply #191
twice

nvm: i tried reinstalling again and it finally worked. i must have installed an old version of it or something.

AMIP - the complete now playing plug-in

Reply #192
Ok then. =)

Anyway, another question for Serge.
It seems whenever there exist both ID3v1 and ID3v2 tags in a file, it prefers to read the ID3v1 tag.
Is there any way to override AMIP so it'd read the ID3v2 tag instead?

AMIP - the complete now playing plug-in

Reply #193
that would be VERY usefull for songs with large titles and since i have a bunch of Nile songs, it cuts the title off.

AMIP - the complete now playing plug-in

Reply #194
Btw, I have this WavPack file reported as 810Kbps while it actually has (in its properties) 781Kbps.
Coincidentally, the next file in the same folder does have a bitrate of 810Kbps.
These two files are an encode of a single album which consists of only two tracks.


Hmm, I'll check it, probably incorrect index is used when I look for track bitrate. Thanks for reporting.

Anyway, in what kind of situation should I use %ABR?
It seems %br already report the exact same numbers (for VBR files) as %ABR.


With foobar there is no reason to use %ABR, since it already reports average bitrate. But some players don't do so, in this case for mpeg files AMIP uses EncSpot library that calculates average bitrate.

And there's this %ver variable which outputs the whole 'foobar2000 v0.9' string when used with fb2k 0.9.
I thought for a string like that I should use %player %ver, but with that I got 'foobar2000 foobar2000 v0.9' instead.
Is this an error on AMIP's side or that fb2k doesn't return values as expected?
Btw, I used %ver for Callbacks' parameters (/yahoo %ver) if that'd be of any help.


This one is a known problem. I was too lazy to extract just version number from the version string returned by foobar API, so I'm just passing the entire string, with foobar use just %ver. Maybe in the future versions I'll change it for consistency.

And when changing between songs, my Y!M status sometimes turns into a Busy status.
It's pretty apparent when opening new files, not changing between tracks already present in the current playlist.
Is this AMIP's 'error' or is it that Y!M is just being lousy? =b


I don't know, maybe there are some special chars that Yahoo recognizes as status change.

Last but not least, AMIP's documentation explains $lc(string) twice.
You might want to fix it. =)


Thanks, fixed.

Anyway, another question for Serge.
It seems whenever there exist both ID3v1 and ID3v2 tags in a file, it prefers to read the ID3v1 tag.
Is there any way to override AMIP so it'd read the ID3v2 tag instead?


AMIP always prefers id3v2 tag. The problem you have is probably related to the version of you id3v2 tag (2.4), Unicode encoding of the tag or some other factor that breaks id3lib reading of id3v2 tag. I can't do much about it right now, but it should be probably fixed when I'll move to another tagging libary.

AMIP - the complete now playing plug-in

Reply #195
Btw, I have this WavPack file reported as 810Kbps while it actually has (in its properties) 781Kbps.
Coincidentally, the next file in the same folder does have a bitrate of 810Kbps.
These two files are an encode of a single album which consists of only two tracks.

Hmm, I'll check it, probably incorrect index is used when I look for track bitrate. Thanks for reporting.
This is a log that AMIP created (using Callbacks and the /file command) :

Code: [Select]
...foobar2000 v0.9 is paused...
...foobar2000 v0.9 is stopped...
...foobar2000 v0.9 is off...
...foobar2000 v0.9 is started...
...foobar2000 v0.9 is stopped...
...Yasunori Mitsuda - Fields of Time - Home World [Chrono Cross OST - Disc One: Awakening | 03:26 | FLAC 1021Kbps 44KHz | 22.00MB]...
...Key+Lia - Natukage (Summer Shadow) [Natukage / nostalgia | 05:53 | WavPack 810Kbps 44KHz | 32.88MB]...
...Key+Lia - nostalgia [Natukage / nostalgia | 05:53 | WavPack 810Kbps 44KHz | 34.13MB]...
...foobar2000 v0.9 is stopped...
...Key+Lia - nostalgia [Natukage / nostalgia | 05:53 | WavPack 810Kbps 44KHz | 34.13MB]...
...Key+Lia - nostalgia [Natukage / nostalgia | 05:53 | WavPack 810Kbps 44KHz | 34.13MB]...
...Yasunori Mitsuda - Chrono Cross - Scars of Time [Chrono Cross OST - Disc One: Awakening | 02:29 | FLAC 1021Kbps 44KHz | 16.49MB]...
...Yasunori Mitsuda - Deadline [Chrono Cross OST - Disc One: Awakening | 02:38 | FLAC 1027Kbps 44KHz | 19.34MB]...
...Yasunori Mitsuda - Aruni - Home [Chrono Cross OST - Disc One: Awakening | 03:23 | FLAC 1021Kbps 44KHz | 17.88MB]...
...Yasunori Mitsuda - Fields of Time - Home World [Chrono Cross OST - Disc One: Awakening | 03:26 | FLAC 1021Kbps 44KHz | 22.00MB]...
...Yasunori Mitsuda - Lizard Dance [Chrono Cross OST - Disc One: Awakening | 02:41 | FLAC 1021Kbps 44KHz | 17.27MB]...
...Yasunori Mitsuda - Reminiscing - Forgotten Memory [Chrono Cross OST - Disc One: Awakening | 03:25 | FLAC 1021Kbps 44KHz | 13.39MB]...
...Yasunori Mitsuda - On the Beach of Dreams - Another World [Chrono Cross OST - Disc One: Awakening | 02:22 | FLAC 1021Kbps 44KHz | 11.93MB]...
...Yasunori Mitsuda - Deadline [Chrono Cross OST - Disc One: Awakening | 02:38 | FLAC 1027Kbps 44KHz | 19.34MB]...
...foobar2000 v0.9 is paused...
...foobar2000 v0.9 is off...
Key+Lia is the two tracks single album I reported earlier.
As expected, both tracks are being reported as 810Kbps while only the second track is.

With some Chrono Cross OST (Disc 1) tracks it's getting interesting.

I've played the first few files and all is being reported 1021Kbps.
They're not.
The funny thing is, the track (Yasunori Mitsuda - Deadline) which bitrate is actually 1021Kbps is being reported as having 1027Kbps.

This is the format (or command) I used for logging :

Code: [Select]
/file:(C:\amip.log) ...$if(%id3,%1 - %2 $if(%4,[%4 |,),$if(%ape,%1 - %2 $if(%4,[%4 |,),$if(%flactag,%1 - %2 $if(%4,[%4 |,),%nm))) $if(%4,,[)%min:%sec | $if(%mpc,MusePack,$if($mat(%ext,ogg),Vorbis,$if(%flac,FLAC,$if(%mac,Monkey's Audio,$if($mat(%ext,ofr),OptimFROG,$if($mat(%ext,wv),WavPack,$uc(%ext))))))) %br~Kbps %sr~KHz | %fl~MB]...
The general format is like this :
[!--sizeo:1--][span style=\"font-size:8pt;line-height:100%\"][!--/sizeo--]*artist* - *title* [*album* | *duration* | *format* *bitrate* *samplerate* | *filesize*][/size]

If no tags are present :
[!--sizeo:1--][span style=\"font-size:8pt;line-height:100%\"][!--/sizeo--]*filename* [*duration* | *format* *bitrate* *samplerate* | *filesize*][/size]

Please note that it's the same format (excluding /file command, of course) I used to display the now playing info on my Y!M status.
Hope that'd help you in rectifying the problem.

AMIP - the complete now playing plug-in

Reply #196
Bitrate problem has been fixed in 2006-04-10 beta, changes since last beta:
* fb2k-0.9: %br and %sr were retrieved from the wrong playlist item (not currently playing)
* fb2k-0.9: %ver now returns only number (0.9 instead of foobar2000 v0.9), to get player name use %player

AMIP - the complete now playing plug-in

Reply #197
Ok, I've tested the new beta.
Bitrate is now displayed properly.
Thanks for the quick fix! =)

I might be asking too much, but could you implement an OR for the if() conditional function?
Or maybe an additional OR function like $or().
So instead of :

Code: [Select]
$if(%id3,%1 - %2 $if(%4,[%4 |,),$if(%ape,%1 - %2 $if(%4,[%4 |,),$if(%flactag,%1 - %2 $if(%4,[%4 |,),%nm)))

I could just write :

Code: [Select]
$if($or(%id3,%ape,%flactag),%1 - %2 $if(%4,[%4 |,),%nm)

...which is simpler.
Note that the $or() function could take an arbitrary number of arguments, depends on how many arguments you'd like to compare.
i.e $or(a,b), $or(a,b,c,d), even one that doesn't make sense like $or(a), etc.

Anyway, still waiting for a new tagging library incorporation, but take your time.
At the moment, everything is fine and dandy.

AMIP - the complete now playing plug-in

Reply #198
You may want to use foobar2000 formatting in AMIP Wrapper options, it has more functions and options, in AMIP you can just use %s for the foobar formatted string. This should also solve the problem with tags.

Anyway, thanks for the suggestion, I'll consider it.

AMIP - the complete now playing plug-in

Reply #199
Well, actually, I'm thinking of using AMIP for other computers which users have never heard about fb2k (read: Winamp users).
So, I prefer to just configure AMIP and make the best use of it.
Besides, Winamp isn't as flexible as fb2k in term of title formatting.

Btw, I could just copy the plugin.ini over to Winamp's plugin folder, right?

 
SimplePortal 1.0.0 RC1 © 2008-2020