Skip to main content
Topic: foo_onewaysync (Read 42054 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: foo_onewaysync

Reply #275
Thanks tipar!  :D  If you don't mind I will share the link and credit you in the first post.

It is OK, Firefox did not let me enter the forum in the previous Mozilla update, I just waited until I could, sorry for the delay. Regards.
Yes, the avatar it is the cover of «The City» by Vangelis.

Re: foo_onewaysync

Reply #276
That was due to a certificate issue that was not taken care of while it would have been possible to transition seamlessly. The paid certificate was allowed to expire, and the server was configured to pin the certificate vendor that paid certificate came from. What should have happened, is the pinning should have been reduced or even removed two weeks before expiration, so that a seamless transition could occur when the certificate finally expired.

The only alternative for existing users was to either clear their HPKP settings file of any references to this domain, which was fairly straightforward, if not annoying, for desktop browsers, while quite troublesome for mobile browsers. Or wait out the two weeks.

Re: foo_onewaysync

Reply #277
The addon fails to sync crashing with a null pointer error whenever there is any playlist to sync. If there are no playlists checked for the task, the addon completes with "Exported files and playlists succesfully. 0 playlists exported. 0 files converted. 0 files updated."

I have uninstalled, deleted the addon configuration, and reinstalled the addon, and this still happens.

Crash log and dump attached.

Re: foo_onewaysync

Reply #278
The addon fails to sync crashing with a null pointer error whenever there is any playlist to sync. If there are no playlists checked for the task, the addon completes with "Exported files and playlists succesfully. 0 playlists exported. 0 files converted. 0 files updated."

I have uninstalled, deleted the addon configuration, and reinstalled the addon, and this still happens.

Crash log and dump attached.
I think I figured it out. I had added .cue-files that pointed to non-existing files to my playlists by accident. Probably the component tries to stat every file in the playlist and gets an unexpected null value when it's a cue pointer? I tried with some dead items in the playlist and they didn't crash anything.

Re: foo_onewaysync

Reply #279
Thanks for the detailed bug report. Makes my life easier :)

Fixed with new release 0.6.3b.

Re: foo_onewaysync

Reply #280
Hello,
I've encountered the known problem which mismatches metadata and files in my device - some files end up in the wrong path, some get incorrect metadata after conversion, and some files suffer from both symptoms.
I have version 0.6.3a of the component.

Is there a way to solve this problem?

Re: foo_onewaysync EMPTY PLAYLIST

Reply #281
I am new to all of this and just trying to synch playlists to my AGPTEK A05 mp3 player.  When I select all the files in an established FOO playlist; right click and go through synch process, the music files are downloaded , neatly organized in files by album, and show up in the navigation on the AGPTEK.  The named playlist does show up under playlists, however, when I click on it it says no files.  No files were associated with the list.  There is an .m3u file on the device with playlist name,  but it is only 1 KB size.  What am I doing wrong?

Thanks.

Re: foo_onewaysync

Reply #282
Hello,
I've encountered the known problem which mismatches metadata and files in my device - some files end up in the wrong path, some get incorrect metadata after conversion, and some files suffer from both symptoms.
I have version 0.6.3a of the component.

Is there a way to solve this problem?
Do you have large playlists? How many threads do you use?
Try cleaning up temporary files in Windows, maybe this will improve the situation, but I doubt it. Also try limiting the number of conversion threads to one and see if this fixes the problem.

Re: foo_onewaysync

Reply #283
No files were associated with the list.  There is an .m3u file on the device with playlist name,  but it is only 1 KB size.  What am I doing wrong?

Thanks.
Is the player connected via MTP? You can tell by the first letters of the device path in OWS, if they are 'wpd' it is connected via MTP.
Files on MTP devices can not be modified. This is not a limitation of OWS or foobar, but of windows.

To work around this, you can set up a OWS sync command. Or you first export to your hard drive and copy files manually to your mp3 player.

Re: foo_onewaysync

Reply #284
Do you have large playlists? How many threads do you use?
Try cleaning up temporary files in Windows, maybe this will improve the situation, but I doubt it. Also try limiting the number of conversion threads to one and see if this fixes the problem.

Yes, to be frank I only have one playlist with all my music in it... 3082 items. I use 3 threads, that's the maximum the plugin will let me.
Will try to clean the temp folder and limit the threads to 1 and see what I get.

Thanks!

Re: foo_onewaysync

Reply #285
Okay, I have tried to limit the conversion threads to 1, and it didn't help...
I think something is messing with my temp folder but I'm not sure what. I will try to configure my temp folder to another drive and try again, and will report back.
Also I have attached the debug info from foobar's log (password protected - sent you a PM with the password) If it's any help.

Thanks a lot :)

Re: foo_onewaysync

Reply #286
Okay, I have tried to limit the conversion threads to 1, and it didn't help...
I think something is messing with my temp folder but I'm not sure what. I will try to configure my temp folder to another drive and try again, and will report back.
Also I have attached the debug info from foobar's log (password protected - sent you a PM with the password) If it's any help.

Thanks a lot :)

Tried again with a different temp folder on a different drive (previously was on a SSD, now on a HDD), but still errors occur.
The mismatched files are different every time so it's probably not a problem with specific files.

Any clue to what's going on?

Re: foo_onewaysync

Reply #287
@Pok_Madui if you are on Win10, please do check the following windows settings:
I didn't even know there was a "Storage sense" setting in Windows 10. Thank you for letting me know about it. I turned it off, and also turned off a seemingly related setting I found right under the Storage sense setting, labeled "Delete temporary files that my apps aren't using".

This seems to be a good temporary workaround for the problem, but I hope you can come up with a better, long-term solution for this, since I'm sure everyone else with similar setup as me (SSD users or people with smaller HDDs) will appreciate having this fixed, too.

Thank you in advance for your work.


Re: foo_onewaysync

Reply #289
Release 0.6.4 hopefully fixes these issues for good  :)


Re: foo_onewaysync

Reply #291
I'm happy to report that I've tried syncing to my phone again, and so far I haven't found any problems!

Thanks zimjo for all your support and hard work and for this awesome plugin, it really makes the process of syncing to my phone as simple as (literally) pressing a button  :D



 
SimplePortal 1.0.0 RC1 © 2008-2018