Skip to main content
Topic: foo_youtube (Read 180531 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: foo_youtube

Reply #975
Hm, seems like Marc2k3 is secretly following here :-)
@Marc: THANKS VERY MUCH FOR SOLVING THIS!!  :)  :)

PS: solved with V2.1.6 of foo_jscript_panel, see here

Re: foo_youtube

Reply #976
PPS: coming back one day?

Re: foo_youtube

Reply #977
Is there a way to save a video's audio stream using this plugin without re-encoding it via the convert feature in foobar? Thank you for this great plugin!

If you convert it to mp3, or any other format, you loosing quality.
Mp3 is compromise, that bring smaler size and compressed sound, but that loss in quality human ear can not hear. You will not be able to hear the difference. So i dont see point to save high possible sound. Especially because youtube videos already have encoded audio sound, so audio within M4A file extension that youtube use, is typically encoded with AAC lossy compression. So you already have lossy format..

Anyway..

If you want to save highest possible sound from youtube, you should select video and then: convert > ... > output format > edit > encoder > custom ,  and you should use "ffmpeg.exe" or some other encoder, that extracts "separates audio from the video"..

See this:  https://www.tech-g.com/2012/04/19/extracting-audio-from-youtube-files-without-loss-of-quality/

I think this is possible within foobar, you only must set right parameters....


Re: foo_youtube

Reply #979
I'm trying to play some videos offline and looks like it always use software decoding. LAV Filters set to managed. Is there a way to enable hardware decoding? Regards :)

Re: foo_youtube

Reply #980
Seems like Foobar-YoTube, are skipping some songs for me.

When I go to links of song, to check if they are broken, then I come to a YouTube, "bla bla mature content" if song has some kind of bad lyrics or video, and I have to "accept" to continue to see video.

Either way, is there any way one could get YouTube plugin to bypass this and play the song ?

example.
https://www.youtube.com/watch?v=3jkF0-g01f8&bpctr=1532418259

"Certain features have been disabled for this video
In response to user reports, we have disabled some features, such as comments, sharing and suggested videos, because this video contains content that may be inappropriate or offensive to some audiences."

Re: foo_youtube

Reply #981
foobar2000 crash when I open Video window with Classic UI being used. foobar2000 v1.4, Classic UI v1.1, Windows 10 64-bit. Regards.

Re: foo_youtube

Reply #982
Can I somehow move "foo_youtube" folder to other location?

I tried to set path in: preferences > advanced > tools > youtube source > network > temporary directory > %fb2k_profile_dir%\Cache\foo_youtube

But nothing happens?
Temporary directory is used for temporary files. There are no way to override directory used for cache.

Is there a way to save a video's audio stream using this plugin without re-encoding it via the convert feature in foobar?
No.
To elaborate, AFAIK there are no separation of demux stage from decoding process. Without this it is not possible to remux files, only re-encode.

foobar2000 crash when I open Video window with Classic UI being used. foobar2000 v1.4, Classic UI v1.1, Windows 10 64-bit. Regards.
Cannot reproduce. You may send crash report to fy@3dyd.com

Re: foo_youtube

Reply #983
I'm trying to play some videos offline and looks like it always use software decoding. LAV Filters set to managed. Is there a way to enable hardware decoding?
Local filters use so-called RunTime Config Mode, when all settings are defaulted. This is done on purpose. There are no way to display filter properties page of local unregistered filter (it will display properties page of the filter registered in the system). And there are no sane way to store filter settings locally (i.e. all changes will be stored globally in the system). All this could result in unexpected behaviour, especially when versions of local and global filters are different.

Currently the only way to achieve what you want is to use "System" source.

When I go to links of song, to check if they are broken, then I come to a YouTube, "bla bla mature content" if song has some kind of bad lyrics or video, and I have to "accept" to continue to see video.

Either way, is there any way one could get YouTube plugin to bypass this and play the song ?
Since Youtube does not force sign-in for such videos, there is a chance that this restriction can be bypassed in further versions.

Re: foo_youtube

Reply #984
Great

Hope for that feature in future, keep up the great work with this awesome plugin.


Re: foo_youtube

Reply #986
foobar2000 crash when I open Video window with Classic UI being used. foobar2000 v1.4, Classic UI v1.1, Windows 10 64-bit. Regards.
@arch21, got your crash report, thanks. Answering here as you asked.
Bug seems to be in seekbar drawing code. Possible workarounds for now: disable seekbar (component preferences -> Video tab -> Show seekbar -> Never) or switch to other UI (bug persists only when foo_ui_classic is used).

@Sergey77
see here.

Re: foo_youtube

Reply #987
Hi!
@3dyd,
1. Do You plan to activate the "Activity" panel when playing local video files?
Now the "Activity" panel works only when playing video from Youtube.
2. @musicmusic and 3dyd, note the following please:
When using "Search (Integrated)" panel the end line of the playlist looks strange in CUI (see attached pic.)
At the end of the playlist should be "...get more" like at popup window "Search on Youtube".
Сould You comment on this?

Thanks!

Re: foo_youtube

Reply #988
1. More precisely, it is enabled for http and https URLs. I guess, initially local files were not added there because it was primarily used to track outgoing connections. I will enable Activity for local files.

2. This is by design. Read Clip properties mapping topic for details.

Re: foo_youtube

Reply #989
@3dyd
Yes,In china I also can playback the youtube videos on foobar2000,This must be set:Advanced>Tools>youtube source>network>proxy like "hostname[:port]" only.Thanks for  The Great plugin.

Re: foo_youtube

Reply #990
I think 403's have returned. Thank you for this plugin @3dyd.

Re: foo_youtube

Reply #991
Yepp, can confirm 403:s

Re: foo_youtube

Reply #992
403 Russia / Siberia :-)
Win XP SP2 foo_youtube 2.2.2 beta 1

Re: foo_youtube

Reply #993
Thanks for notifications. Fix should be available shortly.

Re: foo_youtube

Reply #994
Thanks for notifications. Fix should be available shortly.

Thank you, can you please add "auto-update" to the plugin? "Get updates" button in Components panel only works for plugins downloaded from foobar2000's official plugin site.

Re: foo_youtube

Reply #995
will you update to latest SDK?
latest beta fix the issue with CUI. thanks.

 

Re: foo_youtube

Reply #996
Yes. Next major update will be built with new SDK.

@Hidrojen
If nothing unforeseen happens, starting from next major update I will be posting release versions also in official 3rd party components repository. So it will be possible to get updates using regular way.

Re: foo_youtube

Reply #997
@3dyd, thank you for new version of foo_acfu!
and of course we look forward to your next major update of foo_youtube.
I remember the "Component unlikely will have embedded support for other sites", but I also unlikely will to use anything other than foo_youtube :)
All the same if there is an opportunity, could you improve the synchronization of video and audio when playing streaming video?
Most often the sound is ahead of the video. Sometimes from the beginning of playback and sometimes gradually.
Use of the options "Synchronize playback" and "Synchronize video" doesn't solve the problem.
Also usually a video starts to playback then freezes for a few seconds then the playback continues (noted for streaming video only)
It would be great to solve that issue.

Thanks!

Re: foo_youtube

Reply #998
Foobar2000 already supports Avisynth scripts (plays audio). But the plugin does not recognize them as video files. Is there a way to make the plugin accept *.avs files?

Re: foo_youtube

Reply #999
@3dyd: is it possible to add `url+time` element to the context menu? For example https://www.youtube.com/watch?v=GBUCmMxmup0&t=807 (note the additional time tag). Such option is great for when you want to switch to browser-based youtube or when you want to share a link to some part of stream.

 
SimplePortal 1.0.0 RC1 © 2008-2018