Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_youtube (Read 328330 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: foo_youtube

Reply #1475
- for tracks not available, crossfading fails when jumping to next available track giving a 'hard' handover to next playable track. As this is probably difficult to cure, a tool for indentifying/removing unplayable tracks would be great
Is there any approach for a further improvement of crossfading behaviour with yt tracks? It works well when there are no 'special effects' occuring in playing the tracks of a playlist containing yt tracks. However, cross-fading fails when
- next track can not be played and foobar jumps to the track after next track. To me it looks like pre-loading of the following track for cross-fading is aborted when the next available track can not be played. Is it possible to enable further preloading attempts after first track pre-loading failed?
- manual track change ('next') -> here maybe a 'delayed next' function could help, which changes to next track after a defined timeframe, e.g. after 25s, to enable proper pre-loading for cross-fading. Is something like that available?

Probably not directly related to foo_youtube, but as a starting point... Please give me you hints if I should use another thread.

Re: foo_youtube

Reply #1476
Is it possible to display subtitles to videos played from local hard drive? Either embedded (in vob or m2ts) or external (srt, txt - for avi and other file extensions)? It works with videos played from the web (youtube) but I can't manage to do it with local files.

Re: foo_youtube

Reply #1477
wojak,try these settings:
XXX
subtitles will be displayed in how are the lyrics in foo_uie_lyrics3 0.5
Although I don't like this method :(
YouTube Music

Re: foo_youtube

Reply #1478
wojak,try these settings:
[attach type=thumb]21713[/attach][attach type=thumb]21715[/attach][attach type=thumb]21717[/attach]
subtitles will be displayed in how are the lyrics in foo_uie_lyrics3 0.5
Although I don't like this method :(

Thanks, I used it but it is not any good. I assume it would be good for song lyrics but you can't watch movies with it.



Re: foo_youtube

Reply #1481
anyone experiencing errors when playing urls from soundcloud, mixcloud etc after updating to youtube source 3.8 stable?

Re: foo_youtube

Reply #1482
I keep getting unsupported file errors.

Edit: seems to have been fixed after changing the youtube-dl binary to youtube-dl.org (managed) and not my external yt-dlp. Wonder why that is. Strange.

EDIT2: soundcloud still keeps hitting up an unsupported file error. Have they changed something on their backend that foobar can't handle? Youtube-dl from the command line still works fine for downloading.

Re: foo_youtube

Reply #1483
Fixed (I think.) had to set the lav filters to 'system' instead of managed.

Or maybe that was not the issue. I deleted youtube-dl and then redownloaded from the managed option, instead of youtube-dl 2022-04-04 and things seem to be working fine now. Why all of this is I have no idea.

Re: foo_youtube

Reply #1484
Help set up the output of only the official video by the performer, that is, video clips and not content with a static picture, and so that it opens in a separate tab and does not create a playlist with garbage

[["%artist%"] ["%title%"] intitle:Official Video] So I tried but something doesn't work

Re: foo_youtube

Reply #1485
hi all

foo_youtube dont work
before yesterday's day all worked well

file -> add location https://www.youtube.com/watch?v=BKcY77qyMmE

in foobar Information window
The following error(s) occurred during loading of the location(s):
Connection error

windows xp SP3 foobar 1.3.20 foo_youtube 3.7.2 beta 1

advanced->networking->supress https certificate checks -> youtube.com entered

i think in foobar problem since sometimes in foo_youtube video appears and immediately stopped
possible, one of the server youtube's has included support only tls 1.2

foo_youtube has own (curl) crypto stack and he continues to work
foobar use OS crypto stack WINXP not support tls 1,2 and probably in this reason

Re: foo_youtube

Reply #1486
No problems with foo_youtube on my side, I can play your link with foo_youtube without any problems.

Re: foo_youtube

Reply #1487
i research my problem
when foobar do request (file->add location)
GET http://www.youtube.com/watch?v=vs6UfFPyssM HTTP/1.1
Host: www.youtube.com
Connection: close
User-Agent: foobar2000/1.3.20
Accept: */*
Icy-MetaData: 1

fiddler say SSL hanshake failed  and remote host refused connection
foobar do 10 attempts (preferences->advanced->network->keep reconnecting dropped connection 10 for default)
and say in foobar Information window
The following error(s) occurred during loading of the location(s):
Connection error

but! when i manually do such request with curl development kit

GET /watch?v=vs6UfFPyssM HTTP/1.1
Host: www.youtube.com
Accept: */*
Connection: close
User-Agent: foobar2000/1.3.20
Icy-MetaData: 1

response 200 OK and page content return for me

requests alike, ip alike, but response different
problen i think with HTTPS tls 1,2, foobar use crypto OS stack, but WINXP not support tls 1,2
curl development kit use own crypto stack and support tls 1,2 handshake
probable youtube server enable only tls 1,2 on own side

Re: foo_youtube

Reply #1488
is anyone struggling to play bandcamp links?

Bit of an unorthodox use for the component I'm aware but it allows me to check out new music I shall consider purchassing without bandcamp's horrid web streaming interface. It seems to have stopped working over the past week or so for me.

Re: foo_youtube

Reply #1489
for example I get this error:
Unable to open item for playback (Youtube Source: foo_youtube: Invalid data found when processing input | foobar2000: Unsupported file format | ffmpeg: Invalid data found when processing input):
"jungantagen.bandcamp.com/track/pulsar-acid-sequence-01"

What is this invalid data?

 

Re: foo_youtube

Reply #1490
Also very selective with soundcloud/mixcloud/links, when it was much less likely to through errors in the past