Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: foo_youtube (Read 273333 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: foo_youtube

Reply #1325
Or perhaps a different tag could be used for the uploader.

Re: foo_youtube

Reply #1326
Or perhaps a different tag could be used for the uploader.

I assume you're replying to me - how would that be done? I imagine it's possible to write a regular expression which just does "grab the video's title as a <title>, do nothing else". Unfortunately, I'm unable to write regular expressions as I do not have a box full of rabid squirrels to throw a keyboard into.

Re: foo_youtube

Reply #1327
Code: [Select]
Unable to open item for playback (Youtube Source: foo_youtube: server error (403) from r3---sn-u2oxu-3g3e.googlevideo.com | ffmpeg: Server returned 403 Forbidden (access denied) | foobar2000: Access denied):
"www.youtube.com/watch?v=sDHqywS6un0"

Started today for every  YT video.

Re: foo_youtube

Reply #1328
Code: [Select]
Unable to open item for playback (Youtube Source: foo_youtube: server error (403) from r3---sn-u2oxu-3g3e.googlevideo.com | ffmpeg: Server returned 403 Forbidden (access denied) | foobar2000: Access denied):
"www.youtube.com/watch?v=sDHqywS6un0"

Started today for every  YT video.
Same here. Haven't been able to get plugin to work correctly since yesterday. Tried versions 3.6, 3.6.1 and 3.7 beta 1, updated cookies and user agent, all to no avail. Using latest version of foobar2000.
Music videos on non-official accounts still play fine.


Re: foo_youtube

Reply #1330
I have with these settings works without problems 3.7 beta 1
Thanks! Changing External to Managed and checking the Prefer option did the trick. I was still having trouble with one video (which was still returning a 403), restarting foobar2000 resolved that. Now using 3.6.1.


Re: foo_youtube

Reply #1332
I have with these settings works without problems 3.7 beta 1
Thanks a lot! It really works (only with foo_youtube_3.7_beta1).
Also glad to report that this plugin works with new "YouTube Music" service. It supports playlists, artists and albums. 😊

Re: foo_youtube

Reply #1333
Code: [Select]
Unable to open item for playback (Youtube Source: foo_youtube: server error (403) from r1---sn-ab5l6nzk.googlevideo.com | ffmpeg: Server returned 403 Forbidden (access denied) | foobar2000: Access denied):
"www.youtube.com/watch?v=LvdLovAaYzM"
Receiving this error for all YouTube videos for 2+ weeks.
♫♪.ılılıll|̲̅̅●̲̅̅|̲̅̅=̲̅̅|̲̅̅=̲̅̅|̲̅̅●̲̅̅|llılılı.♫♪
  ꂵ꒐ꏳꁝꁲꑀ꒒ ꉣꊿꌅꋖꑀꌅ

Re: foo_youtube

Reply #1334
@mountwash

Try...

Help - Third-party binaries
http://fy.3dyd.com/help/third_party_binaries/

-LAV Filters
 LAVFilters-0.74.1-Installer.exe
https://github.com/Nevcairiel/LAVFilters/releases
-libcurl
 libcurl.dll
http://fy.3dyd.com/download/libcurl_7_68.7z
-youtube-dl
 youtube-dl.exe (Windows exe)
http://ytdl-org.github.io/youtube-dl/download.html
SHURE SRH1840, SENNHEISER HD660S, Beyerdynamic DT 1990 PRO, HIFIMAN HE5se, Ultrasone Performance 880, AKG K712 PRO, Bowers & Wilkins P7, SONY MDR-1AM2, Bose QuietComfort 35 wireless, SENNHEISER HD 4.50BTNC (made a Upgrade/Balanced Cable by myself)

Re: foo_youtube

Reply #1335
mountwash you have disabled LAVFilters not found
YouTube Music

Re: foo_youtube

Reply #1336
@mountwash

Try...

Help - Third-party binaries
http://fy.3dyd.com/help/third_party_binaries/

-LAV Filters
 LAVFilters-0.74.1-Installer.exe
https://github.com/Nevcairiel/LAVFilters/releases
-libcurl
 libcurl.dll
http://fy.3dyd.com/download/libcurl_7_68.7z
-youtube-dl
 youtube-dl.exe (Windows exe)
http://ytdl-org.github.io/youtube-dl/download.html
Worked! Many thanks!  :D  :D  :D
♫♪.ılılıll|̲̅̅●̲̅̅|̲̅̅=̲̅̅|̲̅̅=̲̅̅|̲̅̅●̲̅̅|llılılı.♫♪
  ꂵ꒐ꏳꁝꁲꑀ꒒ ꉣꊿꌅꋖꑀꌅ

Re: foo_youtube

Reply #1337
Checking the prefer youtube-dl option, my foobar2000 crashes very frequently. Does anyone suffer similar problems?
  • Windows 10 Pro 64bit
  • Foobar2000 v1.6
  • foo_youtube_3.7_beta1
  • youtube_dl v2020.12.12

Re: foo_youtube

Reply #1338
I had one crash with foo_youtube_3.7_beta1 then reverted back to 3.6.1 and have had no problems since.
♫♪.ılılıll|̲̅̅●̲̅̅|̲̅̅=̲̅̅|̲̅̅=̲̅̅|̲̅̅●̲̅̅|llılılı.♫♪
  ꂵ꒐ꏳꁝꁲꑀ꒒ ꉣꊿꌅꋖꑀꌅ

Re: foo_youtube

Reply #1339
foo_youtube_3. 7_beta1 I have crashes happen quite often
YouTube Music

Re: foo_youtube

Reply #1340
Hello good people, i'm new and noob for foobar and youtube and i hope i can get some help... I still getting 403 error from youtube not all videos some works... i tried updating user agent and it works for a day and stopped, then i set settings from "SergPuh.68" and it worked for a day then again stopped, i tried installing LAV Filters, set to external libcurl.dll, trying 3.6.1 - 3.7_beta, deleting cache folder... and still i now getting this error
"Unable to open item for playback (Youtube Source: ffmpeg: Server returned 403 Forbidden (access denied) |....."

Re: foo_youtube

Reply #1341
Hi :)
@minimi1

Reply #1334 Air KEN
https://hydrogenaud.io/index.php?topic=104379.msg991380#msg991380

Use Youtube Source 3.6.1 (foo_youtube.dll)

youtube-dl (youtube-dl.exe)
https://github.com/ytdl-org/youtube-dl/releases

C:\Windows\youtube-dl.exe
Double click

foobar2000 Preferences>Tool>Youtube Source>Maintenance tab>
Third-party Binaries>youtube-dl right click>System, Prefer youtube-dl over internal analyzer
SHURE SRH1840, SENNHEISER HD660S, Beyerdynamic DT 1990 PRO, HIFIMAN HE5se, Ultrasone Performance 880, AKG K712 PRO, Bowers & Wilkins P7, SONY MDR-1AM2, Bose QuietComfort 35 wireless, SENNHEISER HD 4.50BTNC (made a Upgrade/Balanced Cable by myself)

Re: foo_youtube

Reply #1342
^ Thank you Air KEN for helping me, after half hour i managed to fix by setting youtube-dl source to external and navigate to youtube-dl.exe :)

Re: foo_youtube

Reply #1343
Thank you 3dyd. Also, to posters who helped with the settings, I see that the 'auto-check for updates' (foo_acfu) help me with the component version numbers, too.  I had long ago wondered why there was no video capability in Foobar2K. The stern responses were: 'it's for audio'. Foo_youtube addresses that especially in how it not just links to a single file, but, how it allows for youtube playlists that expand in F2K. I've also added a video tab to my main window. 

Re: foo_youtube

Reply #1344
Hi there.

I'm using foo_youtube_3. 7_beta1 in latest foobar version.

Everything is working fine, except that thumbnails are not shown as Album Art. No one image is shown as "Album Art". I use all default settings.

How can I fix that? I would like to see a list with album arts in Facets.

Thanks in advance.

Re: foo_youtube

Reply #1345
Adil install the latest version of the Youtube Source 3.7 component In the component settings, check the use thumbnails as covers box.
YouTube Music

Re: foo_youtube

Reply #1346
@SergPuh.68

Thank you very much for your time!

I really did that, but neither SimplayList nor Facets show the artwork of the archives. I took a look at all the component settings and, as said before, everything is in the default. The component works correctly, it just doesn't display the artwork...

Re: foo_youtube

Reply #1347
Adil,when playing local files from your computer, are the covers displayed? Once again check the settings that are responsible for displaying covers.
YouTube Music

Re: foo_youtube

Reply #1348
@SergPuh.68

I followed your settings step by step and now it worked! It's working exactly as I wanted!

I cannot say precisely what was the determining configuration, but I believe that they were all equally responsible for it to work.

Thank you very much for your dedication here, I am very pleased and thankful for your support!

All the best to you!   ;)

Adil

Re: foo_youtube

Reply #1349
So, now I'm trying to download a video, but nothing happens.

This is the configuration I use in Run Services:

Code: [Select]
"C:\Plugins\Codecs\youtube-dl\youtube-dl.exe" -i  "%fy_url%" -o 'G:\%(title)s.%(ext)s'

Could someone please tell me what's wrong?

 
SimplePortal 1.0.0 RC1 © 2008-2021