Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: foo_youtube (Read 254518 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: foo_youtube

Reply #1276
I tried to add a "playlist", I did work with other playlist like 1-2 weeks ago. But I cant get this playlist to work.

I tried "Add location" "Add multiple URL's" and "Load channel or playlist" and none worked for me.
So Im assuming there is a difference between this URL and the others I I used, what do I need to change in this URL To make it import the entire playlist to foobar/YT playlist ?

https://www.youtube.com/watch?v=BR8HgdmVDwQ&list=PLhIzey5JOsYGtAVfgh69jRzPwbZ1o_jdD


Re: foo_youtube

Reply #1278
Search on YouTube has stopped working for playlists.


Re: foo_youtube

Reply #1280
You need to set Youtube API key on Maintenance tab if you don't enable "Prefer youtube-dl over internal analyzer" on youtube-dl, at least that what I can guess by unset the key and see the console.
Regarding search issue, try change to youtube.web if it was not because youtube.api needs key to be set.


Re: foo_youtube

Reply #1282
Hi! Just want to report that there is alot of  "403" now. :)

EDIT: ehm... fixed it self after restart of foobar :D

Re: foo_youtube

Reply #1283
Is there going to be an android youtube source component (or does one already exist)? I'd like to be able to put a whole youtube playlist in foobar2000 on my phone too if possible. Thanks in advance


Re: foo_youtube

Reply #1285
I tried "Add location" "Add multiple URL's" and "Load channel or playlist" and none worked for me.
Same here...
same here

still not working
Still working perfect on my side.

Did you follow the recommendations from arch21?
You need to set Youtube API key on Maintenance tab if you don't enable "Prefer youtube-dl over internal analyzer" on youtube-dl, at least that what I can guess by unset the key and see the console.

Re: foo_youtube

Reply #1286
I cant get this playlist to work.
Search on YouTube has stopped working for playlists.
Both can not be confirmed on my side:
I can load this playlist via File/Youtube Source/Load channel or playlist...  without problems.
Search of youtube playlists works as always.
Using foo_youtube 3.6.1
This option also does not work for me.
Using foo_youtube 3.6.1

Re: foo_youtube

Reply #1287
You need to set Youtube API key on Maintenance tab if you don't enable "Prefer youtube-dl over internal analyzer" on youtube-dl, at least that what I can guess by unset the key and see the console.
Regarding search issue, try change to youtube.web if it was not because youtube.api needs key to be set.

Where and how can I enable "Prefer youtube-dl over internal analyzer"?

Re: foo_youtube

Reply #1288
From Maintenance tab of Youtube Source preference, you will context menu when you right-click on youtube-dl. If you don't have youtube-dl binary, then you need to download it first. You can choose 'Managed', restart foobar2000, then you will additional option to download and update the binary. After finish downloading, enable that option. If still not working to you, try to get Youtube API key (there is a guide on developer site).

If you found more issue on this component, you could post console content, especially foo_youtube part to help.


Re: foo_youtube

Reply #1290
When a youtube track is already playing if I click on another youtube item in the playlist, foobar freezes for almost 5 mins. I am running on the latest foobar. foo_youtube settings are at their defaults.

I am using almost 20 other plugins, so I don't know if there is some conflict, but there are no errors in the console. Are you aware of any conflicts?

Any other reason?

That aside, its a beautiful plugin. I am amazed at the amount of features that you have built in.

Re: foo_youtube

Reply #1291
edit

Re: foo_youtube

Reply #1292
When a youtube track is already playing if I click on another youtube item in the playlist, foobar freezes for almost 5 mins. I am running on the latest foobar. foo_youtube settings are at their defaults.

I am using almost 20 other plugins, so I don't know if there is some conflict, but there are no errors in the console. Are you aware of any conflicts?

Any other reason?

That aside, its a beautiful plugin. I am amazed at the amount of features that you have built in.

it has nothing to do with the plugin,
it ist something wrong with your foobar setup

Re: foo_youtube

Reply #1293
The first time I found that foobar could play video. It's amazing.
I've used this plugin to play local video.
Can I load local subtitle files (such as .ass or .srt file) while I'm playing video ?
Can someone help me with my questions ?

Re: foo_youtube

Reply #1294
@3dyd, can I bother you a bit about `foo_youtube` implementation (non YT specific)? I'm implementing a similar component for Spotify, so I was hoping to skip some trial-error steps that you've surely went through during the course of `foo_youtube` development =)
I can use whatever means of contact you are comfortable with (i.e. here in the topic, PM, e-mail, instant messenger of some sort or w/e).

Re: foo_youtube

Reply #1295
Hi guys, new foobar user here. I tried to add both youtube api and youtube-dl (and setting to be prefered over internal analyser), but the component still only downloads 50 tracks. Is there a work around?

Re: foo_youtube

Reply #1296
No, that's a limit set by the search API and it's not possible to retrieve more than 50 videos per track. File>youtube Source>Load channel or playlist can load everything, though.

Re: foo_youtube

Reply #1297
No, that's a limit set by the search API and it's not possible to retrieve more than 50 videos per track. File>youtube Source>Load channel or playlist can load everything, though.
Wow thanks, thats awesome!

issue

Reply #1298
these menu items are mixed up
screenshot

clicking "по дате" (by date) you'll get a "по рейтингу" (by rating) sorting and so on.
QC Tester

Re: foo_youtube

Reply #1299
Many of the videos in my music playlist return a 403 when attempting to play them using foo_youtube, as of today. Mostly official music videos and videos generated by YouTube ('(Artist) - Topic'). They play just fine in my browser.

I cannot download these videos using youtube-dl either ('non-403' videos do work), so it seems to me this isn't necessarily a foo_youtube issue? FYI, youtube-dl gets redirected to https://www.youtube.com/yts/jsbin/player_ias-vfl_PLd61/en_US/base.js. Perhaps this has something to do with copyright?

I am using the latest version of foobar2000 and foo_youtube, attached to this message are the log contents after opening a 403 video.

@3dyd Having the exact same issue again with 3.6.1, youtube-dl still works though. Restarting foobar2000 resolved the issue.

 
SimplePortal 1.0.0 RC1 © 2008-2020