Skip to main content
Topic: foo_out_pulse - pulseaudio output (Read 1676 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: foo_out_pulse - pulseaudio output

Reply #25
If that works, is there any other output in the foobar console when it fails? Could you try with release 0.1 from github?

Thanks for the suggestion, but mpv also didn't work. I got this message: "[ao/pulse] The stream is suspended. Bailing out."

There probably is something wrong with my pulseaudio config, even though I didn't touch it before.

Re: foo_out_pulse - pulseaudio output

Reply #26
I just realised that you can use the pulse cookie to authenticate, you just need to copy or link it into your wine prefix. So you don't need to use the 'auth-ip-acl=' option in Pulseaudio's configuration, which is a bit much better from a security perspective. See the updated setup instructions in the readme

Re: foo_out_pulse - pulseaudio output

Reply #27
Try killing two modules in your system default.pa configuration, module-role-cork and module-suspend-on-idle, by commenting out the two modules. Then you can use "pacmd unload-module <module-name>" to unload those two modules from the current instance.

Re: foo_out_pulse - pulseaudio output

Reply #28
After some digging I was able to fix the issue. On my system there are two pulseaudio instances: one launched under my user and another for gdm. I had to disable the gdm instance and then I could connect via foobar2000.

The component works but unfortunately I still get some occasional audio pops when switching windows or desktops.

Re: foo_out_pulse - pulseaudio output

Reply #29
I still get some occasional audio pops when switching windows or desktops.

That's a very extreme version of that problem, does that happen with other apps or just foobar? Switching windows is a pretty lightweight activity

Re: foo_out_pulse - pulseaudio output

Reply #30
That's a very extreme version of that problem, does that happen with other apps or just foobar? Switching windows is a pretty lightweight activity

I happens only with foobar, but I guess it may be related to Wine. However, it's not constant. Sometimes the playback is flawless no matter what but other times it gets sensitive on CPU spikes it seems.

I saw similar reports of foobar audio issues under Wine and I was trying to find a way to bypass wineaudio or something. It's not so bad so I guess I can live with it.

Re: foo_out_pulse - pulseaudio output

Reply #31
The intention of this component was definitely to try and fix that. Wine does seem to have some problems with audio but this bypasses the normal wine audio stack completely. Of course there still could be problems but as long as foobar doesn't get hung up by Wine for longer than the buffer length, in theory there shouldn't be any dropouts, but clearly it's not helping as much as I hoped. You could try increasing the buffer in foobar's Output settings (as this directly controls the Pulseaudio buffer) and check how long the buffer is when it's playing something, running pactl list sink-inputs and looking for "Buffer Latency".

Another option to bypass Wine's audio stack is to use the UPnP media renderer output and have a receiver running on the same machine. The only downside is that visualisations won't work.

Re: foo_out_pulse - pulseaudio output

Reply #32
The intention of this component was definitely to try and fix that. Wine does seem to have some problems with audio but this bypasses the normal wine audio stack completely. Of course there still could be problems but as long as foobar doesn't get hung up by Wine for longer than the buffer length, in theory there shouldn't be any dropouts, but clearly it's not helping as much as I hoped. You could try increasing the buffer in foobar's Output settings (as this directly controls the Pulseaudio buffer) and check how long the buffer is when it's playing something, running pactl list sink-inputs and looking for "Buffer Latency".

Another option to bypass Wine's audio stack is to use the UPnP media renderer output and have a receiver running on the same machine. The only downside is that visualisations won't work.

I investigated the problem further. Indeed, it does NOT happen only with foobar but with any audio player! I listen mostly to foobar on this machine, so I assumed it was related to it.

So now to fix the general audio problem I found some suggestions to change scheduler settings in Pulseaudio. I tried and it seemed to have fixed the issue (so far). Even if it comes back, now I know where the problem might be. Thanks a lot for your help!

 

Re: foo_out_pulse - pulseaudio output

Reply #33
So now to fix the general audio problem I found some suggestions to change scheduler settings in Pulseaudio. I tried and it seemed to have fixed the issue (so far). Even if it comes back, now I know where the problem might be. Thanks a lot for your help!

Yep, changing the scheduler is necessary for me to get problem-free playback too. Glad it's working!

 
SimplePortal 1.0.0 RC1 © 2008-2020