Skip to main content
Topic: foobar2000 conversion speed 0.00x (Read 8694 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foobar2000 conversion speed 0.00x

Reply #27

I'm having the same problem with my new Intel build. Issues appear with WD Green 20EARX drive. I used WDIDLE tool soon after flawn was found in certain WD hard drives.

I have checked all the things mentioned in this thread, SMART, if caching is on, what's the mode (ACHI) etc, but so far I haven't been able to track down what exactly is the problem.

I'm using Windows 7 Pro and I'm starting to wonder if issue is somehow related to bug that caused disk write speeds to drop dramatically in Windows Vista and in certain cases Windows 7.

It's a long shot really, but I don't have much options left to consider.

My motherboard is Asus H87-Pro (rev 2).

foobar2000 conversion speed 0.00x

Reply #28
JamesHunt, it's a pain, I don't even convert much but you know, I want to make my money worth when I buy something. I am sure one day I'll change my system and I'll go back to FLAC and converting 30000 files like this...I can't even watch, I guess I'll do it overnight
I don't even want to spend more than the basic reliable enough drive since I don't use the PC much more than a storage machine.

If it can help you in any way, I just swapped the SATA Barracuda with the SATA WD Green (that I use for backup) and it slows down even earlier, ~10-15 files (the Barracuda ~20-50). I really think the processor is too fast for these basic drives, we should try with a WD RE or a Raptor etc.

foobar2000 conversion speed 0.00x

Reply #29
If it can help you in any way, I just swapped the SATA Barracuda with the SATA WD Green (that I use for backup) and it slows down even earlier, ~10-15 files (the Barracuda ~20-50). I really think the processor is too fast for these basic drives, we should try with a WD RE or a Raptor etc.

Sorry, but there is something seriously wrong with your computer. 

I just tried converting over 150 files to FLAC on an ST3000DM001 (the 3TB version of your drive) and it never dropped down close to 0.00x.  I also tried a 3TB WD Green which is on a crappy ASMedia controller with the same result.  My PC is faster than yours, the idea that the drive is too slow for a processor is just crazy.  A raptor or RE drive is not significantly faster and in many cases would be slower.  Your Seagate drive is equal in transfer rate to the best raptors which is what would matter when doing a single thread conversion, which you mentioned is a problem.  Even when I did an 8 thread conversion the drives did slow down, but not anywhere close to 0.00x. 

Did you use different SATA cables when you swapped drives?  Tried different SATA ports?

foobar2000 conversion speed 0.00x

Reply #30
I'll try a different cable and a different port tonight.

washu, what processor do you have?

Changed cable and port from SATA 3Gbps to SATA 6Gbps and it doesn't seem to slow down (no shit?), at least never to 0, it goes down a little. For some reason it was plugged in with the other port, probably because I've replaced the WD Green and forgot to change the cable and port.

foobar2000 conversion speed 0.00x

Reply #31
I've managed to slow it down to 0 with EZ CD Extractor, it was actually frozen for longer than before right now. Didn't slow down yet with foobar2000, the one I use anyway.

foobar2000 conversion speed 0.00x

Reply #32
You may have a cable issue.  Try using the good 6Gbps cable in a 3Gbps port.

Just a shot in the dark, but what power supply do you have?

I'm running an i7-4770K @ 4.6 GHz.  Except for the few who can clock it even higher, it's pretty much the fastest single thread conversion speed you can get. 

foobar2000 conversion speed 0.00x

Reply #33
The cable I'm using now is brand new from the ASUS box, 6Gbps cable. What benefit would I have plugging a 6Gbps drive in a 3Gbps port, buffering, caching?

I'll try later anyway.

foobar2000 conversion speed 0.00x

Reply #35
The fastest? It's the #30 in this list:

Notice I said "single thread".  Passmark uses all cores.  The top CPU on the list (Xeon E5-2697) has twelve cores, of course it will easily beat a 4 core CPU in a multi-threaded test.  However, it is only 2.7 GHz and a generation behind.  Per core it only gets a passmark score of 1594.  A 4770K gets a per core speed of 2582 and that is at stock speeds which mine is not.

I specifically tested a single thread to duplicate what you claimed to have done and eliminate disk seeking as a possible bottleneck.  A 4770K running a single thread will write data to the drive faster than your 2700K doing the same unless you have a crazy high overclock, which is ruled out by your motherboard.  That shows that the drive itself is not "too slow" as you had claimed as I never dropped even close to 0.00x.

foobar2000 conversion speed 0.00x

Reply #36
Perfect, good explanation. I used to know a lot about hardware and stay behind companies that make new products but I got lost while ago and didn't care nor need to update.

Thanks for your time, your time testing and your knowledge.

Still need to finish my first job then I'll get back and test that cable.

foobar2000 conversion speed 0.00x

Reply #37
Have you tried running Seatools (DOS version) and do an extensive test? It sounds like a defective drive.

Too much time, the Windows version of the software said the drive is perfectly fine. I think the PC is "too fast" for this drive.
Hence why I suggested to run the DOS one. Last time I tested it, the functionality wasn't identical. Also, short test won't do, it won't catch your slowdown issue because it happens after some time, not immediately. It's up to you though.

foobar2000 conversion speed 0.00x

Reply #38
Guys. I have 2x WD Greens on AMD 990FX with AMD PhII 1100T. With foobar I only use one of them. In the past I used the other one, results were mostly the same. Currently I can run 6 threads of wav-> flac conversion without problems - WD30EZRX is source of WAVs and destination of FLACs. That is 13 access operation at the same time (including playback in the background). Speed is like 120 - 180x with occasional drops to 50 (for less than 5 sec.).  But occasionally playback and animations (musical spectrum and peak/VU meter) start stuttering. And after some time (half a minute or sometimes nearly 1 minute) it goes away. When I try to make bigger load on this HDD (copying large amounts of files in explorer) I also sometimes have problems with playback (stuttering). My conclusion (done in other thread on this forum) is that WD Green drives are just relatively slow storage drives. Economic, ideal for just storing large amounts of data, but they aren't best performing drives. My drives had always quickly disabled Idle 3 mode (yes - disabled, not postponed to 5 mins) so it doesn't have impact on the drives in my case. Bear with it - WD Greens are worth their price. Never try to install any OS on them.
But anyway - in your case eahm I will suspect that some setting in BIOS is still wrong... Or it is just the problem with hardware - more likely chipset (like specific incompatibility) but maybe with HDD.

foobar2000 conversion speed 0.00x

Reply #39
I've tried the 6Gbps cable in the 3Gbps port and of course it's worse. It's working well right now but I still don't like it and since I've had a bad feeling from the first day I bought this drive I just ordered an ST3000DM001.

I'll update when I configure the new one, I will use this one as a second USB backup.

foobar2000 conversion speed 0.00x

Reply #40
Just got the drive, it's copying the data right now. Newegg is insane, delivered the next day with free 4-5 business days shipping.

foobar2000 conversion speed 0.00x

Reply #41
Things to check/try

- What kind of controller do you have the data drive connected to?  What mode is it in (IDE/AHCI/RAID)?

- Check the drive in device manager and make sure that it is in better performance mode and not quick removal mode.  Make sure write caching is turned on. 

- If you have any third party anti-virus or "security" software installed, UNINSTALL it.  Disabling is not good enough.

- Use the disk tab in resource monitor to see if anything besides the encoder and foobar are accessing the files.  Also check if the response time for the files is high.

- Check the drive with the Seagate testing tool (seatools).

It's not related to your issue, but your SSD is not a good one.  While it is not as bad as an OCZ, it is still near the top of crappy sandforce SSDs.  Make sure you take frequent backups.

SF crappy?? SandForce controllers embedded within any SSD really work flawlessly. Only thing i guess you will need to take care is to keep the controller firmware up to date & also SSD manufacturer firmware up to date as well. If this is taken care of, then trust me SandForce based controllers perform really well & can be really fast. i own one Samsung, and SF based -  Intel,OCZ, and V300.... haven't found any issues with other than that, OCZ needs to be updated the firmware.


foobar2000 conversion speed 0.00x

Reply #42
SF crappy?? SandForce controllers embedded within any SSD really work flawlessly.

As a byproduct, data that cannot readily be compressed (for example random data, encrypted files or partitions, compressed files, or many common audio and video file formats) is slower to write. ~

In 2012, SandForce SF-2000-based drives were discovered to only include AES-128 encryption instead of the advertised AES-256 encryption. It was speculated the lower grade encryption was used to qualify for US ITAR licences which are precluded for products featuring certain levels of encryption heading for a selected list of US-ambivalent or actively unfriendly countries. ~

It never hurts to investigate just a little ....
Quis custodiet ipsos custodes?  ;~)

SimplePortal 1.0.0 RC1 © 2008-2020