Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: MathAudio Room EQ for Foobar2000 (Read 64597 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: MathAudio Room EQ for Foobar2000

Reply #200
Also I can't use it with Cubase. If I use mathaudio as a system equalizer, it works if I play an audio file, but not with Cubase. if i load it as cubase vst plugin, it beeps even though i put the key code in the registry.
Hi Enri-audio, the registration button is located in the "About" dialog. If you have any other questions concerning the VST version of the plug-in, please contact us directly at https://mathaudio.com/contact.htm 

Re: MathAudio Room EQ for Foobar2000

Reply #201
News
New version released ( v2.7.7 ).
v2.7.7 uses newer versions of Foobar2000 SDK and Windows SDK.
Windows XP and Windows Vista are no longer supported.

Re: MathAudio Room EQ for Foobar2000

Reply #202
Hello @k2k,
thanks for the news!

However, I am not so expert on the matter of SDK and I would like to know what's the improvement achieved?
I mean, I am running Foobar on Windows 10, and does this v 2.7.7 run better? Less memory usage? Less CPU load?

If I am happy with the v 2.7.6, why I should upgrade it?
Thanks and regards, Andrea

 

Re: MathAudio Room EQ for Foobar2000

Reply #203
Hello @k2k,
thanks for the news!

However, I am not so expert on the matter of SDK and I would like to know what's the improvement achieved?
I mean, I am running Foobar on Windows 10, and does this v 2.7.7 run better? Less memory usage? Less CPU load?

If I am happy with the v 2.7.6, why I should upgrade it?
Thanks and regards, Andrea
Hello Andrea,
v2.7.7 is compiled with a newer compiler which knows and uses the advantages of the latest types of CPU. Most probably v2.7.7 puts less load on the CPU if you use a last-generation CPU chip, though we did not make such measurements. We updated the plug-in to make it more compatible with future releases of Windows and Foobar2000. We wish to be sure that the plug-in will not stop working after the next Windows update. Our previous ten-years-old compiler was optimized for Windows XP and nobody guarantees its compatibility with future updates of Windows 10. That is why we decided to move to a newer technology.
The new version of Room EQ doesn't bring any changes in the sound, so there are no urgent reasons to upgrade.

Re: MathAudio Room EQ for Foobar2000

Reply #204
Hi, any idea why the measurement sweep signal sounds crackling if Windows default format set on 48 kHz and no crackling on 44.1 kHz using Lexicon Alpha? (I want to show it with a screen recording, but in that no crackling.)

Re: MathAudio Room EQ for Foobar2000

Reply #205
Hi, any idea why the measurement sweep signal sounds crackling if Windows default format set on 48 kHz and no crackling on 44.1 kHz using Lexicon Alpha? (I want to show it with a screen recording, but in that no crackling.)

Nothing matters, either (now default) WASAPI shared or exclusive output used, as soon as the Room Measurement radio button selected the system sounds distorted (with 48 kHz default formats) or noisy even without playback (with 16 bit default formats). The only usable setting is 24 bit and 44.1 kHz.
Standard USB audio device drivers used by Windows 10 for Lexicon Alpha.

Re: MathAudio Room EQ for Foobar2000

Reply #206
Just out of curiosity (because it's a obsolete HW) I tested (v2.7.7) with my workplace PC's VT1705 VIA codec and even the Start Measurement button not working (foobar v1.6.1 default - WASAPI shared - output).

Re: MathAudio Room EQ for Foobar2000

Reply #207
Hi, any idea why the measurement sweep signal sounds crackling if Windows default format set on 48 kHz and no crackling on 44.1 kHz using Lexicon Alpha? (I want to show it with a screen recording, but in that no crackling.)
I don't know the reason of this problem, but the accuracy of measurement doesn't depend on the sampling rate. You can safely use 44.1 kHz for measurement.

Re: MathAudio Room EQ for Foobar2000

Reply #208
Just out of curiosity (because it's a obsolete HW) I tested (v2.7.7) with my workplace PC's VT1705 VIA codec and even the Start Measurement button not working (foobar v1.6.1 default - WASAPI shared - output).
Click the "In/Out" button and select the necessary audio output. Make sure that nothing takes exclusive control of the audio device's driver (including Foobar2000).

Re: MathAudio Room EQ for Foobar2000

Reply #209
I don't know the reason of this problem, but the accuracy of measurement doesn't depend on the sampling rate. You can safely use 44.1 kHz for measurement.

Yes, fortunately accuracy not affected, and at least one default format still works. The whole thing just occurred in the first place because with this device the Windows default is 24/48. It's only a suspicion that one reason might be the rework for the new foobar (beside driver or HW reasons), but without previous version I cannot test this.

Re: MathAudio Room EQ for Foobar2000

Reply #210
Yes, fortunately accuracy not affected, and at least one default format still works. The whole thing just occurred in the first place because with this device the Windows default is 24/48. It's only a suspicion that one reason might be the rework for the new foobar (beside driver or HW reasons), but without previous version I cannot test this.
Most probably this is a driver problem. If you set your audio card to the default sampling rate of 48 kHz, the audio player should be able to switch it to 44.1 kHz when necessary. If the driver doesn't allow switching the sampling rate, it may result in the "crackling". Try to find and install the latest driver for your audio interface. If the driver is not designed specifically for your version of Windows, it is better to set it to the default frequency of 44.1 kHz because 44.1 kHz is the sampling rate of majority of audio files in existence. You can check your audio driver like follows. Set the audio driver to 48 kHz, remove Room EQ from Foobar2000, switch Foobar2000 to a conventional audio driver (not WASAPI) and try to play a conventional audio file with the sampling frequency of 44.1 kHz. If you hear the "crackling", most probably this is a driver problem.

Re: MathAudio Room EQ for Foobar2000

Reply #211
I've just found out that Foobar2000 v1.6.1 uses a new default WASAPI output, so you cannot use it to test DirectSoud drivers. In any case I think that the problem is caused by the audio driver. A lot of audio cards have problems with automatic sample rate switching. This is not a large problem because you can manually set your card to 44.1 kHz for the measurement.

Re: MathAudio Room EQ for Foobar2000

Reply #212
I've just found out that Foobar2000 v1.6.1 uses a new default WASAPI output, so you cannot use it to test DirectSoud drivers. In any case I think that the problem is caused by the audio driver. A lot of audio cards have problems with automatic sample rate switching. This is not a large problem because you can manually set your card to 44.1 kHz for the measurement.
Yes that's what I wanted to emphasize. But I wrongly misinterpreted in your latest change log that foobar's change to WASAPI shared output is one reason for the modernization of the latest version. And that's why I maintained the possibility that Room EQ device access through foobar might be one reason. The driver is the latest, but as I found out only the USB device node using manufacturer components. There is no problem when I play 44.1/48 kHz sources with WASAPI exclusive which demands sample rate change from the device. Anyway, thanks a lot. If I want, I will do DirectSound tests with previous foobar version, and next week I hope I can start the measurements and corrections with your free plugin which I very much appreciate.

Re: MathAudio Room EQ for Foobar2000

Reply #213
foobar2000 1.6.2 fixed the problem most likely with this: "Added workarounds for wrong audio mix format reported by certain buggy soundcard drivers. (beta 3, beta 4)". Room EQ does an awesome job with cleaning my most compromised 100-500 Hz range.

 
SimplePortal 1.0.0 RC1 © 2008-2020